aboutsummaryrefslogtreecommitdiff
path: root/games/pyspacewar/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/pyspacewar/Makefile')
-rw-r--r--games/pyspacewar/Makefile45
1 files changed, 20 insertions, 25 deletions
diff --git a/games/pyspacewar/Makefile b/games/pyspacewar/Makefile
index 9ffca64b7ce1..387e6b4dbd4c 100644
--- a/games/pyspacewar/Makefile
+++ b/games/pyspacewar/Makefile
@@ -2,53 +2,48 @@
# $FreeBSD$
PORTNAME= pyspacewar
-PORTVERSION= 0.9.7
-PORTREVISION= 4
+PORTVERSION= 0.9.8
CATEGORIES= games python
-MASTER_SITES= http://mg.pov.lt/${PORTNAME}/\
- LOCAL/beech
DIST_SUBDIR= python
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Two ships duel in a gravity field
+MAINTAINER= nemysis@FreeBSD.org
+COMMENT= Game loosely based on the original Spacewar!
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/GPL.txt
RUN_DEPENDS= ${PYGAME}
+USE_GITHUB= yes
+GH_ACCOUNT= mgedmin
+GH_PROJECT= ${PORTNAME}
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= 2d058b1
+
USES= python
USE_PYTHON= distutils autoplist
-PLIST_FILES= share/icons/hicolor/16x16/apps/pyspacewar.png \
- share/icons/hicolor/22x22/apps/pyspacewar.png \
- share/icons/hicolor/32x32/apps/pyspacewar.png \
- share/icons/hicolor/48x48/apps/pyspacewar.png \
- share/pixmaps/${PORTNAME}.png
-
-PORTDOCS= NEWS.txt README.txt performance-notes.txt
+PORTDOCS= *.rst
OPTIONS_DEFINE= DOCS
INSTALLS_ICONS= yes
-ICON_SIZES= 16x16 22x22 32x32 48x48
DESKTOP_ENTRIES="PySpaceWar" "" ${PORTNAME} \
"${PORTNAME}" "Game;ArcadeGame;" ""
-post-patch:
-.for s in 16 22 32 48
- @cd ${WRKSRC}/src/pyspacewar/icons && \
- ${MV} ${PORTNAME}${s}.png ${PORTNAME}_${s}x${s}.png
-.endfor
-
post-install:
-.for s in ${ICON_SIZES}
- @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps
- ${INSTALL_DATA} ${WRKSRC}/src/pyspacewar/icons/${PORTNAME}_${s}.png \
- ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
+.for i in 16 22 32 48
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${i}x${i}/apps
+ ${INSTALL_DATA} ${WRKSRC}/src/pyspacewar/icons/${PORTNAME}${i}.png \
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/${i}x${i}/apps/${PORTNAME}.png
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps
+ ${INSTALL_DATA} ${WRKSRC}/src/pyspacewar/icons/${PORTNAME}${i}.svg \
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps/${PORTNAME}${i}.svg
.endfor
+# Symlink icon which is needed that PySpaceWar works
+ @${MKDIR} ${STAGEDIR}${PYTHON_SITELIBDIR}/${PORTNAME}/icons
${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
- ${STAGEDIR}${PREFIX}/share/pixmaps/
+ ${STAGEDIR}${PYTHON_SITELIBDIR}/${PORTNAME}/icons/${PORTNAME}48.png
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}