aboutsummaryrefslogtreecommitdiff
path: root/games/quake3/files/patch-code-unix-Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/quake3/files/patch-code-unix-Makefile')
-rw-r--r--games/quake3/files/patch-code-unix-Makefile74
1 files changed, 41 insertions, 33 deletions
diff --git a/games/quake3/files/patch-code-unix-Makefile b/games/quake3/files/patch-code-unix-Makefile
index 9b6a16757899..6d2d8b31dc2c 100644
--- a/games/quake3/files/patch-code-unix-Makefile
+++ b/games/quake3/files/patch-code-unix-Makefile
@@ -1,5 +1,5 @@
---- code/unix/Makefile.orig Thu May 25 16:59:37 2006
-+++ code/unix/Makefile Thu May 25 17:04:46 2006
+--- ./code/unix/Makefile.orig Wed May 31 18:55:11 2006
++++ ./code/unix/Makefile Wed May 31 18:55:13 2006
@@ -19,6 +19,7 @@
PLATFORM=$(shell uname|tr A-Z a-z)
@@ -67,8 +67,14 @@
GLLDFLAGS=-L/usr/X11R6/lib -lX11 -lXext -lXxf86dga -lXxf86vm
ifeq ($(ARCH),axp)
-@@ -199,31 +200,27 @@
+@@ -197,33 +198,35 @@
+ ifeq ($(PLATFORM),freebsd)
+
++ifeq ($(ARCH),powerpc)
++ARCH=ppc
++endif
++
GLIBC= #libc is irrelevant
-ifneq (,$(findstring alpha,$(shell uname -m)))
@@ -108,7 +114,9 @@
-CC=$(shell if [ -f $(NEWPGCC) ]; then echo $(NEWPGCC); else echo pgcc; fi )
-RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG -O6 -mcpu=pentiumpro -march=pentium -fomit-frame-pointer -pipe -ffast-math -malign-loops=2 -malign-jumps=2 -malign-functions=2 -fno-strict-aliasing - fstrength-reduce
+ifneq ($(ARCH),i386)
++ ifneq ($(ARCH),ppc)
+DLL_ONLY=true
++ endif
+endif
+
+ifeq ($(DLL_ONLY),true)
@@ -116,7 +124,7 @@
endif
LIBEXT=a
-@@ -235,25 +232,37 @@
+@@ -235,25 +238,37 @@
ARFLAGS=ar rv
RANLIB=ranlib
@@ -169,7 +177,7 @@
endif
else # ifeq freebsd
-@@ -283,7 +292,7 @@
+@@ -283,7 +298,7 @@
ARFLAGS=ar rv
RANLIB=ranlib
@@ -178,7 +186,7 @@
GLLDFLAGS=-L/usr/X11/lib -lGL -lX11 -lXext -lm
TARGETS=$(B)/sgiquake3 \
-@@ -310,9 +319,9 @@
+@@ -310,9 +325,9 @@
RANLIB=ranlib
ifeq ($(PLATFORM),freebsd)
@@ -190,7 +198,7 @@
endif # ifeq freebsd
TARGETS=\
-@@ -348,7 +357,7 @@
+@@ -348,7 +363,7 @@
$(MAKE) targets B=$(BR) CFLAGS="$(RELEASE_CFLAGS)"
#Build both debug and release builds
@@ -199,7 +207,7 @@
targets:makedirs $(TARGETS)
-@@ -516,20 +525,6 @@
+@@ -516,20 +531,6 @@
$(B)/client/unix_net.o \
$(B)/client/unix_shared.o \
\
@@ -220,7 +228,7 @@
# $(B)/client/q_parse.o \
# $(B)/client/math_quaternion.o \
# $(B)/client/util_str.o \
-@@ -541,7 +536,9 @@
+@@ -541,7 +542,9 @@
# $(B)/client/q_shared.o \
ifeq ($(ARCH),i386)
@@ -231,12 +239,15 @@
endif
ifeq ($(ARCH),ppc)
-@@ -559,10 +556,24 @@
+@@ -559,10 +562,24 @@
$(B)/client/linux_qgl.o \
$(B)/client/linux_glimp.o \
$(B)/client/linux_snd.o \
+ $(B)/client/linux_signals.o \
-+ $(B)/client/snd_mixa.o \
+ $(B)/client/snd_mixa.o \
+- $(B)/client/matha.o \
+- $(B)/client/ftol.o \
+- $(B)/client/snapvector.o
+ $(B)/client/matha.o
+
+ Q3POBJ_SMP=\
@@ -245,10 +256,7 @@
+ $(B)/client/linux_glimp_smp.o \
+ $(B)/client/linux_snd.o \
+ $(B)/client/linux_signals.o \
- $(B)/client/snd_mixa.o \
-- $(B)/client/matha.o \
-- $(B)/client/ftol.o \
-- $(B)/client/snapvector.o
++ $(B)/client/snd_mixa.o \
+ $(B)/client/matha.o
+
+ ifeq ($(ARCH),i386)
@@ -259,7 +267,7 @@
else
ifeq ($(PLATFORM),irix)
Q3POBJ=\
-@@ -578,7 +589,6 @@
+@@ -578,7 +595,6 @@
$(B)/client/linux_common.o \
$(B)/client/linux_qgl.o \
$(B)/client/linux_glimp.o \
@@ -267,7 +275,7 @@
$(B)/client/linux_snd.o \
$(B)/client/snd_mixa.o \
$(B)/client/matha.o \
-@@ -587,7 +597,6 @@
+@@ -587,7 +603,6 @@
$(B)/client/linux_common.o \
$(B)/client/linux_qgl.o \
$(B)/client/linux_glimp_smp.o \
@@ -275,7 +283,7 @@
$(B)/client/linux_snd.o \
$(B)/client/snd_mixa.o \
$(B)/client/matha.o
-@@ -602,12 +611,12 @@
+@@ -602,12 +617,12 @@
endif #FreeBSD
endif #IRIX
@@ -290,7 +298,7 @@
$(CC) -o $@ $(Q3OBJ) $(Q3POBJ_SMP) $(GLLDFLAGS) \
$(THREAD_LDFLAGS) $(LDFLAGS)
-@@ -754,10 +763,10 @@
+@@ -754,10 +769,10 @@
$(B)/client/linux_common.o : $(UDIR)/linux_common.c; $(DO_CC)
$(B)/client/linux_glimp.o : $(UDIR)/linux_glimp.c; $(DO_CC) $(GL_CFLAGS)
$(B)/client/linux_glimp_smp.o : $(UDIR)/linux_glimp.c; $(DO_SMP_CC) $(GL_CFLAGS)
@@ -302,7 +310,7 @@
$(B)/client/snd_mixa.o : $(UDIR)/snd_mixa.s; $(DO_AS)
$(B)/client/matha.o : $(UDIR)/matha.s; $(DO_AS)
-@@ -912,13 +921,17 @@
+@@ -912,13 +927,17 @@
$(B)/ded/unix_main.o \
$(B)/ded/unix_net.o \
$(B)/ded/unix_shared.o \
@@ -321,7 +329,7 @@
endif
ifeq ($(ARCH),ppc)
-@@ -927,7 +940,7 @@
+@@ -927,7 +946,7 @@
endif
endif
@@ -330,7 +338,7 @@
$(CC) -o $@ $(Q3DOBJ) $(LDFLAGS)
$(B)/ded/sv_bot.o : $(SDIR)/sv_bot.c; $(DO_DED_CC)
-@@ -988,6 +1001,7 @@
+@@ -988,6 +1007,7 @@
$(B)/ded/unix_main.o : $(UDIR)/unix_main.c; $(DO_DED_CC)
$(B)/ded/unix_net.o : $(UDIR)/unix_net.c; $(DO_DED_CC)
$(B)/ded/unix_shared.o : $(UDIR)/unix_shared.c; $(DO_DED_CC)
@@ -338,7 +346,7 @@
$(B)/ded/null_client.o : $(NDIR)/null_client.c; $(DO_DED_CC)
$(B)/ded/null_input.o : $(NDIR)/null_input.c; $(DO_DED_CC)
$(B)/ded/null_snddma.o : $(NDIR)/null_snddma.c; $(DO_DED_CC)
-@@ -1068,7 +1082,7 @@
+@@ -1068,7 +1088,7 @@
$(B)/baseq3/cgame/q_math.o \
$(B)/baseq3/cgame/q_shared.o
@@ -347,7 +355,7 @@
$(CC) $(SHLIBLDFLAGS) -o $@ $(Q3CGOBJ)
$(B)/baseq3/cgame/bg_misc.o : $(GDIR)/bg_misc.c; $(DO_SHLIB_CC)
-@@ -1128,7 +1142,7 @@
+@@ -1128,7 +1148,7 @@
$(B)/missionpack/cgame/q_shared.o \
$(B)/missionpack/cgame/ui_shared.o
@@ -356,7 +364,7 @@
$(CC) $(SHLIBLDFLAGS) -o $@ $(MPCGOBJ)
$(B)/missionpack/cgame/bg_misc.o : $(GDIR)/bg_misc.c; $(DO_SHLIB_CC) -DMISSIONPACK
-@@ -1200,7 +1214,7 @@
+@@ -1200,7 +1220,7 @@
$(B)/baseq3/game/q_math.o \
$(B)/baseq3/game/q_shared.o
@@ -365,7 +373,7 @@
$(CC) $(SHLIBLDFLAGS) -o $@ $(Q3GOBJ)
$(B)/baseq3/game/ai_chat.o : $(GDIR)/ai_chat.c; $(DO_SHLIB_CC)
-@@ -1278,7 +1292,7 @@
+@@ -1278,7 +1298,7 @@
$(B)/missionpack/game/q_math.o \
$(B)/missionpack/game/q_shared.o
@@ -374,7 +382,7 @@
$(CC) $(SHLIBLDFLAGS) -o $@ $(MPGOBJ)
$(B)/missionpack/game/ai_chat.o : $(GDIR)/ai_chat.c; $(DO_SHLIB_CC) -DMISSIONPACK
-@@ -1367,7 +1381,7 @@
+@@ -1367,7 +1387,7 @@
$(B)/baseq3/ui/q_math.o \
$(B)/baseq3/ui/q_shared.o
@@ -383,7 +391,7 @@
$(CC) $(CFLAGS) $(SHLIBLDFLAGS) -o $@ $(Q3UIOBJ)
$(B)/baseq3/ui/bg_misc.o : $(GDIR)/bg_misc.c; $(DO_SHLIB_CC)
-@@ -1410,7 +1424,7 @@
+@@ -1410,7 +1430,7 @@
$(B)/baseq3/ui/ui_startserver.o : $(Q3UIDIR)/ui_startserver.c; $(DO_SHLIB_CC)
$(B)/baseq3/ui/ui_team.o : $(Q3UIDIR)/ui_team.c; $(DO_SHLIB_CC)
$(B)/baseq3/ui/ui_teamorders.o : $(Q3UIDIR)/ui_teamorders.c; $(DO_SHLIB_CC)
@@ -392,7 +400,7 @@
$(B)/baseq3/ui/ui_video.o : $(Q3UIDIR)/ui_video.c; $(DO_SHLIB_CC)
# bk001205 - these wre the only SHLIB compiles in 1.17
-@@ -1450,7 +1464,7 @@
+@@ -1450,7 +1470,7 @@
# $(B)/missionpack/ui/q_math.o \
# $(B)/missionpack/ui/q_shared.o
@@ -401,7 +409,7 @@
$(CC) $(CFLAGS) $(SHLIBLDFLAGS) -o $@ $(MPUIOBJ)
$(B)/missionpack/ui/ui_atoms.o : $(UIDIR)/ui_atoms.c; $(DO_SHLIB_CC) -DMISSIONPACK
-@@ -1613,23 +1627,8 @@
+@@ -1613,23 +1633,8 @@
$(B)/q3static/unix_net.o \
$(B)/q3static/unix_shared.o \
\
@@ -425,7 +433,7 @@
$(B)/q3static/linux_snd.o \
$(B)/q3static/snd_mixa.o \
$(B)/q3static/matha.o
-@@ -1779,7 +1778,6 @@
+@@ -1779,7 +1784,6 @@
$(B)/q3static/unix_net.o : $(UDIR)/unix_net.c; $(DO_CC) -DQ3_STATIC
$(B)/q3static/unix_shared.o : $(UDIR)/unix_shared.c; $(DO_CC) -DQ3_STATIC
$(B)/q3static/linux_glimp.o : $(UDIR)/linux_glimp.c; $(DO_CC) -DQ3_STATIC
@@ -433,7 +441,7 @@
$(B)/q3static/linux_qgl.o : $(UDIR)/linux_qgl.c; $(DO_CC) -DQ3_STATIC
$(B)/q3static/linux_input.o : $(UDIR)/linux_input.c; $(DO_CC) -DQ3_STATIC
$(B)/q3static/linux_snd.o : $(UDIR)/linux_snd.c; $(DO_CC) -DQ3_STATIC
-@@ -2020,7 +2018,7 @@
+@@ -2020,7 +2024,7 @@
@@ -442,7 +450,7 @@
$(CC) $(CFLAGS) -o $@ $(Q3SOBJ) $(GLLDFLAGS) $(LDFLAGS)
-@@ -2059,9 +2057,9 @@
+@@ -2059,9 +2063,9 @@
copyfiles:
-mkdirhier $(COPYDIR)