aboutsummaryrefslogtreecommitdiff
path: root/games/qudos
diff options
context:
space:
mode:
Diffstat (limited to 'games/qudos')
-rw-r--r--games/qudos/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/games/qudos/Makefile b/games/qudos/Makefile
index cd15f9899eda..8cc570566b8c 100644
--- a/games/qudos/Makefile
+++ b/games/qudos/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qudos
PORTVERSION= 0.40.1
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= games
MASTER_SITES= http://qudos.quakedev.com/linux/quake2/engines/QuDos/
DISTNAME= QuDos-${PORTVERSION}-src
@@ -67,7 +67,7 @@ PLIST_SUB+= ${mod}="@comment "
.if !defined(WITHOUT_GLX) || !defined(WITHOUT_SDLGL)
USE_GL= yes
-LIB_DEPENDS+= jpeg.10:${PORTSDIR}/graphics/jpeg \
+LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png
.endif
@@ -183,6 +183,11 @@ MAKE_ENV+= WITH_X86_ASM=YES
MAKE_ENV+= WITH_X86_ASM=NO
.endif
+post-patch:
+# Resolve name collision with jpeg-8
+ ${REINPLACE_CMD} -e 's|jpeg_mem_src|local_jpeg_mem_src|' \
+ ${WRKSRC}/src/ref_gl/gl_image.c
+
post-build:
.for bin in ${Q2BIN}
@cd ${WRKSRC}/quake2 && ${MV} ${bin:S/qudos/QuDos/} ${bin}