aboutsummaryrefslogtreecommitdiff
path: root/games/redeclipse
diff options
context:
space:
mode:
Diffstat (limited to 'games/redeclipse')
-rw-r--r--games/redeclipse/Makefile73
-rw-r--r--games/redeclipse/distinfo3
-rw-r--r--games/redeclipse/files/bfclient.in18
-rw-r--r--games/redeclipse/files/bfserver.in18
-rw-r--r--games/redeclipse/files/patch-src_Makefile19
-rw-r--r--games/redeclipse/files/pkg-message.in11
-rw-r--r--games/redeclipse/pkg-descr6
7 files changed, 0 insertions, 148 deletions
diff --git a/games/redeclipse/Makefile b/games/redeclipse/Makefile
deleted file mode 100644
index a0fed6fe9ce6..000000000000
--- a/games/redeclipse/Makefile
+++ /dev/null
@@ -1,73 +0,0 @@
-# New ports collection makefile for: sauerbraten
-# Date created: 2006-02-01
-# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
-#
-# $FreeBSD$
-#
-
-PORTNAME= bloodfrontier
-DISTVERSION= B2
-PORTREVISION= 2
-CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/Blood%20Frontier/Blood%20Frontier%20Beta%202
-DISTNAME= ${PORTNAME}-${DISTVERSION}-linux
-
-MAINTAINER= amdmi3@FreeBSD.org
-COMMENT= Single- and multi-player first-person shooter based on Cube 2
-
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-USE_BZIP2= yes
-CONFIGURE_WRKSRC= ${WRKSRC}/src/enet
-BUILD_WRKSRC= ${WRKSRC}/src
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
-ALL_TARGET= libenet ${BINARIES}
-MAKE_JOBS_SAFE= yes
-
-SUB_FILES= bfclient bfserver pkg-message
-
-OPTIONS= CLIENT "Build client" on \
- DEDICATED "Build dedicated server" on
-
-.include <bsd.port.options.mk>
-
-.if ${ARCH} == "sparc64"
-BROKEN= does not build on sparc64
-.endif
-
-.if defined(WITHOUT_CLIENT) && defined(WITHOUT_DEDICATED)
-IGNORE= needs at least one executable (CLIENT or DEDICATED)
-.endif
-
-.if !defined(WITHOUT_CLIENT)
-USE_GL= yes
-USE_SDL= image mixer sdl
-PLIST_FILES+= bin/bfclient libexec/bfclient
-BINARIES+= client
-.endif
-
-.if !defined(WITHOUT_DEDICATED)
-PLIST_FILES+= bin/bfserver libexec/bfserver
-BINARIES+= server
-.endif
-
-do-install:
-.for f in ${BINARIES}
- ${INSTALL_SCRIPT} ${WRKDIR}/bf${f} ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/bf${f} ${PREFIX}/libexec
-.endfor
- ${MKDIR} ${DATADIR}
- cd ${WRKSRC}/data && ${COPYTREE_SHARE} "." ${DATADIR}/
-
-post-install:
- @${FIND} ${DATADIR} -type f | \
- ${SED} -e 's|^${PREFIX}/||' >> ${TMPPLIST}
- @${FIND} ${DATADIR} -type d | ${SORT} -r | \
- ${SED} -e 's|^${PREFIX}/|@dirrm |' >> ${TMPPLIST}
-
- @${ECHO_CMD}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_CMD}
-
-.include <bsd.port.mk>
diff --git a/games/redeclipse/distinfo b/games/redeclipse/distinfo
deleted file mode 100644
index 69b647527760..000000000000
--- a/games/redeclipse/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (bloodfrontier-B2-linux.tar.bz2) = 814df812d14714687f44085c83d5b91b
-SHA256 (bloodfrontier-B2-linux.tar.bz2) = e05e7e18661d906fc0685c72704493fe8a8bbd0b803747ceaf4038527f957b58
-SIZE (bloodfrontier-B2-linux.tar.bz2) = 417998023
diff --git a/games/redeclipse/files/bfclient.in b/games/redeclipse/files/bfclient.in
deleted file mode 100644
index 01d3b7ef4949..000000000000
--- a/games/redeclipse/files/bfclient.in
+++ /dev/null
@@ -1,18 +0,0 @@
-#!/bin/sh
-
-# The executable needs to be run from its data directory, and needs to store
-# configuration in it. We therefore mirror the data directory hierarchy in
-# ~/.bloodfrontier, and create symlinks to the data files.
-
-if [ -d ~/.bloodfrontier ]
-then
- echo "Using existing ~/.bloodfrontier directory."
-else
- echo "Creating ~/.bloodfrontier directory."
- cd %%DATADIR%% || exit 1
- find * -type d -exec mkdir -p ~/.bloodfrontier/{} \;
- find * -type f -exec ln -s %%DATADIR%%/{} ~/.bloodfrontier/{} \; 2>/dev/null
-fi
-
-cd ~/.bloodfrontier || exit 1
-exec %%PREFIX%%/libexec/bfclient "$@"
diff --git a/games/redeclipse/files/bfserver.in b/games/redeclipse/files/bfserver.in
deleted file mode 100644
index 6f15e12a2bd0..000000000000
--- a/games/redeclipse/files/bfserver.in
+++ /dev/null
@@ -1,18 +0,0 @@
-#!/bin/sh
-
-# The executable needs to be run from its data directory, and needs to store
-# configuration in it. We therefore mirror the data directory hierarchy in
-# ~/.bloodfrontier, and create symlinks to the data files.
-
-if [ -d ~/.bloodfrontier ]
-then
- echo "Using existing ~/.bloodfrontier directory."
-else
- echo "Creating ~/.bloodfrontier directory."
- cd %%DATADIR%% || exit 1
- find * -type d -exec mkdir -p ~/.bloodfrontier/{} \;
- find * -type f -exec ln -s %%DATADIR%%/{} ~/.bloodfrontier/{} \; 2>/dev/null
-fi
-
-cd ~/.bloodfrontier || exit 1
-exec %%PREFIX%%/libexec/bfserver "$@"
diff --git a/games/redeclipse/files/patch-src_Makefile b/games/redeclipse/files/patch-src_Makefile
deleted file mode 100644
index c7f5e89d57ac..000000000000
--- a/games/redeclipse/files/patch-src_Makefile
+++ /dev/null
@@ -1,19 +0,0 @@
---- src/Makefile.orig 2009-11-25 14:52:58.000000000 +0300
-+++ src/Makefile 2009-12-17 00:09:47.000000000 +0300
-@@ -1,5 +1,4 @@
- #CXXFLAGS= -ggdb3
--CXXFLAGS= -O3 -fomit-frame-pointer
- override CXXFLAGS+= -Wall -fsigned-char
-
- PLATFORM= $(shell uname -s)
-@@ -21,8 +20,8 @@
- CLIENT_INCLUDES= -DINTERFACE -DIRC $(INCLUDES) -Iinclude
- CLIENT_LIBS= -mwindows -lmingw32 -Llib -lSDLmain -lSDL -lSDL_image -lSDL_mixer -lzdll -lopengl32 -lenet -lws2_32 -lwinmm
- else
--CLIENT_INCLUDES= -DINTERFACE -DIRC $(INCLUDES) -I/usr/X11R6/include `sdl-config --cflags`
--CLIENT_LIBS= -Lenet -lenet -L/usr/X11R6/lib `sdl-config --libs` -lSDL_image -lSDL_mixer -lz -lGL
-+CLIENT_INCLUDES= -DINTERFACE -DIRC $(INCLUDES) -I${LOCALBASE}/include `${SDL_CONFIG} --cflags`
-+CLIENT_LIBS= -Lenet -lenet -L${LOCALBASE}/lib `${SDL_CONFIG} --libs` -lSDL_image -lSDL_mixer -lz -lGL
- endif
- ifeq ($(PLATFORM),Linux)
- CLIENT_LIBS+= -lrt
diff --git a/games/redeclipse/files/pkg-message.in b/games/redeclipse/files/pkg-message.in
deleted file mode 100644
index 3bc3f84a8629..000000000000
--- a/games/redeclipse/files/pkg-message.in
+++ /dev/null
@@ -1,11 +0,0 @@
-###############################################################################
-
-1) First time, bloodfrontier creates a ~/.bloodfrontier directory with symlinks.
-2) Config files are in the ~/.bloodfrontier directory.
-3) If you want add new bindings into ~/.bloodfrontier/config.cfg, see
-
- %%DATADIR%%/data/keymap.cfg.
-
-4) Enjoy it ;)
-
-###############################################################################
diff --git a/games/redeclipse/pkg-descr b/games/redeclipse/pkg-descr
deleted file mode 100644
index 5a1891fcb570..000000000000
--- a/games/redeclipse/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-Single-player and multi-player first-person shooter, built as a
-total conversion of Cube Engine 2, which lends itself toward a
-balanced gameplay, completely at the control of map makers, while
-maintaining a general theme of tactics and low gravity.
-
-WWW: http://www.bloodfrontier.com/