aboutsummaryrefslogtreecommitdiff
path: root/games/robocode
diff options
context:
space:
mode:
Diffstat (limited to 'games/robocode')
-rw-r--r--games/robocode/Makefile2
-rw-r--r--games/robocode/files/robocode-MeleeRumble.in2
-rw-r--r--games/robocode/files/robocode-RoboRumble.in2
-rw-r--r--games/robocode/files/robocode-Robocode.in2
-rw-r--r--games/robocode/files/robocode-TeamRumble.in2
-rw-r--r--games/robocode/files/robocode-TwinDuel.in2
6 files changed, 1 insertions, 11 deletions
diff --git a/games/robocode/Makefile b/games/robocode/Makefile
index e87d3327bbb9..a2902eba382a 100644
--- a/games/robocode/Makefile
+++ b/games/robocode/Makefile
@@ -3,6 +3,7 @@
PORTNAME= robocode
PORTVERSION= 1.9.3.7
+PORTREVISION= 1
CATEGORIES= games java
MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${DISTVERSION}-setup.jar
@@ -18,7 +19,6 @@ LICENSE_FILE= ${WRKSRC}/license/epl-v10.html
USES= dos2unix zip:infozip
DOS2UNIX_GLOB= *.css *.team *.properties package-list MANIFEST.MF
USE_JAVA= yes
-JAVA_VERSION= 1.6+
JAVA_EXTRACT= yes
JAVA_RUN= yes
NO_WRKSUBDIR= yes
diff --git a/games/robocode/files/robocode-MeleeRumble.in b/games/robocode/files/robocode-MeleeRumble.in
index aaf841419c3e..68195f06821f 100644
--- a/games/robocode/files/robocode-MeleeRumble.in
+++ b/games/robocode/files/robocode-MeleeRumble.in
@@ -3,8 +3,6 @@
# $FreeBSD$
#
-export JAVA_VERSION="%%JAVA_VERSION%%"
-
cd "%%DATADIR%%" && exec "%%LOCALBASE%%/bin/java" -Xmx1024M \
-cp "libs/robocode.jar:libs/roborumble.jar:libs/codesize-1.1.jar" \
roborumble.RoboRumbleAtHome ./roborumble/meleerumble.txt "${@}"
diff --git a/games/robocode/files/robocode-RoboRumble.in b/games/robocode/files/robocode-RoboRumble.in
index f435b4f37728..7198612eda04 100644
--- a/games/robocode/files/robocode-RoboRumble.in
+++ b/games/robocode/files/robocode-RoboRumble.in
@@ -3,8 +3,6 @@
# $FreeBSD$
#
-export JAVA_VERSION="%%JAVA_VERSION%%"
-
cd "%%DATADIR%%" && exec "%%LOCALBASE%%/bin/java" -Xmx512M \
-cp "libs/robocode.jar:libs/roborumble.jar:libs/codesize-1.1.jar" \
roborumble.RoboRumbleAtHome ./roborumble/roborumble.txt "${@}"
diff --git a/games/robocode/files/robocode-Robocode.in b/games/robocode/files/robocode-Robocode.in
index ba2645a19fd4..d4546cbfb6e2 100644
--- a/games/robocode/files/robocode-Robocode.in
+++ b/games/robocode/files/robocode-Robocode.in
@@ -3,7 +3,5 @@
# $FreeBSD$
#
-export JAVA_VERSION="%%JAVA_VERSION%%"
-
cd "%%DATADIR%%" && exec "%%LOCALBASE%%/bin/java" -Xmx512M \
-cp "libs/robocode.jar" robocode.Robocode "${@}"
diff --git a/games/robocode/files/robocode-TeamRumble.in b/games/robocode/files/robocode-TeamRumble.in
index f435b4f37728..7198612eda04 100644
--- a/games/robocode/files/robocode-TeamRumble.in
+++ b/games/robocode/files/robocode-TeamRumble.in
@@ -3,8 +3,6 @@
# $FreeBSD$
#
-export JAVA_VERSION="%%JAVA_VERSION%%"
-
cd "%%DATADIR%%" && exec "%%LOCALBASE%%/bin/java" -Xmx512M \
-cp "libs/robocode.jar:libs/roborumble.jar:libs/codesize-1.1.jar" \
roborumble.RoboRumbleAtHome ./roborumble/roborumble.txt "${@}"
diff --git a/games/robocode/files/robocode-TwinDuel.in b/games/robocode/files/robocode-TwinDuel.in
index 910a136ca357..d2f2b3163941 100644
--- a/games/robocode/files/robocode-TwinDuel.in
+++ b/games/robocode/files/robocode-TwinDuel.in
@@ -3,8 +3,6 @@
# $FreeBSD$
#
-export JAVA_VERSION="%%JAVA_VERSION%%"
-
cd "%%DATADIR%%" && exec "%%LOCALBASE%%/bin/java" -Xmx512M \
-cp "libs/robocode.jar:libs/roborumble.jar:libs/codesize-1.1.jar" \
roborumble.RoboRumbleAtHome ./roborumble/twinduel.txt "${@}"