aboutsummaryrefslogtreecommitdiff
path: root/games/trackballs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/trackballs/Makefile')
-rw-r--r--games/trackballs/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/games/trackballs/Makefile b/games/trackballs/Makefile
index 47620fd43478..af5a42ed4a9c 100644
--- a/games/trackballs/Makefile
+++ b/games/trackballs/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= trackballs
-PORTVERSION= 1.0.0
+PORTVERSION= 1.1.0
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,25 +19,27 @@ RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
USE_X_PREFIX= yes
USE_SDL= image mixer sdl ttf
+USE_GETTEXT= yes
USE_GETOPT_LONG= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+MAKE_ARGS= mkinstalldirs="${MKDIR}"
MAN6= ${PORTNAME}.6
CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include
-LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib
+LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib -lintl
post-patch:
@${FIND} ${WRKSRC} -name '*.h' -o -name '*.cc' | ${XARGS} \
- ${REINPLACE_CMD} -e "/^#include/s|SDL/SDL|SDL|; \
- /stdint.h/d"
- @${REINPLACE_CMD} -e "s|/bin/bash|${LOCALBASE}/bin/bash|" \
+ ${REINPLACE_CMD} -e '/^#include/s|SDL/SDL|SDL|; \
+ /stdint.h/d'
+ @${REINPLACE_CMD} -e 's|/bin/bash|${LOCALBASE}/bin/bash|' \
${WRKSRC}/share/icons/installIcons
- @${REINPLACE_CMD} -e "s|install -D|install|" \
+ @${REINPLACE_CMD} -e 's|install -D|$$(INSTALL)|' \
${WRKSRC}/share/Makefile.in
.include <bsd.port.mk>