aboutsummaryrefslogtreecommitdiff
path: root/games/xblast
diff options
context:
space:
mode:
Diffstat (limited to 'games/xblast')
-rw-r--r--games/xblast/Makefile8
-rw-r--r--games/xblast/files/patch-aa16
2 files changed, 17 insertions, 7 deletions
diff --git a/games/xblast/Makefile b/games/xblast/Makefile
index 8f1fcea16f70..b2a812d3a7c6 100644
--- a/games/xblast/Makefile
+++ b/games/xblast/Makefile
@@ -16,11 +16,7 @@ MAINTAINER= se@FreeBSD.org
WRKSRC= ${WRKDIR}/XBlast-2.6-sound
USE_IMAKE= yes
-NO_INSTALL_MANPAGES= yes
-MANN= xblast.n
-MANCOMPRESSED= no
-
-post-install:
- @${INSTALL_MAN} ${WRKSRC}/xblast.man ${MANNPREFIX}/man/mann/xblast.n
+MAN1= xblast.1
+MANCOMPRESSED= yes
.include <bsd.port.mk>
diff --git a/games/xblast/files/patch-aa b/games/xblast/files/patch-aa
index cc7e8f5d3c0c..7e9ec15d8c5c 100644
--- a/games/xblast/files/patch-aa
+++ b/games/xblast/files/patch-aa
@@ -1,5 +1,5 @@
--- Imakefile.orig Wed Jul 28 21:36:20 1999
-+++ Imakefile Fri Aug 27 14:42:54 1999
++++ Imakefile Tue Oct 17 20:23:46 2000
@@ -25,7 +25,9 @@
* If you want to have sound, comment the following line
* Set SOUND_DIR to the directory, where the sounds can be found
@@ -11,3 +11,17 @@
/*
* all programs to be build
+@@ -71,6 +73,13 @@
+ SRCS2 = xbsndsrv.c
+ OBJS2 = xbsndsrv.o
+
++/*
++ * The following is a terrible hack, but there is no man page
++ * and ComplexProgramTarget always wants to install one ...
++ */
++#undef InstallManPage
++#define InstallManPage(p,d)
++
+ ComplexProgramTarget_2(xbsndsrv,NullParameter,NullParameter)
+
+ /*