aboutsummaryrefslogtreecommitdiff
path: root/games/xrally
diff options
context:
space:
mode:
Diffstat (limited to 'games/xrally')
-rw-r--r--games/xrally/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/games/xrally/Makefile b/games/xrally/Makefile
index cee927665b0a..e9f15e1f8597 100644
--- a/games/xrally/Makefile
+++ b/games/xrally/Makefile
@@ -28,4 +28,10 @@ MAKE_ENV= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
CFLAGS="${PTHREAD_CFLAGS} -I${X11BASE}/include" \
INCLUDES="-I${X11BASE}/include"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 504000
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
+.include <bsd.port.post.mk>