aboutsummaryrefslogtreecommitdiff
path: root/games/xshisen/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/xshisen/Makefile')
-rw-r--r--games/xshisen/Makefile19
1 files changed, 16 insertions, 3 deletions
diff --git a/games/xshisen/Makefile b/games/xshisen/Makefile
index b43a79d4021f..4e12cd619125 100644
--- a/games/xshisen/Makefile
+++ b/games/xshisen/Makefile
@@ -12,15 +12,24 @@ MASTER_SITES= http://www.techfirm.co.jp/~masaoki/
MAINTAINER= nakai@FreeBSD.org
+BUILD_DEPENDS= nkf:${PORTSDIR}/japanese/nkf
+
# runs fine on ssh connection
#IS_INTERACTIVE= YES # Has to create an app-defaults file
USE_X_PREFIX= yes
USE_XPM= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-lxpg4"
CONFIGURE_ARGS= --datadir="${X11BASE}/lib/X11" \
--enable-japanese=euc #Japanese char set euc, jis sjis
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 220000 && ${OSVERSION} < 400020 || \
+ ${OSVERSION} >= 500000 && ${OSVERSION} < 500005
+CONFIGURE_ENV= LIBS="-lxpg4"
+.endif
+
MANLANG= "" ja
MAN6= xshisen.6
@@ -30,8 +39,12 @@ post-install:
@${CHOWN} root:games ${PREFIX}/lib/X11/xshisen/xshisen-scores
@${CHMOD} 0660 ${PREFIX}/lib/X11/xshisen/xshisen-scores
${INSTALL_MAN} ${WRKSRC}/xshisen.man ${PREFIX}/man/man6/xshisen.6
- @${PREFIX}/bin/xshisen -KCONV jis < ${WRKSRC}/xshisen.jman-jis \
+ @nkf -e < ${WRKSRC}/xshisen.jman-jis \
> ${WRKSRC}/xshisen.jman
${INSTALL_MAN} ${WRKSRC}/xshisen.jman ${PREFIX}/man/ja/man6/xshisen.6
+ -test -d ${PREFIX}/lib/X11/ja_JP.EUC/ -a \
+ -d ${PREFIX}/lib/X11/ja_JP.EUC/app-defaults && \
+ ${LN} -s ${PREFIX}/lib/X11/ja_JP.eucJP/app-defaults/XShisen \
+ ${PREFIX}/lib/X11/ja_JP.EUC/app-defaults && \
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>