aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/fgkicker/Makefile34
-rw-r--r--games/fgkicker/distinfo1
-rw-r--r--games/fgkicker/pkg-descr6
-rw-r--r--games/fgkicker/pkg-plist1
5 files changed, 43 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 17456da6643e..6be7b933806b 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -104,6 +104,7 @@
SUBDIR += exult
SUBDIR += falconseye
SUBDIR += farblazer
+ SUBDIR += fgkicker
SUBDIR += fkiss
SUBDIR += flightgear
SUBDIR += flying
diff --git a/games/fgkicker/Makefile b/games/fgkicker/Makefile
new file mode 100644
index 000000000000..26f0bf742b11
--- /dev/null
+++ b/games/fgkicker/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: fgkicker
+# Date created: 30 November 2003
+# Whom: Erik Greenwald <erik@smluc.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fgkicker
+PORTVERSION= 0.4
+CATEGORIES= games
+MASTER_SITES= http://users.pandora.be/ceppe/linux/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= erik@smluc.org
+COMMENT= A launcher frontend for FlightGear
+
+RUN_DEPENDS= fgfs:${PORTSDIR}/games/flightgear
+
+USE_X_PREFIX= yes
+USE_GNOME= gtk20
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} "s|/usr/games/fgfs\",15|${PREFIX}/bin/fgfs\",511|" ${WRKSRC}/fgkicker.c
+ @${REINPLACE_CMD} "s|-fmessage-length=0|| ; s|-O0|${CFLAGS}|" ${WRKSRC}/fgkicker.mak
+
+do-build:
+ (cd ${WRKSRC} && ${GMAKE} -f ${PORTNAME}.mak ${PORTNAME})
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/games/fgkicker/distinfo b/games/fgkicker/distinfo
new file mode 100644
index 000000000000..08c1c1cfe63e
--- /dev/null
+++ b/games/fgkicker/distinfo
@@ -0,0 +1 @@
+MD5 (fgkicker-0.4.tgz) = cda82e31c772453a221a00c46c1b12d7
diff --git a/games/fgkicker/pkg-descr b/games/fgkicker/pkg-descr
new file mode 100644
index 000000000000..56941eb62097
--- /dev/null
+++ b/games/fgkicker/pkg-descr
@@ -0,0 +1,6 @@
+Fgkicker is an easy GUI frontend to launch the Flightgear simulator. Just pick
+your options, then click "Kick!" and you can roam the skies...
+
+WWW: http://users.pandora.be/ceppe/linux/fgkicker.htm
+
+ -Erik Greenwald <erik@smluc.org>
diff --git a/games/fgkicker/pkg-plist b/games/fgkicker/pkg-plist
new file mode 100644
index 000000000000..f24a2d87b050
--- /dev/null
+++ b/games/fgkicker/pkg-plist
@@ -0,0 +1 @@
+bin/fgkicker