aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/bloboats/Makefile1
-rw-r--r--games/textmaze/Makefile5
2 files changed, 5 insertions, 1 deletions
diff --git a/games/bloboats/Makefile b/games/bloboats/Makefile
index d513a2dc96b7..0bc3564d5340 100644
--- a/games/bloboats/Makefile
+++ b/games/bloboats/Makefile
@@ -20,6 +20,7 @@ COMMENT= A boat racing game in the spirit of Elasto Mania or X-Moto
USE_GMAKE= yes
USE_SDL= mixer image net sdl
USE_GL= yes
+MAKE_JOBS_SAFE= yes
MAKE_ENV+= DATADIR="${DATADIR}"
diff --git a/games/textmaze/Makefile b/games/textmaze/Makefile
index bb656e8571d3..b3c31b8c8f0b 100644
--- a/games/textmaze/Makefile
+++ b/games/textmaze/Makefile
@@ -19,10 +19,13 @@ COMMENT= Generates mazes on a text terminal and lets you traverse them
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Curses.pm:${PORTSDIR}/devel/p5-Curses
USE_PERL5= yes
-WRKSRC= ${WRKDIR}/TextMaze
NO_BUILD= yes
+MAKE_JOBS_SAFE= yes
+
PLIST_FILES= bin/textmaze
+WRKSRC= ${WRKDIR}/TextMaze
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local/bin/perl|${PERL}|' \
${WRKSRC}/${PORTNAME}