aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/openalchemist/Makefile13
-rw-r--r--games/super_methane_brothers/Makefile17
-rw-r--r--games/trophy/Makefile13
3 files changed, 15 insertions, 28 deletions
diff --git a/games/openalchemist/Makefile b/games/openalchemist/Makefile
index bc1174d1749b..b9c120aa4260 100644
--- a/games/openalchemist/Makefile
+++ b/games/openalchemist/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: openalchemist
-# Date created: Sat Oct 01 09:30:00 UTC 2003
-# Whom: Ganael LAPLANCHE <ganael.laplanche@martymac.org>
-#
+# Created by: Ganael LAPLANCHE <ganael.laplanche@martymac.org>
# $FreeBSD$
-#
PORTNAME= openalchemist
PORTVERSION= 0.3
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
@@ -22,7 +18,7 @@ LICENSE_FILE_CCbySA= ${WRKSRC}/GRAPHICS-LICENSE
LICENSE_PERMS_CCbySA= ${_LICENSE_PERMS_DEFAULT}
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
-LIB_DEPENDS= clanCore:${PORTSDIR}/devel/clanlib \
+LIB_DEPENDS= clanCore:${PORTSDIR}/devel/clanlib1 \
jpeg:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png
@@ -43,7 +39,8 @@ PORTDOCS= AUTHORS ChangeLog README TODO
.include <bsd.port.options.mk>
post-patch:
- @${REINPLACE_CMD} -E -e 's|^%|#|g' ${WRKSRC}/configure.ac
+ @${REINPLACE_CMD} -E -e 's|0.8|1.0|g' -e 's|^%|#|g' ${WRKSRC}/configure.ac
+ @${REINPLACE_CMD} -E -e 's|0.8|1.0|g' ${WRKSRC}/build/Makefile.am
@${REINPLACE_CMD} -E -e 's|^dist_pkgdata_DATA =.*|dist_pkgdata_DATA = data/* skins/aqua.zip skins/brushed.zip skins/vectoriel.zip|g' ${WRKSRC}/Makefile.am
@${REINPLACE_CMD} -E -e 's|^#!/usr/bin/python|#!${LOCALBASE}/bin/python|g' ${WRKSRC}/openalchemist-config
diff --git a/games/super_methane_brothers/Makefile b/games/super_methane_brothers/Makefile
index 26117c741abd..3fd78f37573e 100644
--- a/games/super_methane_brothers/Makefile
+++ b/games/super_methane_brothers/Makefile
@@ -1,14 +1,9 @@
-# New ports collection makefile for: Super Methane Brothers
-# Date created: 22 Jan 2004
-# Whom: Jean-Yves Lefort <jylefort@brutele.be>
-#
-# $Carpetsmoker: ports/games/super_methane_brothers/Makefile,v 1.2 2007/08/02 13:45:02 carpetsmoker Exp $
+# Created by: Jean-Yves Lefort <jylefort@brutele.be>
# $FreeBSD$
-#
PORTNAME= super_methane_brothers
PORTVERSION= 1.4.8
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= games
MASTER_SITES= SF/methane/Methane%20Stable/Methane%20V${PORTVERSION}
DISTNAME= methane-${PORTVERSION}
@@ -17,21 +12,19 @@ EXTRACT_SUFX= .tgz
MAINTAINER= c.petrik.sosa@gmail.com
COMMENT= A port of the Amiga platform game of the same name
-LIB_DEPENDS= clanCore-0.8:${PORTSDIR}/devel/clanlib \
+LIB_DEPENDS= clanCore:${PORTSDIR}/devel/clanlib1 \
mikmod:${PORTSDIR}/audio/libmikmod
USE_GMAKE= yes
MAKEFILE= makefile
BUILD_WRKSRC= ${WRKSRC}/source/linux
-CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/ClanLib-0.8
-LDFLAGS+= -L${LOCALBASE}/lib -L${LOCALBASE}/lib/ClanLib-0.8
-
post-patch:
@${REINPLACE_CMD} -e \
's|g++|${CXX}|; s|gcc|${CXX}|; \
s|^\(METHANE_FLAGS =\)|\1 ${CPPFLAGS}|; \
- s|^\(METHANE_LIBS =\)|\1 ${LDFLAGS}|' \
+ s|^\(METHANE_LIBS =\)|\1 ${LDFLAGS}|; \
+ s|0.8|1.0|g' \
${BUILD_WRKSRC}/makefile
do-install:
diff --git a/games/trophy/Makefile b/games/trophy/Makefile
index 049b17134fa2..f214698cb372 100644
--- a/games/trophy/Makefile
+++ b/games/trophy/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: trophy
-# Date created: 2004-01-24
-# Whom: Jean-Yves Lefort <jylefort@brutele.be>
-#
+# Created by: Jean-Yves Lefort <jylefort@brutele.be>
# $FreeBSD$
-#
PORTNAME= trophy
PORTVERSION= 2.0.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= SF
@@ -16,11 +12,12 @@ COMMENT= A single player racing game
LICENSE= GPLv2
-LIB_DEPENDS= clanCore-0.8:${PORTSDIR}/devel/clanlib
+LIB_DEPENDS= clanCore:${PORTSDIR}/devel/clanlib1
GNU_CONFIGURE= yes
CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib"
-CPPFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= ${PTHREAD_LIBS}
MAN6= trophy.6