aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/alephone/Makefile8
-rw-r--r--games/battleball/Makefile8
-rw-r--r--games/clanbomber/Makefile8
-rw-r--r--games/nil/Makefile8
-rw-r--r--games/pipenightdreams/Makefile8
5 files changed, 35 insertions, 5 deletions
diff --git a/games/alephone/Makefile b/games/alephone/Makefile
index bbf575941789..d25e4b4b24e5 100644
--- a/games/alephone/Makefile
+++ b/games/alephone/Makefile
@@ -18,6 +18,12 @@ COMMENT= The open source version of Bungie's Marathon game
LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12:install \
SDL_image.10:${PORTSDIR}/graphics/sdl_image:install
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
USE_X_PREFIX= yes
@@ -34,4 +40,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/battleball/Makefile b/games/battleball/Makefile
index f9968fd62db5..1adae103a101 100644
--- a/games/battleball/Makefile
+++ b/games/battleball/Makefile
@@ -15,6 +15,12 @@ DISTNAME= ${PORTNAME}.${PORTVERSION:S/.//}.src
MAINTAINER= ports@FreeBSD.org
COMMENT= 3D single/multiplayer military soccer game for X Window System
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
USE_X_PREFIX= yes
USE_MESA= yes
WRKSRC= ${WRKDIR}/battleball-2.1-src
@@ -32,4 +38,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/clanbomber/Makefile b/games/clanbomber/Makefile
index 23dc693b6a9d..8d13e2c7bdb8 100644
--- a/games/clanbomber/Makefile
+++ b/games/clanbomber/Makefile
@@ -16,10 +16,16 @@ COMMENT= A bomberman-like multiplayer game
LIB_DEPENDS= clanCore.0:${PORTSDIR}/devel/clanlib
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
USE_XLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="${PTHREAD_LIBS} -L${LOCALBASE}/lib" \
CPPFLAGS="-I${LOCALBASE}/include"
CFLAGS+= -fpermissive
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/nil/Makefile b/games/nil/Makefile
index 282079ddb0fe..849a5f171d00 100644
--- a/games/nil/Makefile
+++ b/games/nil/Makefile
@@ -17,6 +17,12 @@ COMMENT= A multiplayer game that can be described as Quake in 2D or Worms done r
LIB_DEPENDS= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
WRKSRC= ${WRKDIR}/${PORTNAME}/${PORTNAME}
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
@@ -42,4 +48,4 @@ post-install:
@${ECHO_MSG} "See ${PREFIX}/share/nil/README for usage instructions."
@${ECHO_MSG} ""
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/pipenightdreams/Makefile b/games/pipenightdreams/Makefile
index d9302040e864..e63c29405cc8 100644
--- a/games/pipenightdreams/Makefile
+++ b/games/pipenightdreams/Makefile
@@ -15,6 +15,12 @@ COMMENT= A puzzle game similar to PipeMania
LIB_DEPENDS= SDL_image.10:${PORTSDIR}/graphics/sdl_image
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
GNU_CONFIGURE= yes
USE_BZIP2= yes
@@ -34,4 +40,4 @@ post-patch:
${REINPLACE_CMD} "s|/usr/share/games|${LOCALBASE}/share|g" \
${WRKSRC}/src/main.cpp
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>