aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/pysolfc/Makefile2
-rw-r--r--games/pysolfc/files/patch-pysollib_mfxutil.py21
2 files changed, 22 insertions, 1 deletions
diff --git a/games/pysolfc/Makefile b/games/pysolfc/Makefile
index 2e8449a17ead..0042d7fb1168 100644
--- a/games/pysolfc/Makefile
+++ b/games/pysolfc/Makefile
@@ -1,6 +1,6 @@
PORTNAME= pysolfc
DISTVERSION= 2.6.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games python
MASTER_SITES= SF/${PORTNAME}/PySolFC/${PYSOLFCDIR} \
SF/${PORTNAME}/PySolFC-Cardsets/${CARDSETDIR}:cardsets
diff --git a/games/pysolfc/files/patch-pysollib_mfxutil.py b/games/pysolfc/files/patch-pysollib_mfxutil.py
new file mode 100644
index 000000000000..a76d320c68ae
--- /dev/null
+++ b/games/pysolfc/files/patch-pysollib_mfxutil.py
@@ -0,0 +1,21 @@
+Fix runtime errors with Python 3.8+ because the function time.clock() has been
+removed in Python 3.8, after having been deprecated since Python 3.3.
+
+Obtained from:
+https://github.com/shlomif/PySolFC/commit/0961401105850a18ff129e2c25cfffae45a81752
+
+--- pysollib/mfxutil.py.orig 2021-06-09 18:23:28 UTC
++++ pysollib/mfxutil.py
+@@ -143,7 +143,11 @@ def getprefdir(package):
+
+
+ # high resolution clock() and sleep()
+-uclock = time.clock
++try:
++ uclock = time.perf_counter
++except Exception:
++ uclock = time.clock
++
+ usleep = time.sleep
+ if os.name == "posix":
+ uclock = time.time