aboutsummaryrefslogtreecommitdiff
path: root/german/aspell/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'german/aspell/Makefile')
-rw-r--r--german/aspell/Makefile25
1 files changed, 21 insertions, 4 deletions
diff --git a/german/aspell/Makefile b/german/aspell/Makefile
index c28595b5d7b8..ad2adc8bbbfd 100644
--- a/german/aspell/Makefile
+++ b/german/aspell/Makefile
@@ -2,14 +2,31 @@
# $FreeBSD$
PORTNAME= aspell
-SPELLVERSION= 6-de-20030222-1
+MASTER_SITES= https://j3e.de/ispell/igerman98/dict/
+PORTVERSION= 20161207
PORTREVISION= 1
CATEGORIES= german textproc
+DISTNAME= igerman98-${PORTVERSION}
MAINTAINER= office@FreeBSD.org
COMMENT= Aspell German dictionary
-DICT= de
+USES= gmake tar:bzip2
+ALL_TARGET= aspell/de_DE.rws aspell/de_AT.rws aspell/de_CH.rws
-.include "${.CURDIR}/../../textproc/aspell/Makefile.inc"
-.include <bsd.port.post.mk>
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/aspell \
+ ${STAGEDIR}${PREFIX}/lib/aspell-0.60
+.for lang in de_DE de_AT de_CH
+ ${INSTALL_DATA} ${WRKSRC}/aspell/${lang}.dat \
+ ${WRKSRC}/aspell/${lang}_affix.dat \
+ ${WRKSRC}/aspell/${lang}.multi \
+ ${STAGEDIR}${PREFIX}/lib/aspell-0.60
+ ${INSTALL_DATA} ${WRKSRC}/aspell/${lang}.rws \
+ ${STAGEDIR}${PREFIX}/share/aspell
+.endfor
+ ${ECHO} "add de_DE.multi" > ${STAGEDIR}${PREFIX}/share/aspell/deutsch.alias
+ ${ECHO} "add de_DE.multi" > ${STAGEDIR}${PREFIX}/share/aspell/german.alias
+ ${ECHO} "add de_CH.multi" > ${STAGEDIR}${PREFIX}/share/aspell/swiss.alias
+
+.include <bsd.port.mk>