aboutsummaryrefslogtreecommitdiff
path: root/graphics/eog/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/eog/Makefile')
-rw-r--r--graphics/eog/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/graphics/eog/Makefile b/graphics/eog/Makefile
new file mode 100644
index 000000000000..ffe019d9203e
--- /dev/null
+++ b/graphics/eog/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: eog2
+# Date created: 21 May 2002
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= eog
+PORTVERSION= 2.8.2
+PORTREVISION= 1
+CATEGORIES= graphics gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.8
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= The Eye Of Gnome image viewer
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+USE_GNOME= gnomeprefix gnomehack gnomehier intlhack libgnomeprintui \
+ librsvg2 desktopfileutils libgnomeui
+USE_X_PREFIX= yes
+INSTALLS_OMF= yes
+USE_LIBTOOL_VER=15
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+GCONF_SCHEMAS= eog.schemas
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_EXIF) || exists(${LOCALBASE}/lib/libexif.so.10)
+LIB_DEPENDS+= exif.10:${PORTSDIR}/graphics/libexif
+.endif
+
+post-install:
+ @-update-desktop-database > /dev/null
+
+.include <bsd.port.post.mk>