aboutsummaryrefslogtreecommitdiff
path: root/graphics/freeglut/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/freeglut/Makefile')
-rw-r--r--graphics/freeglut/Makefile57
1 files changed, 29 insertions, 28 deletions
diff --git a/graphics/freeglut/Makefile b/graphics/freeglut/Makefile
index 1c365ec3997e..11170f18054b 100644
--- a/graphics/freeglut/Makefile
+++ b/graphics/freeglut/Makefile
@@ -1,3 +1,4 @@
+# vim:ts=8:sw=8
# New ports collection makefile for: freeglut
# Date created: Wed Apr 23 2003
# Whom: thierry@pompo.net
@@ -5,36 +6,40 @@
# $FreeBSD$
#
-PORTNAME= freeglut
-PORTVERSION= 2.4.0
-PORTREVISION= 4
-CATEGORIES= graphics
-MASTER_SITES= SF
+PORTNAME= freeglut
+PORTVERSION= 2.6.0
+CATEGORIES= graphics
+MASTER_SITES= SF/${PORTNAME:L}/${PORTNAME:L}/
-MAINTAINER= ports@FreeBSD.org
-COMMENT= An alternative to the OpenGL Utility Toolkit (GLUT) library
+MAINTAINER= aldis@bsdroot.lv
+COMMENT= An alternative to the OpenGL Utility Toolkit (GLUT) library
-CONFLICTS= libglut-[0-9]*
+CONFLICTS= libglut-[0-9].*
-USE_AUTOTOOLS= libtool:22
-GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
-USE_XORG= ice
-USE_GL= glu
-CONFIGURE_ARGS= --disable-warnings
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-lusbhid"
-
-REINPLACE_ARGS= -i ""
+USE_AUTOTOOLS= libtool:22
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USE_XORG= ice xi
+USE_GL= glu
+CONFIGURE_ARGS= --disable-warnings
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-lusbhid"
+USE_LDCONFIG= yes
DOCS= download.html freeglut.html freeglut_logo.png \
freeglut_user_interface.html index.html ogl_sm.png \
progress.html structure.html
BINS= CallbackMaker Fractals Fractals_random Lorenz One shapes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 800000
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-src__freeglut_joystick.c
+.endif
+
pre-configure:
-.for fract in /fractals.c _random/fractals_random.c
+.for fract in Fractals/fractals.c Fractals_random/fractals_random.c
@${REINPLACE_CMD} -e "s|/usr/local|${PREFIX}|g" \
- ${WRKSRC}/progs/demos/Fractals${fract}
+ ${WRKSRC}/progs/demos/${fract}
.endfor
post-build:
@@ -48,23 +53,19 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/doc/${FILE} ${DOCSDIR}
.endfor
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+.endif
+.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/progs/demos/Fractals/fractals.dat \
- ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/progs/demos/Fractals/fractals.dat ${EXAMPLESDIR}
.for prog in ${BINS}
- @${INSTALL_PROGRAM} ${WRKSRC}/progs/demos/${prog}/.libs/${prog:L} \
- ${EXAMPLESDIR}
+ @${INSTALL_PROGRAM} ${WRKSRC}/progs/demos/${prog}/.libs/${prog:L} ${EXAMPLESDIR}
.endfor
@${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
.endif
+.if ${OSVERSION} >= 800000
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 800064
-BROKEN= does not build
.endif
.include <bsd.port.post.mk>