aboutsummaryrefslogtreecommitdiff
path: root/graphics/giblib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/giblib/Makefile')
-rw-r--r--graphics/giblib/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/graphics/giblib/Makefile b/graphics/giblib/Makefile
index f2e4db25dff9..cb04468644fb 100644
--- a/graphics/giblib/Makefile
+++ b/graphics/giblib/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= giblib
-PORTVERSION= 1.2.3
+PORTVERSION= 1.2.4
CATEGORIES= graphics devel
MASTER_SITES= http://www.linuxbrit.co.uk/downloads/
@@ -16,12 +16,20 @@ COMMENT= A utility library that includes a wrapper for imlib2
LIB_DEPENDS= Imlib2.2:${PORTSDIR}/graphics/imlib2
USE_X_PREFIX= yes
-GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_GNOME= gnomehack gnometarget pkgconfig
+USE_REINPLACE= yes
+USE_LIBTOOL_VER= 15
INSTALLS_SHLIB= yes
-.if defined(NOPORTDOCS)
-MAKE_ENV= NO_DOC=yes
+post-patch:
+ @${REINPLACE_CMD} -e 's|: install-docsDATA|:|g' ${WRKSRC}/Makefile.in
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in AUTHORS ChangeLog README TODO
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
.endif
.include <bsd.port.mk>