aboutsummaryrefslogtreecommitdiff
path: root/graphics/gimp1/files
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gimp1/files')
-rw-r--r--graphics/gimp1/files/patch-configure25
-rw-r--r--graphics/gimp1/files/patch-libgimp::Makefile.in14
-rw-r--r--graphics/gimp1/files/patch-plug-ins_Makefile.in10
-rw-r--r--graphics/gimp1/files/patch-plug-ins_print_print-escp2_c20
4 files changed, 17 insertions, 52 deletions
diff --git a/graphics/gimp1/files/patch-configure b/graphics/gimp1/files/patch-configure
index 25dd31d25b59..4d64eb9d8f9d 100644
--- a/graphics/gimp1/files/patch-configure
+++ b/graphics/gimp1/files/patch-configure
@@ -1,9 +1,6 @@
-
-$FreeBSD$
-
---- configure.orig Sun Feb 10 08:21:30 2002
-+++ configure Sun May 19 23:52:50 2002
-@@ -746,7 +746,7 @@
+--- configure.orig Mon May 19 18:46:21 2003
++++ configure Sat May 31 19:37:03 2003
+@@ -1475,7 +1475,7 @@
GIMP_VERSION=$GIMP_MAJOR_VERSION.$GIMP_MINOR_VERSION.$GIMP_MICRO_VERSION
LT_RELEASE=$GIMP_MAJOR_VERSION.$GIMP_MINOR_VERSION
@@ -12,7 +9,7 @@ $FreeBSD$
LT_REVISION=$GIMP_INTERFACE_AGE
LT_AGE=`expr $GIMP_BINARY_AGE - $GIMP_INTERFACE_AGE`
LT_CURRENT_MINUS_AGE=`expr $LT_CURRENT - $LT_AGE`
-@@ -5577,6 +5577,7 @@
+@@ -7535,6 +7535,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
@@ -20,7 +17,7 @@ $FreeBSD$
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-@@ -11957,8 +11958,8 @@
+@@ -18639,8 +18640,8 @@
fi
@@ -31,15 +28,3 @@ $FreeBSD$
gimpsysconfdir=$sysconfdir/$PACKAGE/$GIMP_MAJOR_VERSION.$GIMP_MINOR_VERSION
localedir='${prefix}/${DATADIRNAME}/locale'
-@@ -13133,11 +13134,6 @@
- *) # Relative path.
- srcdir="$ac_dots$ac_given_srcdir$ac_dir_suffix"
- top_srcdir="$ac_dots$ac_given_srcdir" ;;
-- esac
--
-- case "$ac_given_INSTALL" in
-- [/$]*) INSTALL="$ac_given_INSTALL" ;;
-- *) INSTALL="$ac_dots$ac_given_INSTALL" ;;
- esac
-
- echo creating "$ac_file"
diff --git a/graphics/gimp1/files/patch-libgimp::Makefile.in b/graphics/gimp1/files/patch-libgimp::Makefile.in
index b9cdc7868203..f025eddbe488 100644
--- a/graphics/gimp1/files/patch-libgimp::Makefile.in
+++ b/graphics/gimp1/files/patch-libgimp::Makefile.in
@@ -1,19 +1,19 @@
---- libgimp/Makefile.in.orig Tue Feb 12 05:46:08 2002
-+++ libgimp/Makefile.in Wed Feb 20 14:02:07 2002
-@@ -225,13 +225,13 @@
+--- libgimp/Makefile.in.orig Mon May 19 19:07:25 2003
++++ libgimp/Makefile.in Sat May 31 19:41:48 2003
+@@ -226,13 +226,13 @@
gimpinclude_HEADERS = gimp.h ${PDB_WRAPPERS_H} gimpchainbutton.h gimpchannel.h gimpcolorbutton.h gimpcolordisplay.h gimpcolorselector.h gimpcolorspace.h gimpcompat.h gimpdrawable.h gimpdialog.h gimpenums.h gimpenv.h gimpexport.h gimpfeatures.h gimpfileselection.h gimpgradientselect.h gimphelpui.h gimpimage.h gimplayer.h gimplimits.h gimpmath.h gimpmatrix.h gimpmenu.h gimpmodule.h gimpparasite.h gimpparasiteio.h gimppatheditor.h gimppixelrgn.h gimppixmap.h gimpproceduraldb.h gimpquerybox.h gimpselection.h gimpsignal.h gimpsizeentry.h gimptile.h gimptypes.h gimpui.h gimpunit.h gimpunitmenu.h gimputils.h gimpvector.h gimpwidgets.h gimpintl.h
-libgimp_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) -release $(LT_RELEASE) $(no_undefined) $(libgimp_export_symbols)
-+libgimp_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) $(no_undefined) $(libgimp_export_symbols)
++libgimp_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) $(no_undefined) $(libgimp_export_symbols)
--libgimp_la_LIBADD = $(GLIB_LIBS) -lm
-+libgimp_la_LIBADD = $(GTK_LIBS) -lm
+-libgimp_la_LIBADD = $(GLIB_LIBS) $(libmath)
++libgimp_la_LIBADD = $(GTK_LIBS) $(libmath)
libgimp_la_DEPENDENCIES = $(gimp_def)
-libgimpui_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) -release $(LT_RELEASE) $(no_undefined) $(libgimpui_export_symbols)
-+libgimpui_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) $(no_undefined) $(libgimpui_export_symbols)
++libgimpui_la_LDFLAGS = -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) $(no_undefined) $(libgimpui_export_symbols)
libgimpui_la_LIBADD = $(GTK_LIBS) $(conditional_libgimp_la)
diff --git a/graphics/gimp1/files/patch-plug-ins_Makefile.in b/graphics/gimp1/files/patch-plug-ins_Makefile.in
index 829f78c7162b..503a87e4f6e0 100644
--- a/graphics/gimp1/files/patch-plug-ins_Makefile.in
+++ b/graphics/gimp1/files/patch-plug-ins_Makefile.in
@@ -1,9 +1,9 @@
---- plug-ins/Makefile.in.orig Fri Jul 27 21:36:22 2001
-+++ plug-ins/Makefile.in Wed Aug 15 22:02:54 2001
-@@ -113,7 +113,7 @@
- HAVE_FINITE = @HAVE_FINITE@
+--- plug-ins/Makefile.in.orig Mon May 19 19:07:31 2003
++++ plug-ins/Makefile.in Sat May 31 19:44:38 2003
+@@ -111,7 +111,7 @@
+ GTK_CONFIG = @GTK_CONFIG@
+ GTK_LIBS = @GTK_LIBS@
HAVE_GTK_DOC = @HAVE_GTK_DOC@
- HAVE_ISFINITE = @HAVE_ISFINITE@
-HELPBROWSER = @HELPBROWSER@
+#HELPBROWSER = @HELPBROWSER@
HTML_DIR = @HTML_DIR@
diff --git a/graphics/gimp1/files/patch-plug-ins_print_print-escp2_c b/graphics/gimp1/files/patch-plug-ins_print_print-escp2_c
deleted file mode 100644
index 9575c80c7952..000000000000
--- a/graphics/gimp1/files/patch-plug-ins_print_print-escp2_c
+++ /dev/null
@@ -1,20 +0,0 @@
---- plug-ins/print/print-escp2.c.orig Fri Oct 13 01:17:44 2000
-+++ plug-ins/print/print-escp2.c Fri Oct 13 01:18:14 2000
-@@ -26,6 +26,8 @@
- * compile on generic platforms that don't support glib, gimp, gtk, etc.
- */
-
-+#include <sys/types.h>
-+
- #ifndef WEAVETEST
- #include "print.h"
- #endif
-@@ -4000,7 +4002,7 @@
- if (lineoffs[0].v[j] != 0)
- fprintf(stderr,
- "WARNING: pass %d subpass %d row %d: lineoffs %ld\n",
-- w.pass, i, row, lineoffs[0].v[j]);
-+ w.pass, i, row, (long)lineoffs[0].v[j]);
- lineoffs[0].v[j] = 0;
- lineactive[0].v[j] = 0;
- }