aboutsummaryrefslogtreecommitdiff
path: root/graphics/libgnomecanvas/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/libgnomecanvas/Makefile')
-rw-r--r--graphics/libgnomecanvas/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/graphics/libgnomecanvas/Makefile b/graphics/libgnomecanvas/Makefile
index e0211433a81d..72d929dfdb2a 100644
--- a/graphics/libgnomecanvas/Makefile
+++ b/graphics/libgnomecanvas/Makefile
@@ -17,15 +17,23 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= A graphics library for GNOME
USE_BZIP2= yes
+PREFIX?= ${X11BASE}
+
+.if !defined(REFERENCE_PORT)
+
+PORTREVISION= 1
+
USE_GMAKE= yes
USE_GETTEXT= yes
-USE_X_PREFIX= yes
+USE_XLIB= yes
INSTALLS_SHLIB= yes
USE_AUTOTOOLS= libtool:15
-USE_GNOME= gnomehack libglade2 libartlgpl2 ltverhack
+USE_GNOME= gnomehack libglade2 libartlgpl2 ltverhack referencehack
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
--disable-gtk-doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>
+
+.endif