aboutsummaryrefslogtreecommitdiff
path: root/graphics/libpano12/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/libpano12/Makefile')
-rw-r--r--graphics/libpano12/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/graphics/libpano12/Makefile b/graphics/libpano12/Makefile
new file mode 100644
index 000000000000..1b89985cb0b7
--- /dev/null
+++ b/graphics/libpano12/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: panorama-tools
+# Date created: 26 august 2004
+# Whom: cartola (Carlos E. G. Carvalho)
+#
+# $FreeBSD$
+# This port has been made as a building and running dependence for the
+# hugin port.
+# The hugin port is a gui interface to interact with this and other
+# tools.
+
+PORTNAME= libpano12
+PORTVERSION= 2.7.0.3
+CATEGORIES= graphics
+MASTER_SITES= http://www.openit.com.br/distfiles/
+
+MAINTAINER= cartola@openit.com.br
+COMMENT= Panorama Tools to make panorama pictures
+
+LIB_DEPENDS= tiff:${PORTSDIR}/graphics/tiff \
+ png:${PORTSDIR}/graphics/png \
+ jpeg:${PORTSDIR}/graphics/jpeg
+
+USE_JAVA= yes
+JAVA_VERSION= 1.3+
+
+MAKEFILE= makefile.freebsd
+
+INSTALLS_SHLIB= yes
+
+post-extract:
+ ${CP} ${FILESDIR}/makefile.freebsd ${WRKSRC}/makefile.freebsd
+
+.include <bsd.port.mk>