aboutsummaryrefslogtreecommitdiff
path: root/graphics/ocropus/files/patch-configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/ocropus/files/patch-configure.ac')
-rw-r--r--graphics/ocropus/files/patch-configure.ac32
1 files changed, 18 insertions, 14 deletions
diff --git a/graphics/ocropus/files/patch-configure.ac b/graphics/ocropus/files/patch-configure.ac
index 49821662f843..a0d4abb730db 100644
--- a/graphics/ocropus/files/patch-configure.ac
+++ b/graphics/ocropus/files/patch-configure.ac
@@ -1,27 +1,31 @@
--- ./configure.ac.orig 2009-06-01 05:18:41.000000000 +0900
-+++ ./configure.ac 2009-06-17 19:47:20.000000000 +0900
-@@ -114,11 +114,19 @@
- AC_MSG_ERROR([no TIFFOpen; please install libtiff4-dev or equivalent]))
++++ ./configure.ac 2010-02-02 21:28:54.000000000 +0900
+@@ -115,13 +115,20 @@
AC_LANG_CPLUSPLUS
-+# should require CXXCPP before conditional AC_CHECK_HEADER
-+AC_PROG_CXXCPP
++# Unconditional AC_CHECK_LIB should be done before conditional ones.
++# --- libpthread (needed by tesseract) ---
++AC_CHECK_LIB(pthread, pthread_create,,)
++
# --- iulib (required) ---
# NB: we can only use functions with C linkage here
AC_CHECK_LIB(iulib, exit,,
- AC_MSG_ERROR([no iulib; please install iulib first (see INSTALL)]))
-+ AC_CHECK_LIB(avcodec, avcodec_open, ,
-+ AC_MSG_ERROR([no iulib; please install iulib first (see INSTALL)]))
-+ AC_CHECK_LIB(avformat, url_fopen, ,
-+ AC_MSG_ERROR([no iulib; please install iulib first (see INSTALL)]))
-+ AC_CHECK_LIB(iulib, sleep, ,
-+ AC_MSG_ERROR([no iulib; please install iulib first (see INSTALL)]))
+-
+-# --- libpthread (needed by tesseract) ---
+-AC_CHECK_LIB(pthread, pthread_create,,)
++ AC_CHECK_LIB([avcodec], [avcodec_open], ,
++ [AC_MSG_ERROR([no iulib; please install iulib first (see INSTALL)])])
++ AC_CHECK_LIB([avformat], [url_fopen], ,
++ [AC_MSG_ERROR([no iulib; please install iulib first (see INSTALL)])])
++ AC_CHECK_LIB([iulib], [sleep], ,
++ [AC_MSG_ERROR([no iulib; please install iulib first (see INSTALL)])])
+)
- # --- libpthread (needed by tesseract) ---
- AC_CHECK_LIB(pthread, pthread_create,,)
-@@ -176,14 +184,14 @@
+ # --- libtesseract (ahouls become optional) ---
+ if test x$notesseract != x1; then
+@@ -176,14 +183,14 @@
LDFLAGS="$LDFLAGS -L$leptheaders/../../lib"
AC_CHECK_LIB(lept,pixCreate,,AC_MSG_ERROR([leptonica not found! Choose --without-leptonica if you don't want to use it.]))
fi