aboutsummaryrefslogtreecommitdiff
path: root/graphics/ogre3d/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/ogre3d/Makefile')
-rw-r--r--graphics/ogre3d/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/graphics/ogre3d/Makefile b/graphics/ogre3d/Makefile
index 899c4096d7a8..e72a9a8d1082 100644
--- a/graphics/ogre3d/Makefile
+++ b/graphics/ogre3d/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= zzip.13:${PORTSDIR}/devel/zziplib \
WRKSRC= ${WRKDIR}/ogrenew
CONFIGURE_ARGS= --disable-cg --program-transform-name= --enable-static \
--with-cppunit-prefix=/nonexistent --disable-freeimage
-CONFIGURE_ENV+= CPPFLAGS="-I${X11BASE}/include -DNDEBUG" \
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -DNDEBUG" \
ZZIPLIB_CFLAGS="-I${LOCALBASE}/include" \
ZZIPLIB_LIBS="-L${LOCALBASE}/lib -lzzip"
GNU_CONFIGURE= YES
@@ -41,7 +41,7 @@ post-patch:
s|sdl-config|${SDL_CONFIG}|g; \
s|-lpthread|${PTHREAD_LIBS}|g; \
s|"-lIL|"-L${LOCALBASE}/lib -lIL|g; \
- s|-lGL -lGLU|-L${X11BASE}/lib &|g; \
+ s|-lGL -lGLU|-L${LOCALBASE}/lib &|g; \
s|" == "x|" = "x|g; \
s|-lfreeimage|-L${LOCALBASE}/lib &|g' \
${WRKSRC}/configure