aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-GraphViz2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/p5-GraphViz2/Makefile')
-rw-r--r--graphics/p5-GraphViz2/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/graphics/p5-GraphViz2/Makefile b/graphics/p5-GraphViz2/Makefile
index 723c365e25b1..955cdde53606 100644
--- a/graphics/p5-GraphViz2/Makefile
+++ b/graphics/p5-GraphViz2/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= GraphViz2
-PORTVERSION= 2.24
+PORTVERSION= 2.25
CATEGORIES= graphics perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:RSAVAGE
@@ -42,12 +42,17 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/dot:${PORTSDIR}/graphics/graphviz \
p5-XML-Tiny>=2.06:${PORTSDIR}/textproc/p5-XML-Tiny \
p5-parent>=0.225:${PORTSDIR}/devel/p5-parent
RUN_DEPENDS:= ${BUILD_DEPENDS}
-TEST_DEPENDS= p5-Test-Pod>=1.45:${PORTSDIR}/devel/p5-Test-Pod
+TEST_DEPENDS= p5-Test-Pod>=1.45:${PORTSDIR}/devel/p5-Test-Pod \
+ p5-Test-Version>=0:${PORTSDIR}/devel/p5-Test-Version
OPTIONS_DEFINE= EXAMPLES
USE_PERL5= 5.14.2+ configure
-USES= perl5
+USES= perl5 shebangfix
+
+PORTEXAMPLES= *
+
+SHEBANG_FILES= scripts/generate.png.sh scripts/generate.svg.sh scripts/pod2html.sh
.include <bsd.port.options.mk>