aboutsummaryrefslogtreecommitdiff
path: root/graphics/qiv
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/qiv')
-rw-r--r--graphics/qiv/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/graphics/qiv/Makefile b/graphics/qiv/Makefile
index 3b95e51d90d5..feec381aee3a 100644
--- a/graphics/qiv/Makefile
+++ b/graphics/qiv/Makefile
@@ -24,6 +24,12 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAN1= qiv.1
PLIST_FILES= bin/qiv
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "alpha"
+BROKEN= "Does not compile on alpha"
+.endif
+
do-configure:
@ ${MV} ${WRKSRC}/qiv.1 ${WRKSRC}/qiv.1.pre_sed
@ ${SED} -e 's#\/usr\/bin#${PREFIX}/bin#g' \
@@ -39,4 +45,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/qiv ${PREFIX}/bin/
${INSTALL_MAN} ${WRKSRC}/qiv.1 ${PREFIX}/man/man1/
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>