aboutsummaryrefslogtreecommitdiff
path: root/graphics/qslim/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/qslim/Makefile')
-rw-r--r--graphics/qslim/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/graphics/qslim/Makefile b/graphics/qslim/Makefile
index 1a41e7574595..73bd97a1dfab 100644
--- a/graphics/qslim/Makefile
+++ b/graphics/qslim/Makefile
@@ -17,20 +17,20 @@ COMMENT= SlimKit Surface Modeling Tools
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
- forms.1:${PORTSDIR}/x11-toolkits/xforms \
- glut.4:${PORTSDIR}/graphics/libglut
+ forms.1:${PORTSDIR}/x11-toolkits/xforms
CONFIGURE_WRKSRC= ${WRKSRC}/mixkit/build
BUILD_WRKSRC= ${WRKSRC}/mixkit/src
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_GL= glut
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
ALL_TARGET= # none
-CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include \
- -I${X11BASE}/include/X11 ${PTHREAD_CFLAGS}
-LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
+CPPFLAGS= -I${LOCALBASE}/include \
+ -I${LOCALBASE}/include/X11 ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CFLAGS+= -DMIX_ANSI_IOSTREAMS -fpermissive