aboutsummaryrefslogtreecommitdiff
path: root/graphics/xpdf
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/xpdf')
-rw-r--r--graphics/xpdf/Makefile17
-rw-r--r--graphics/xpdf/distinfo2
-rw-r--r--graphics/xpdf/pkg-comment2
-rw-r--r--graphics/xpdf/pkg-descr12
-rw-r--r--graphics/xpdf/pkg-plist6
5 files changed, 28 insertions, 11 deletions
diff --git a/graphics/xpdf/Makefile b/graphics/xpdf/Makefile
index c689cbcbc94d..ed3d7173689f 100644
--- a/graphics/xpdf/Makefile
+++ b/graphics/xpdf/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xpdf
-PORTVERSION= 1.01
+PORTVERSION= 2.00
CATEGORIES= graphics print
MASTER_SITES= ftp://ftp.foolabs.com/pub/xpdf/ \
${MASTER_SITE_TEX_CTAN}
@@ -18,13 +18,14 @@ BUILD_DEPENDS= freetype-config:${PORTSDIR}/print/freetype2
LIB_DEPENDS= t1.4:${PORTSDIR}/devel/t1lib \
freetype.9:${PORTSDIR}/print/freetype2
-USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_XPM= yes
+USE_MOTIF= yes
+
+USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --with-gzip --enable-opi \
+CONFIGURE_ARGS= --with-gzip --enable-opi --with-x \
--with-t1-library="${LOCALBASE}/lib" \
--with-t1-includes="${LOCALBASE}/include" \
--with-freetype2-library="${LOCALBASE}/lib" \
@@ -42,4 +43,12 @@ MAN1= pdffonts.1 \
xpdf.1
MAN5= xpdfrc.5
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ANNOUNCE CHANGES INSTALL README misc/hello.pdf
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
.include <bsd.port.mk>
diff --git a/graphics/xpdf/distinfo b/graphics/xpdf/distinfo
index 8e5fcd876599..3d85a63c5668 100644
--- a/graphics/xpdf/distinfo
+++ b/graphics/xpdf/distinfo
@@ -1 +1 @@
-MD5 (xpdf-1.01.tar.gz) = 36d5b3458dfead16e3ec4df6596ec6f9
+MD5 (xpdf-2.00.tar.gz) = 8cfeab4d23e620b92bfaa0a818c3a28d
diff --git a/graphics/xpdf/pkg-comment b/graphics/xpdf/pkg-comment
index 145bc09305d1..6c9fbcd4c4e2 100644
--- a/graphics/xpdf/pkg-comment
+++ b/graphics/xpdf/pkg-comment
@@ -1 +1 @@
-Display tool for PDF files
+Display PDF files, and convert them to other formats
diff --git a/graphics/xpdf/pkg-descr b/graphics/xpdf/pkg-descr
index c27e12e090d5..8363025888dd 100644
--- a/graphics/xpdf/pkg-descr
+++ b/graphics/xpdf/pkg-descr
@@ -1,9 +1,11 @@
-Xpdf is a viewer for Portable Document Format (PDF) files. (These are
+Xpdf is a viewer for Portable Document Format (PDF) files. These are
also sometimes also called 'Acrobat' files, from the name of Adobe's
-PDF software.) Xpdf runs under UNIX and the X Window System.
+PDF software.
-Xpdf is designed to be small and efficient. It does not use the Motif
-or Xt libraries. It uses standard X fonts. Xpdf is quite usable on a
-486-66 PC running FreeBSD.
+It can also convert PDF input to ps, text, and info formats; and
+split out fonts and images.
WWW: http://www.foolabs.com/xpdf/
+
+- Doug Barton
+DougB@FreeBSD.org
diff --git a/graphics/xpdf/pkg-plist b/graphics/xpdf/pkg-plist
index 71ffba4a7afd..a786035e651c 100644
--- a/graphics/xpdf/pkg-plist
+++ b/graphics/xpdf/pkg-plist
@@ -6,3 +6,9 @@ bin/pdftops
bin/pdftotext
bin/xpdf
etc/xpdfrc
+%%PORTDOCS%%share/doc/xpdf/ANNOUNCE
+%%PORTDOCS%%share/doc/xpdf/CHANGES
+%%PORTDOCS%%share/doc/xpdf/INSTALL
+%%PORTDOCS%%share/doc/xpdf/README
+%%PORTDOCS%%share/doc/xpdf/hello.pdf
+%%PORTDOCS%%@dirrm share/doc/xpdf