aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/linux_dri-devel/Makefile11
-rw-r--r--graphics/linux_dri/Makefile5
2 files changed, 10 insertions, 6 deletions
diff --git a/graphics/linux_dri-devel/Makefile b/graphics/linux_dri-devel/Makefile
index dce738339844..25d94b2d60f9 100644
--- a/graphics/linux_dri-devel/Makefile
+++ b/graphics/linux_dri-devel/Makefile
@@ -33,6 +33,13 @@ MODULELIST= i810_dri.so i915_dri.so mach64_dri.so mga_dri.so r128_dri.so \
sis_dri.so tdfx_dri.so
LDCONFIG_LINUX= ${LINUXBASE}/sbin/ldconfig
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 502111
+EXTRACT_DEPENDS+= bsdtar:${PORTSDIR}/archivers/libarchive
+TAR= bsdtar
+.endif
+
do-install:
${MKDIR} ${PREFIX}/usr/X11R6/lib/modules/dri
${INSTALL_PROGRAM} ${WRKSRC}/linux_dri/libGL.so.1.2 \
@@ -61,8 +68,4 @@ do-install:
post-install:
@${LDCONFIG_LINUX} ${PREFIX}/usr/X11R6/lib
-.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= does not extract on 4.x (both bz2 and gz sources are used)
-.endif
.include <bsd.port.post.mk>
diff --git a/graphics/linux_dri/Makefile b/graphics/linux_dri/Makefile
index a6c8e68932da..45f69cf51f3e 100644
--- a/graphics/linux_dri/Makefile
+++ b/graphics/linux_dri/Makefile
@@ -35,8 +35,9 @@ LDCONFIG_LINUX= ${LINUXBASE}/sbin/ldconfig
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-IGNORE= does not extract with the tar in FreeBSD 4.x
+.if ${OSVERSION} < 502111
+EXTRACT_DEPENDS+= bsdtar:${PORTSDIR}/archivers/libarchive
+TAR= bsdtar
.endif
do-install: