aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/hs-HGL/Makefile5
-rw-r--r--graphics/hs-HGL/distinfo4
-rw-r--r--graphics/hs-HGL/files/patch-Graphics__HGL__Internals__Utilities.hs27
-rw-r--r--graphics/hs-HGL/files/patch-Graphics__HGL__Run.hs20
-rw-r--r--graphics/hs-HGL/files/patch-Graphics__HGL__X11__Display.hs26
-rw-r--r--graphics/hs-HGL/files/patch-Graphics__HGL__X11__Types.hs20
-rw-r--r--graphics/hs-HGL/files/patch-HGL.cabal11
-rw-r--r--graphics/hs-HGL/pkg-descr16
-rw-r--r--graphics/hs-cairo/Makefile7
-rw-r--r--graphics/hs-cairo/distinfo4
-rw-r--r--graphics/hs-dia-base/Makefile4
-rw-r--r--graphics/hs-dia-base/files/patch-dia-base.cabal11
-rw-r--r--graphics/hs-dia-functions/Makefile6
-rw-r--r--graphics/hs-dia-functions/files/patch-dia-functions.cabal11
-rw-r--r--graphics/hs-soegtk/Makefile2
-rw-r--r--graphics/hs-svgcairo/Makefile7
-rw-r--r--graphics/hs-svgcairo/distinfo4
-rw-r--r--graphics/hs-svgcairo/pkg-descr2
18 files changed, 50 insertions, 137 deletions
diff --git a/graphics/hs-HGL/Makefile b/graphics/hs-HGL/Makefile
index 927a26188d73..2d3fb13d1304 100644
--- a/graphics/hs-HGL/Makefile
+++ b/graphics/hs-HGL/Makefile
@@ -2,14 +2,13 @@
# $FreeBSD$
PORTNAME= HGL
-PORTVERSION= 3.2.0.2
-PORTREVISION= 14
+PORTVERSION= 3.2.0.5
CATEGORIES= graphics haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Simple Haskell graphics library based on X11 or Win32
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
USE_CABAL= X11
diff --git a/graphics/hs-HGL/distinfo b/graphics/hs-HGL/distinfo
index a01b658da4ff..d1b37ef35816 100644
--- a/graphics/hs-HGL/distinfo
+++ b/graphics/hs-HGL/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/HGL-3.2.0.2.tar.gz) = 7f0734d1a8a8ad1fdfff44b7838a2d8e6aef025a08549461bc2946b78cdb8c8f
-SIZE (cabal/HGL-3.2.0.2.tar.gz) = 38914
+SHA256 (cabal/HGL-3.2.0.5.tar.gz) = 8b97240ff97d3e5eda09d8ceead6e6d7315e444bdbbfd3b9a260942e5e770d7d
+SIZE (cabal/HGL-3.2.0.5.tar.gz) = 39012
diff --git a/graphics/hs-HGL/files/patch-Graphics__HGL__Internals__Utilities.hs b/graphics/hs-HGL/files/patch-Graphics__HGL__Internals__Utilities.hs
deleted file mode 100644
index d09a4cb11689..000000000000
--- a/graphics/hs-HGL/files/patch-Graphics__HGL__Internals__Utilities.hs
+++ /dev/null
@@ -1,27 +0,0 @@
---- ./Graphics/HGL/Internals/Utilities.hs.orig 2009-11-03 15:50:11.000000000 +0100
-+++ ./Graphics/HGL/Internals/Utilities.hs 2013-05-01 01:30:47.000000000 +0200
-@@ -20,7 +20,7 @@
- modMVar, modMVar_
- ) where
-
--import qualified Control.Exception as E (bracket, try, IOException, tryJust, ioErrors)
-+import qualified Control.Exception as E (bracket, try, IOException, tryJust)
- import Control.Concurrent( MVar, takeMVar, putMVar )
-
- bracket :: IO a -> (a -> IO b) -> (a -> IO c) -> IO c
-@@ -32,15 +32,7 @@
-
- type Exception = E.IOException
- safeTry :: IO a -> IO (Either Exception a)
--
--#if __GLASGOW_HASKELL >= 610
---- ghc-6.10
- safeTry = E.try
--#else
---- ghc 6.8 (and below?)
--safeTry = E.tryJust E.ioErrors
--#endif
--
-
- ----------------------------------------------------------------
- -- Utilities
diff --git a/graphics/hs-HGL/files/patch-Graphics__HGL__Run.hs b/graphics/hs-HGL/files/patch-Graphics__HGL__Run.hs
deleted file mode 100644
index 5e29c6df339a..000000000000
--- a/graphics/hs-HGL/files/patch-Graphics__HGL__Run.hs
+++ /dev/null
@@ -1,20 +0,0 @@
---- ./Graphics/HGL/Run.hs.orig 2009-11-03 15:50:11.000000000 +0100
-+++ ./Graphics/HGL/Run.hs 2013-05-01 01:51:50.000000000 +0200
-@@ -24,7 +24,7 @@
- import Graphics.HGL.Internals.Utilities (safeTry)
- import Control.Concurrent (forkIO, yield)
- import Data.IORef( newIORef, readIORef, writeIORef )
--import System.IO.Error (try)
-+import System.IO.Error (tryIOError)
- #endif
-
- ----------------------------------------------------------------
-@@ -60,7 +60,7 @@
- beginGraphics
- quit <- newIORef False
- safeTry $ do
-- forkIO (try m >> writeIORef quit True)
-+ forkIO (tryIOError m >> writeIORef quit True)
- yield
- handleEvents (readIORef quit)
- endGraphics
diff --git a/graphics/hs-HGL/files/patch-Graphics__HGL__X11__Display.hs b/graphics/hs-HGL/files/patch-Graphics__HGL__X11__Display.hs
deleted file mode 100644
index 0951e6ec3eee..000000000000
--- a/graphics/hs-HGL/files/patch-Graphics__HGL__X11__Display.hs
+++ /dev/null
@@ -1,26 +0,0 @@
---- ./Graphics/HGL/X11/Display.hs.orig 2009-11-03 15:50:11.000000000 +0100
-+++ ./Graphics/HGL/X11/Display.hs 2013-05-01 02:01:44.000000000 +0200
-@@ -14,12 +14,12 @@
- import Control.Monad (when)
- import Data.Maybe (isJust)
- import System.Environment (getEnv)
--import System.IO.Error (try)
-+import System.IO.Error (tryIOError, catchIOError)
- import System.IO.Unsafe (unsafePerformIO)
-
- getDisplayName :: IO String
- getDisplayName = do
-- disp <- try (getEnv "DISPLAY")
-+ disp <- tryIOError (getEnv "DISPLAY")
- return (either (const ":0.0") id disp)
-
- displayRef :: MVar (Maybe X.Display)
-@@ -32,7 +32,7 @@
- openDisplay'
- where
- openDisplay' = do
-- display <- X.openDisplay host `catch` \ err ->
-+ display <- X.openDisplay host `catchIOError` \ err ->
- ioError (userError ("Unable to open X display " ++ host))
- modMVar displayRef (const $ Just display)
- return display
diff --git a/graphics/hs-HGL/files/patch-Graphics__HGL__X11__Types.hs b/graphics/hs-HGL/files/patch-Graphics__HGL__X11__Types.hs
deleted file mode 100644
index 892c5fe75355..000000000000
--- a/graphics/hs-HGL/files/patch-Graphics__HGL__X11__Types.hs
+++ /dev/null
@@ -1,20 +0,0 @@
---- ./Graphics/HGL/X11/Types.hs.orig 2009-11-03 15:50:11.000000000 +0100
-+++ ./Graphics/HGL/X11/Types.hs 2013-05-01 01:53:35.000000000 +0200
-@@ -30,6 +30,7 @@
- import Control.Concurrent.MVar (MVar)
- import Data.Bits
- import Data.Word (Word8)
-+import System.IO.Error
-
- ----------------------------------------------------------------
- -- Units
-@@ -84,8 +85,7 @@
- (X.Color p _ _ _ _) <-
- X.allocColor display color_map (X.Color 0 r g b xcolor_flags)
- return p)
-- `catch` \ err ->
-- print err >> return 0
-+ `catchIOError` \err -> print err >> return 0
- -- ioError (userError ("Error: " ++ show err
- -- ++ "\nUnable to allocate colo[u]r " ++ show (r,g,b)
- -- ++ " - I'll bet you're running Netscape."))
diff --git a/graphics/hs-HGL/files/patch-HGL.cabal b/graphics/hs-HGL/files/patch-HGL.cabal
deleted file mode 100644
index 3733424e49f1..000000000000
--- a/graphics/hs-HGL/files/patch-HGL.cabal
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./HGL.cabal.orig 2009-11-03 15:50:11.000000000 +0100
-+++ ./HGL.cabal 2011-03-13 18:29:56.867337655 +0100
-@@ -22,7 +22,7 @@
-
- library
- if flag(split-base)
-- build-depends: base >= 3 && < 4, array
-+ build-depends: base >= 3, array
- else
- build-depends: base < 2
- exposed-modules:
diff --git a/graphics/hs-HGL/pkg-descr b/graphics/hs-HGL/pkg-descr
index 893d95650fd7..b4b577c9b34d 100644
--- a/graphics/hs-HGL/pkg-descr
+++ b/graphics/hs-HGL/pkg-descr
@@ -1,10 +1,8 @@
-A simple graphics library, designed to give the programmer access to most
-interesting parts of the Win32 Graphics Device Interface and X11 library
-without exposing the programmer to the pain and anguish usually associated with
-using these interfaces.
+A simple graphics library, designed to give the programmer access to
+most interesting parts of the Win32 Graphics Device Interface and X11
+library without exposing the programmer to the pain and anguish usually
+associated with using these interfaces. The library also includes a
+module Graphics.SOE providing the interface used in "The Haskell School
+of Expression", by Paul Hudak.
-The library also includes a module Graphics.SOE providing the interface used
-in "The Haskell School of Expression", by Paul Hudak,
-cf <http://www.haskell.org/soe/>.
-
-WWW: http://www.haskell.org/graphics/index.html
+WWW: http://hackage.haskell.org/package/HGL
diff --git a/graphics/hs-cairo/Makefile b/graphics/hs-cairo/Makefile
index 939c84938786..75f31bd54cfb 100644
--- a/graphics/hs-cairo/Makefile
+++ b/graphics/hs-cairo/Makefile
@@ -1,17 +1,16 @@
# $FreeBSD$
PORTNAME= cairo
-PORTVERSION= 0.12.4
-PORTREVISION= 6
+PORTVERSION= 0.12.5.3
CATEGORIES= graphics haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Binding to the Cairo library
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
USES= pkgconfig
-USE_CABAL= gtk2hs-buildtools mtl
+USE_CABAL= gtk2hs-buildtools mtl utf8-string>=0.2
BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/cairo-pdf.pc:${PORTSDIR}/graphics/cairo
diff --git a/graphics/hs-cairo/distinfo b/graphics/hs-cairo/distinfo
index 73b76d2f3d3c..db93abd22866 100644
--- a/graphics/hs-cairo/distinfo
+++ b/graphics/hs-cairo/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/cairo-0.12.4.tar.gz) = 783943379a6b02e8645dd29960e057bea8d05a7afa12a918d87e54d561b7c63f
-SIZE (cabal/cairo-0.12.4.tar.gz) = 50933
+SHA256 (cabal/cairo-0.12.5.3.tar.gz) = e7edb538745a6f0aa1c0c1574b6549a799240912f9c5047c3d8ca1ffdbb1bcbc
+SIZE (cabal/cairo-0.12.5.3.tar.gz) = 53447
diff --git a/graphics/hs-dia-base/Makefile b/graphics/hs-dia-base/Makefile
index a2cc225766bb..d912715febbf 100644
--- a/graphics/hs-dia-base/Makefile
+++ b/graphics/hs-dia-base/Makefile
@@ -2,13 +2,13 @@
PORTNAME= dia-base
PORTVERSION= 0.1.1.2
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= EDSL for teaching Haskell with diagrams - data types
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/graphics/hs-dia-base/files/patch-dia-base.cabal b/graphics/hs-dia-base/files/patch-dia-base.cabal
new file mode 100644
index 000000000000..dc90e48c18b8
--- /dev/null
+++ b/graphics/hs-dia-base/files/patch-dia-base.cabal
@@ -0,0 +1,11 @@
+--- ./dia-base.cabal.orig 2012-09-11 09:44:42.000000000 +0200
++++ ./dia-base.cabal 2014-07-12 22:27:19.000000000 +0200
+@@ -27,7 +27,7 @@
+ Graphics.Diagrams
+
+ Build-Depends:
+- base >= 4.0 && < 4.7,
++ base >= 4.0 && < 4.8,
+ deepseq >= 1.1 && < 1.4
+
+
diff --git a/graphics/hs-dia-functions/Makefile b/graphics/hs-dia-functions/Makefile
index 1ca80c3c98e4..3136c0a0eb80 100644
--- a/graphics/hs-dia-functions/Makefile
+++ b/graphics/hs-dia-functions/Makefile
@@ -2,15 +2,15 @@
PORTNAME= dia-functions
PORTVERSION= 0.2.1.3
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= EDSL for teaching Haskell with diagrams - functions
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
-USE_CABAL= data-pprint>=0.2 dia-base>=0.1 mtl>=2.0 xhtml>=3000.2
+USE_CABAL= data-pprint>=0.2 dia-base>=0.1 mtl>=2.0
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/graphics/hs-dia-functions/files/patch-dia-functions.cabal b/graphics/hs-dia-functions/files/patch-dia-functions.cabal
new file mode 100644
index 000000000000..6d134c18c85b
--- /dev/null
+++ b/graphics/hs-dia-functions/files/patch-dia-functions.cabal
@@ -0,0 +1,11 @@
+--- ./dia-functions.cabal.orig 2012-09-11 09:47:34.000000000 +0200
++++ ./dia-functions.cabal 2014-07-13 01:36:21.000000000 +0200
+@@ -30,7 +30,7 @@
+ Build-Depends:
+ data-pprint >= 0.2 && < 0.3,
+ dia-base >= 0.1 && < 0.2,
+- base >= 4.0 && < 4.7,
++ base >= 4.0 && < 4.8,
+ containers >= 0.4 && < 0.6,
+ xhtml >= 3000.2 && < 3000.3,
+ mtl >= 2.0 && < 2.2,
diff --git a/graphics/hs-soegtk/Makefile b/graphics/hs-soegtk/Makefile
index 5ce78a262bb5..f30af8d8265f 100644
--- a/graphics/hs-soegtk/Makefile
+++ b/graphics/hs-soegtk/Makefile
@@ -2,7 +2,7 @@
PORTNAME= soegtk
PORTVERSION= 0.12.1
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= graphics haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/graphics/hs-svgcairo/Makefile b/graphics/hs-svgcairo/Makefile
index 47a07b3fceba..755573486bc3 100644
--- a/graphics/hs-svgcairo/Makefile
+++ b/graphics/hs-svgcairo/Makefile
@@ -1,17 +1,16 @@
# $FreeBSD$
PORTNAME= svgcairo
-PORTVERSION= 0.12.1.1
-PORTREVISION= 8
+PORTVERSION= 0.12.5.2
CATEGORIES= graphics haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Binding to the libsvg-cairo library
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
USES= pkgconfig
-USE_CABAL= cairo>=0.12 glib>=0.12 mtl
+USE_CABAL= cairo>=0.12.5.0 glib>=0.12.5.0 mtl
USE_GNOME= librsvg2
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
diff --git a/graphics/hs-svgcairo/distinfo b/graphics/hs-svgcairo/distinfo
index 91905b56bb27..6a0067675cf6 100644
--- a/graphics/hs-svgcairo/distinfo
+++ b/graphics/hs-svgcairo/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/svgcairo-0.12.1.1.tar.gz) = 0bbe3b204ed4f4286abfdea2ae2f7111f0d191bf9decfe7de63b2fb23575893a
-SIZE (cabal/svgcairo-0.12.1.1.tar.gz) = 12896
+SHA256 (cabal/svgcairo-0.12.5.2.tar.gz) = 94a428cae854e8d99c16d76838c602298beafd36bd36d92b4ff396f6dd006950
+SIZE (cabal/svgcairo-0.12.5.2.tar.gz) = 13759
diff --git a/graphics/hs-svgcairo/pkg-descr b/graphics/hs-svgcairo/pkg-descr
index e5151924327d..bd9cdf7ca3fd 100644
--- a/graphics/hs-svgcairo/pkg-descr
+++ b/graphics/hs-svgcairo/pkg-descr
@@ -1,3 +1,3 @@
Svgcairo is used to render SVG with cairo.
-WWW: http://www.haskell.org/gtk2hs/
+WWW: http://projects.haskell.org/gtk2hs/