aboutsummaryrefslogtreecommitdiff
path: root/irc/gruftistats/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/gruftistats/Makefile')
-rw-r--r--irc/gruftistats/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/irc/gruftistats/Makefile b/irc/gruftistats/Makefile
new file mode 100644
index 000000000000..34c9b7ea5100
--- /dev/null
+++ b/irc/gruftistats/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: gruftistats
+# Date created: 29 October 2001
+# Whom: Matthew West <mwest@uct.ac.za>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gruftistats
+PORTVERSION= 0.2.4
+CATEGORIES= irc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gruftistats
+
+MAINTAINER= mwest@uct.ac.za
+
+GNU_CONFIGURE= YES
+USE_GMAKE= YES
+
+.if defined(NOPORTDOCS)
+MAKE_ARGS= NOPORTDOCS=1
+.endif
+
+MAN1= gruftistats.1
+
+post-patch:
+ @${PERL} -pi -e 's,strcasestr,strcasestr_x,g' ${WRKSRC}/ircstats.h \
+ ${WRKSRC}/lib.c
+
+.include <bsd.port.mk>