aboutsummaryrefslogtreecommitdiff
path: root/japanese/edict
diff options
context:
space:
mode:
Diffstat (limited to 'japanese/edict')
-rw-r--r--japanese/edict/Makefile19
-rw-r--r--japanese/edict/distinfo6
-rw-r--r--japanese/edict/files/patch-Makefile (renamed from japanese/edict/files/patch-aa)0
-rw-r--r--japanese/edict/files/patch-exjdxgen.c11
-rw-r--r--japanese/edict/files/patch-xjdic.h (renamed from japanese/edict/files/patch-ab)0
-rw-r--r--japanese/edict/files/patch-xjdxgen.c11
-rw-r--r--japanese/edict/pkg-plist4
7 files changed, 34 insertions, 17 deletions
diff --git a/japanese/edict/Makefile b/japanese/edict/Makefile
index bd31b19f129c..b2b462bc6c74 100644
--- a/japanese/edict/Makefile
+++ b/japanese/edict/Makefile
@@ -7,10 +7,16 @@
PORTNAME= edict
PORTVERSION= 19990714
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= japanese
-MASTER_SITES= ftp://ftp.sedl.org/pub/mirrors/nihongo/ \
+MASTER_SITES= \
+ http://japanology.arts.kuleuven.ac.be/mirrors/monash/ \
+ http://www.bcit-broadcast.com/monash/ \
+ ftp://ftp.mirrorservice.org/sites/ftp.cc.monash.edu.au/pub/nihongo/ \
+ ftp://ftp.edrdg.org/pub/Nihongo/ \
ftp://ftp.u-aizu.ac.jp/pub/SciEng/nihongo/ftp.cc.monash.edu.au/ \
+ ftp://ftp.funet.fi/pub/culture/japan/mirrors/monash/pub/nihongo/ \
+ ftp://ftp.uni-duisburg.de/Mirrors/ftp.monash.edu.au/pub/nihongo/ \
ftp://ftp.cc.monash.edu.au/pub/nihongo/
EXTRACT_SUFX=
DISTFILES= ${DICTFILES} ${SRCFILES} ${DOCFILES}
@@ -27,15 +33,15 @@ DICTFILES= edict.gz edicth enamdict.gz compdic.gz \
kanjidic.gz kanjd212.gz lawgledt.zip \
lingdic.zip geodic.gz pandpdic.zip \
aviation.zip findic.zip mktdic.zip \
- compverb.gz 4jword3_edict.zip concrete.zip
+ 4jword3_edict.zip concrete.zip
SRCFILES= xjdic23.tgz
-DOCFILES= edict_doc.txt edict_doc.html edicth.doc \
+DOCFILES= edict_doc.html edicth.doc \
enamdict_doc.txt enamdict_doc.html \
j_places.inf kanjidic.doc kanjd212.doc ediclsd3.rme \
lawgldoc.new lingdic.txt geodic.doc aviation.txt \
- findic.doc mktdic.doc compverb.doc 4jword3_inf.txt \
+ findic.doc mktdic.doc 4jword3_inf.txt \
concrete.doc
#
@@ -55,7 +61,7 @@ NO_WRKSUBDIR= yes
.include <bsd.port.pre.mk>
.if ${ARCH} != "i386"
-BROKEN= "Does not build"
+BROKEN= Does not build
.endif
do-extract:
@@ -148,7 +154,6 @@ do-install:
@${ECHO_CMD} dicfile aviation >> ${DATADIR}/.xjdicrc
# @${ECHO_CMD} dicfile findic >> ${DATADIR}/.xjdicrc
# @${ECHO_CMD} dicfile mktdic >> ${DATADIR}/.xjdicrc
- @${ECHO_CMD} dicfile compverb >> ${DATADIR}/.xjdicrc
@${ECHO_CMD} dicfile 4jword3_edict.euc >> ${DATADIR}/.xjdicrc
# @${ECHO_CMD} dicfile concrete.doc >> ${DATADIR}/.xjdicrc
# @${ECHO_CMD} dicfile lingdic >> ${DATADIR}/.xjdicrc
diff --git a/japanese/edict/distinfo b/japanese/edict/distinfo
index a86457cd4cb8..0374ed55662b 100644
--- a/japanese/edict/distinfo
+++ b/japanese/edict/distinfo
@@ -31,14 +31,10 @@ MD5 (edict/findic.zip) = IGNORE
SHA256 (edict/findic.zip) = IGNORE
MD5 (edict/mktdic.zip) = IGNORE
SHA256 (edict/mktdic.zip) = IGNORE
-MD5 (edict/compverb.gz) = IGNORE
-SHA256 (edict/compverb.gz) = IGNORE
MD5 (edict/4jword3_edict.zip) = IGNORE
SHA256 (edict/4jword3_edict.zip) = IGNORE
MD5 (edict/concrete.zip) = IGNORE
SHA256 (edict/concrete.zip) = IGNORE
-MD5 (edict/edict_doc.txt) = IGNORE
-SHA256 (edict/edict_doc.txt) = IGNORE
MD5 (edict/edict_doc.html) = IGNORE
SHA256 (edict/edict_doc.html) = IGNORE
MD5 (edict/edicth.doc) = IGNORE
@@ -67,8 +63,6 @@ MD5 (edict/findic.doc) = IGNORE
SHA256 (edict/findic.doc) = IGNORE
MD5 (edict/mktdic.doc) = IGNORE
SHA256 (edict/mktdic.doc) = IGNORE
-MD5 (edict/compverb.doc) = IGNORE
-SHA256 (edict/compverb.doc) = IGNORE
MD5 (edict/4jword3_inf.txt) = IGNORE
SHA256 (edict/4jword3_inf.txt) = IGNORE
MD5 (edict/concrete.doc) = IGNORE
diff --git a/japanese/edict/files/patch-aa b/japanese/edict/files/patch-Makefile
index 56d01b34317b..56d01b34317b 100644
--- a/japanese/edict/files/patch-aa
+++ b/japanese/edict/files/patch-Makefile
diff --git a/japanese/edict/files/patch-exjdxgen.c b/japanese/edict/files/patch-exjdxgen.c
new file mode 100644
index 000000000000..bcf4737ed1b8
--- /dev/null
+++ b/japanese/edict/files/patch-exjdxgen.c
@@ -0,0 +1,11 @@
+--- exjdxgen.c.orig 1998-05-24 08:43:37.000000000 -0700
++++ exjdxgen.c 2008-03-06 11:39:23.000000000 -0800
+@@ -22,7 +22,7 @@
+ #include <sys/stat.h>
+
+ #include <stdio.h>
+-/*#include <stdlib.h>*/
++#include <stdlib.h>
+ #include <ctype.h>
+ #include <string.h>
+ #include "xjdic.h"
diff --git a/japanese/edict/files/patch-ab b/japanese/edict/files/patch-xjdic.h
index 2dc40879b18d..2dc40879b18d 100644
--- a/japanese/edict/files/patch-ab
+++ b/japanese/edict/files/patch-xjdic.h
diff --git a/japanese/edict/files/patch-xjdxgen.c b/japanese/edict/files/patch-xjdxgen.c
new file mode 100644
index 000000000000..087d117446b5
--- /dev/null
+++ b/japanese/edict/files/patch-xjdxgen.c
@@ -0,0 +1,11 @@
+--- xjdxgen.c.orig 1998-09-10 20:04:21.000000000 -0700
++++ xjdxgen.c 2008-03-06 11:40:41.000000000 -0800
+@@ -23,7 +23,7 @@
+ #include <sys/stat.h>
+
+ #include <stdio.h>
+-/*#include <stdlib.h>*/
++#include <stdlib.h>
+ #include <ctype.h>
+ #include <string.h>
+ #include "xjdic.h"
diff --git a/japanese/edict/pkg-plist b/japanese/edict/pkg-plist
index ab040e1070aa..de398ff3a23a 100644
--- a/japanese/edict/pkg-plist
+++ b/japanese/edict/pkg-plist
@@ -10,8 +10,6 @@ share/dict/edict/aviation
share/dict/edict/aviation.xjdx
share/dict/edict/compdic
share/dict/edict/compdic.xjdx
-share/dict/edict/compverb
-share/dict/edict/compverb.xjdx
share/dict/edict/concrete
share/dict/edict/concrete.xjdx
share/dict/edict/ediclsd3
@@ -49,11 +47,9 @@ share/dict/edict/.xjdicrc
@dirrm share/dict/edict
share/doc/xjdic/4jword3_inf.txt
share/doc/xjdic/aviation.txt
-share/doc/xjdic/compverb.doc
share/doc/xjdic/concrete.doc
share/doc/xjdic/ediclsd3.rme
share/doc/xjdic/edict_doc.html
-share/doc/xjdic/edict_doc.txt
share/doc/xjdic/edicth.doc
share/doc/xjdic/enamdict_doc.html
share/doc/xjdic/enamdict_doc.txt