aboutsummaryrefslogtreecommitdiff
path: root/japanese/groff/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'japanese/groff/Makefile')
-rw-r--r--japanese/groff/Makefile101
1 files changed, 46 insertions, 55 deletions
diff --git a/japanese/groff/Makefile b/japanese/groff/Makefile
index 027b87a907e9..a33e44162e7c 100644
--- a/japanese/groff/Makefile
+++ b/japanese/groff/Makefile
@@ -6,23 +6,21 @@
#
PORTNAME= groff
-PORTVERSION= 0.100
-PORTREVISION= 3
+PORTVERSION= 1.17
CATEGORIES= japanese print
MASTER_SITES= ${MASTER_SITE_LOCAL:S,%SUBDIR%,okazaki/&,} \
${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= groff
-DISTNAME= ${PORTNAME}-1.15
-DISTFILES= ${DISTNAME}.tar.gz ${TMAC_DISTNAME}.tar.gz
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${TMAC_DISTNAME}.tar.gz
PATCH_SITES= ${MASTER_SITE_LOCAL}
-PATCH_SITE_SUBDIR= okazaki
-PATCHFILES= ${DISTNAME}-jgroff-${PORTVERSION}-pl1.diff.gz
+PATCH_SITE_SUBDIR= okazaki/groff
+PATCHFILES= ${DISTNAME}-jgroff-0.0.1.diff.gz
PATCH_DIST_STRIP= -p1
MAINTAINER= okazaki@FreeBSD.org
-TMAC_DATE= 20010314
+TMAC_DATE= 20010614
TMAC_DISTNAME= tmac-${TMAC_DATE}
USE_GMAKE= yes
@@ -35,82 +33,75 @@ CONFIGURE_ENV= INSTALL="${INSTALL}" \
INSTALL_DATA="${INSTALL_DATA}" \
INSTALL_MAN="${INSTALL_MAN}"
-TMACBASE= ${WRKDIR}/${TMAC_DISTNAME}
-TMACDIR= share/groff/tmac
+TMACBASE= ${WRKDIR}/tmac
+TMACDIR= share/groff/${PORTVERSION}/tmac
+SITETMACDIR= share/groff/site-tmac
MDOCDIR= ${TMACDIR}/mdoc
-LOCALEDIR= ${MDOCDIR}/locale
INFODIR= ${PREFIX}/info
PORTDOCDIR= share/doc/jgroff
+PLIST_SUB= GROFF_VERSION=${PORTVERSION}
-DESCFILES= devascii/DESC.proto devdvi-ascii/DESC.in \
- devdvi/DESC.in devhtml/DESC devlatin1/DESC.proto \
- devlj4/DESC.in devnippon/DESC.proto devps/DESC.in
-
-MAN1SRC= eqn.1 indxbib.1 lookbib.1 nroff.1 pic.1 \
- refer.1 soelim.1 tbl.1 troff.1
-
-MAN1= ${MAN1SRC:S/^/g/g} addftinfo.1 afmtodit.1 grodvi.1 \
- groff.1 grog.1 grohtml.1 grolj4.1 grops.1 grotty.1 \
- hpftodit.1 lkbib.1 pfbtops.1 psbb.1 tfmtodit.1
-MAN5= groff_font.5 groff_out.5
-MAN7= groff_char.7 groff_man.7 groff_mdoc.7 groff_mdoc.samples.7 \
- groff_me.7 groff_mm.7 groff_mmse.7 groff_ms.7 groff_msafer.7
-
-TMACFILES= tmac.X tmac.a4 \
- tmac.an tmac.an-old tmac.andoc tmac.arkup \
- tmac.doc tmac.dvi tmac.html \
- tmac.latin1 tmac.lbp tmac.m \
- tmac.man tmac.mandoc tmac.markup tmac.mdoc \
- tmac.me tmac.ms tmac.mse \
- tmac.orig_me tmac.pspic tmac.s tmac.safer \
- tmac.trace tmac.tty tmac.tty-char tmac.vgrind \
- eqnrc troffrc troffrc-end
-MDOCFILES= doc-common doc-ditroff doc-nroff doc-syms
-LOCALEFILES= locale-list eucJP
+MAN1SRC= eqn.1 indxbib.1 lookbib.1 neqn.1 nroff.1 pic.1 \
+ refer.1 soelim.1 tbl.1 troff.1 grn.1
+
+MAN1= ${MAN1SRC:S/^/g/g} \
+ addftinfo.1 afmtodit.1 grodvi.1 \
+ groff.1 grog.1 \
+ grohtml.1 grolbp.1 grolj4.1 grops.1 grotty.1 \
+ hpftodit.1 lkbib.1 pfbtops.1 tfmtodit.1
+MAN5= groff_font.5 groff_out.5 groff_tmac.5
+MAN7= groff.7 groff_char.7 groff_man.7 groff_mdoc.7 \
+ groff_me.7 groff_mm.7 groff_mmse.7 groff_ms.7 \
+ groff_mwww.7 mmroff.7 roff.7
+
+SITETMACFILES= mdoc.local
+TMACFILES= tmac.orig_me tmac.vgrind
+MDOCFILES= eucJP
DOCUMENTS= ChangeLog.jp NEWS PROBLEMS README README.jp \
doc/meintro.me doc/meref.me doc/pic.ms
-TROFFRC_FILTER= -e 's,^(.do ds troffrc!koi8-r tmac.tty)$$,$$1\n.do ds troffrc!nippon tmac.tty,;'
-EQNRC_FILTER= -e 's,^(ifdef koi8-r ! define n %1% !)$$,$$1\nifdef nippon ! define n %1% !,;'
+.include <bsd.port.pre.mk>
-#for not writing "/usr/local" explicitly in the patch
-post-patch:
- cd ${WRKSRC} \
- && ${PERL} -pi -e 's:^(postpro +):$$1${PREFIX}/bin/:g;' ${DESCFILES}
+.if ${OSVERSION} < 350001
+WITHOUT_INFO= yes
+PLIST_SUB+= INFO="@comment "
+.else
+PLIST_SUB+= INFO=""
+.endif
-.include <bsd.port.pre.mk>
+TEXINFO_FILTER= -e 's/\@acronym/\@var/g;' \
+ -e 's/ifnottex/ifinfo/g;' \
+ -e 's/ifnotinfo/iftex/g;' \
+ -e 's/\@option/\@samp/g;' \
+ -e 's/\@env/\@code/g;'
post-build:
+.if !defined(WITHOUT_INFO)
cd ${WRKSRC}/doc && makeinfo --no-split groff.texinfo
+.endif
post-install:
+.if !defined(WITHOUT_INFO)
@${MAKE} install-info
+.endif
.if !defined(NOPORTDOCS)
@${MAKE} install-documents
.endif
+.for FILE in ${SITETMACFILES}
+ ${INSTALL_DATA} ${TMACBASE}/${FILE} ${PREFIX}/${SITETMACDIR}
+.endfor
.for FILE in ${TMACFILES}
${INSTALL_DATA} ${TMACBASE}/${FILE} ${PREFIX}/${TMACDIR}
.endfor
.for FILE in ${MDOCFILES}
${INSTALL_DATA} ${TMACBASE}/mdoc/${FILE} ${PREFIX}/${MDOCDIR}
.endfor
- ${MKDIR} ${PREFIX}/${LOCALEDIR}
-.for FILE in ${LOCALEFILES}
- ${INSTALL_DATA} ${FILESDIR}/${FILE} ${PREFIX}/${LOCALEDIR}
-.endfor
- ${MKDIR} ${PREFIX}/${TMACDIR}/locale
- ${INSTALL_DATA} ${TMACBASE}/locale/hyphen.* ${PREFIX}/${TMACDIR}/locale
-.if defined(TROFFRC_FILTER) && !empty(TROFFRC_FILTER)
- ${PERL} -pi ${TROFFRC_FILTER} ${PREFIX}/${TMACDIR}/troffrc
-.endif
-.if defined(EQNRC_FILTER) && !empty(EQNRC_FILTER)
- ${PERL} -pi ${EQNRC_FILTER} ${PREFIX}/${TMACDIR}/eqnrc
-.endif
install-documents:
@${MKDIR} ${PREFIX}/${PORTDOCDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${DOCUMENTS} ${PREFIX}/${PORTDOCDIR}
+ cd ${INSTALL_WRKSRC} \
+ && ${INSTALL_DATA} ${DOCUMENTS} ${PREFIX}/${PORTDOCDIR}
install-info:
${INSTALL_DATA} ${WRKSRC}/doc/groff ${INFODIR}