aboutsummaryrefslogtreecommitdiff
path: root/japanese/msdosfs
diff options
context:
space:
mode:
Diffstat (limited to 'japanese/msdosfs')
-rw-r--r--japanese/msdosfs/Makefile2
-rw-r--r--japanese/msdosfs/files/revlist4
-rw-r--r--japanese/msdosfs/patches.4/patch-ab18
-rw-r--r--japanese/msdosfs/patches.4/patch-ah11
4 files changed, 31 insertions, 4 deletions
diff --git a/japanese/msdosfs/Makefile b/japanese/msdosfs/Makefile
index b140f4d37fe7..d7af9bedd1d5 100644
--- a/japanese/msdosfs/Makefile
+++ b/japanese/msdosfs/Makefile
@@ -22,7 +22,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/msdosfs.ja
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 410001 && ${OSVERSION} < 500000
-LAST_UPDATED= 20001007
+LAST_UPDATED= 20001027
PATCHDIR= ${MASTERDIR}/patches.4
.elif ${OSVERSION} >= 500013
LAST_UPDATED= 20001022
diff --git a/japanese/msdosfs/files/revlist b/japanese/msdosfs/files/revlist
index 49fd5edda1e5..9ac73f2f71e6 100644
--- a/japanese/msdosfs/files/revlist
+++ b/japanese/msdosfs/files/revlist
@@ -6,7 +6,7 @@ This is a table of revisions about this ja-msdosfs.
BRANCH RELENG_4 MAIN
+-------------------+---------------+-----------+
bootsect.h 1.7 1.7
- bpb.h 1.7 1.8
+ bpb.h 1.7.2.1 1.8
denode.h 1.20 1.21
direntry.h 1.15 1.15
fat.h 1.9 1.9
@@ -16,5 +16,5 @@ This is a table of revisions about this ja-msdosfs.
msdosfs_lookup.c 1.30 1.32
msdosfs_vfsops.c 1.60.2.2 1.66
msdosfs_vnops.c 1.95.2.1 1.106
- msdosfsmount.h 1.20.2.1 1.22
+ msdosfsmount.h 1.20.2.2 1.22
+-------------------+---------------+-----------+
diff --git a/japanese/msdosfs/patches.4/patch-ab b/japanese/msdosfs/patches.4/patch-ab
new file mode 100644
index 000000000000..20bc8a4eb43e
--- /dev/null
+++ b/japanese/msdosfs/patches.4/patch-ab
@@ -0,0 +1,18 @@
+--- bpb.h.orig Sat Aug 28 09:48:07 1999
++++ bpb.h Sat Oct 28 02:57:36 2000
+@@ -113,8 +113,14 @@
+ * 16-bit and 32-bit quantities on byte boundaries. If this is not true,
+ * use the macros for the big-endian case.
+ */
++
+ #include <machine/endian.h>
+-#if (BYTE_ORDER == LITTLE_ENDIAN) /* && defined(UNALIGNED_ACCESS) */
++
++#ifdef __i386__
++#define UNLALIGNED_ACCESS
++#endif
++
++#if (BYTE_ORDER == LITTLE_ENDIAN) && defined(UNALIGNED_ACCESS)
+ #define getushort(x) *((u_int16_t *)(x))
+ #define getulong(x) *((u_int32_t *)(x))
+ #define putushort(p, v) (*((u_int16_t *)(p)) = (v))
diff --git a/japanese/msdosfs/patches.4/patch-ah b/japanese/msdosfs/patches.4/patch-ah
index d714accfe832..3ec10f002556 100644
--- a/japanese/msdosfs/patches.4/patch-ah
+++ b/japanese/msdosfs/patches.4/patch-ah
@@ -1,5 +1,14 @@
--- msdosfsmount.h.orig Mon Apr 10 04:32:37 2000
-+++ msdosfsmount.h Wed Oct 4 00:13:52 2000
++++ msdosfsmount.h Sat Oct 28 02:57:45 2000
+@@ -84,7 +84,7 @@
+ u_long pm_fatblocksize; /* size of fat blocks in bytes */
+ u_long pm_fatblocksec; /* size of fat blocks in sectors */
+ u_long pm_fatsize; /* size of fat in bytes */
+- u_long pm_fatmask; /* mask to use for fat numbers */
++ u_int32_t pm_fatmask; /* mask to use for fat numbers */
+ u_long pm_fsinfo; /* fsinfo block number */
+ u_long pm_nxtfree; /* next free cluster in fsinfo block */
+ u_int pm_fatmult; /* these 2 values are used in fat */
@@ -198,6 +198,7 @@
(1024 << ((pmp)->pm_BlkPerSec >> 2))