aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
Diffstat (limited to 'java')
-rw-r--r--java/eclipse-aptana2/Makefile55
-rw-r--r--java/eclipse-aptana2/distinfo3
-rw-r--r--java/eclipse-aptana2/pkg-descr6
-rw-r--r--java/netbeans61/Makefile47
-rw-r--r--java/netbeans61/distinfo3
-rw-r--r--java/netbeans61/files/patch-etc_netbeans.conf14
-rw-r--r--java/netbeans61/files/patch-harness_run.xml14
-rw-r--r--java/netbeans61/files/patch-platform8_lib_nbexec56
-rw-r--r--java/netbeans61/files/pkg-deinstall.in9
-rw-r--r--java/netbeans61/files/pkg-install.in9
-rw-r--r--java/netbeans61/pkg-descr7
11 files changed, 0 insertions, 223 deletions
diff --git a/java/eclipse-aptana2/Makefile b/java/eclipse-aptana2/Makefile
deleted file mode 100644
index 2693b5cbad10..000000000000
--- a/java/eclipse-aptana2/Makefile
+++ /dev/null
@@ -1,55 +0,0 @@
-# New ports collection makefile for: eclipse-aptana
-# Date created: 2007-11-14
-# Whom: Nicola Vitale <nivit@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= aptana
-PORTVERSION= 1.1.6.009905
-PORTEPOCH= 1
-CATEGORIES= java devel
-MASTER_SITES= http://update.aptana.com/install/studio/${ECLIPSE_VER}/
-PKGNAMEPREFIX= eclipse-
-DISTNAME= aptana_update_${PORTVERSION:E}
-
-MAINTAINER= nivit@FreeBSD.org
-COMMENT= Aptana Web Development Tools (Eclipse plugin)
-
-RUN_DEPENDS= ${LOCALBASE}/bin/eclipse:${PORTSDIR}/java/eclipse
-
-ECLIPSE_VER= 3.2
-
-JAVA_OS= native
-JAVA_VENDOR= bsdjava
-JAVA_VERSION= 1.5+
-
-NO_BUILD= yes
-NO_WRKSUBDIR= yes
-
-USE_JAVA= yes
-USE_ZIP= yes
-
-post-extract:
- @cd ${WRKDIR}; \
- ${MKDIR} ${WRKDIR}/eclipse; \
- DIRS=$$(${FIND} . -type d -mindepth 1 -not -name eclipse); \
- for DIR in $${DIRS}; do \
- FILES=$$(${FIND} $${DIR} -type f -name "*.jar"); \
- ${MKDIR} ${WRKDIR}/eclipse/$${DIR}; \
- for FILE in $${FILES}; do \
- JARDIR=$$(${BASENAME} $${DIR})/$$(${BASENAME} $${FILE} .jar); \
- ${UNZIP_CMD} -o $${FILE} -d ${WRKDIR}/eclipse/$${JARDIR}; \
- done; \
- done;
-
-do-install:
- @cd ${WRKDIR} && ${CP} -R eclipse ${PREFIX}/;
-
-post-install:
- @cd ${WRKDIR}; \
- ${ECHO_CMD} "@comment pkg-plist automatically generated" >> ${TMPPLIST}; \
- ${FIND} -s eclipse -type f -exec ${ECHO_CMD} {} ";" >> ${TMPPLIST}; \
- ${FIND} -s eclipse -type d | ${SORT} -r | ${GREP} -vE '^eclipse$$|^eclipse/plugins$$|^eclipse/features$$' | ${SED} -ne 's,^,@dirrm ,p' >> ${TMPPLIST};
-
-.include <bsd.port.mk>
diff --git a/java/eclipse-aptana2/distinfo b/java/eclipse-aptana2/distinfo
deleted file mode 100644
index b371dc8bda92..000000000000
--- a/java/eclipse-aptana2/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (aptana_update_009905.zip) = aaa067b81a0737ef00b868538fee14f2
-SHA256 (aptana_update_009905.zip) = 072a0651f3f751d2dabe7e0b3e10732c87bc0b772991c190ad92f0ead530ce1c
-SIZE (aptana_update_009905.zip) = 98081989
diff --git a/java/eclipse-aptana2/pkg-descr b/java/eclipse-aptana2/pkg-descr
deleted file mode 100644
index 8dd2e85b0220..000000000000
--- a/java/eclipse-aptana2/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-Aptana Studio is an IDE, designed for web developers and provides
-robust support for HTML, CSS and Javascript (bundled libraries:
-ExtJS, jQuery, Mochikit, Scriptaculous, Adobe Spry, YUI, Prototype,
-and Dojo). This is the plug-in for Eclipse.
-
-WWW: http://www.aptana.com/
diff --git a/java/netbeans61/Makefile b/java/netbeans61/Makefile
deleted file mode 100644
index f1b35aa66e7a..000000000000
--- a/java/netbeans61/Makefile
+++ /dev/null
@@ -1,47 +0,0 @@
-# New ports collection makefile for: netbeans
-# Date Created: 2 Jun 2003
-# Whom: olgeni@FreeBSD.org
-#
-# $FreeBSD$
-#
-
-PORTNAME= netbeans
-PORTVERSION= 6.1
-CATEGORIES= java devel
-MASTER_SITES= http://download.netbeans.org/netbeans/6.1/final/zip/
-DISTNAME= netbeans-${PORTVERSION}-200804211638
-
-MAINTAINER= olgeni@FreeBSD.org
-COMMENT= A full-featured integrated environment for Java
-
-USE_ZIP= yes
-USE_JAVA= yes
-JAVA_VERSION= 1.5+
-NO_BUILD= yes
-
-WRKSRC= ${WRKDIR}/netbeans
-
-SUB_FILES= pkg-install pkg-deinstall
-
-.include <bsd.port.pre.mk>
-
-post-patch:
- @${RM} ${WRKSRC}/etc/netbeans.conf.orig
- @${REINPLACE_CMD} -e "s@%%GREP%%@${GREP}@" \
- -e "s@%%GCONFTOOL%%@${LOCALBASE}/bin/gconftool-2@" \
- ${WRKSRC}/platform8/lib/nbexec
-
-do-configure:
- @${REINPLACE_CMD} 's|%%JAVA_HOME%%|${JAVA_HOME}|' ${WRKSRC}/etc/netbeans.conf
- @${RM} ${WRKSRC}/etc/netbeans.conf.bak
-
-do-install:
- @${MKDIR} ${PREFIX}/netbeans
- @${CP} -r ${WRKSRC}/* ${PREFIX}/netbeans
- @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/netbeans
- @${LN} -sf ${PREFIX}/netbeans/bin/netbeans ${PREFIX}/bin/netbeans
- @(cd ${WRKDIR}; ${FIND} -s netbeans -not -type d) >> ${TMPPLIST}
- @(cd ${WRKDIR}; ${FIND} -s -d netbeans -type d) | ${SED} -ne 's,^,@dirrm ,p' >> ${TMPPLIST}
- @(cd ${WRKDIR}; ${FIND} -s -d netbeans -type d -empty) | ${SED} -ne 's,^,@exec mkdir -p %D/,p' >> ${TMPPLIST}
-
-.include <bsd.port.post.mk>
diff --git a/java/netbeans61/distinfo b/java/netbeans61/distinfo
deleted file mode 100644
index 61cd264abbca..000000000000
--- a/java/netbeans61/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (netbeans-6.1-200804211638.zip) = 614d18b34f20ced8d69f4dc1e046e6e3
-SHA256 (netbeans-6.1-200804211638.zip) = 740ebaf809cb95ddd409ae83bc8a247595e8852fcfd780efc6c17f9cb08570e1
-SIZE (netbeans-6.1-200804211638.zip) = 164020872
diff --git a/java/netbeans61/files/patch-etc_netbeans.conf b/java/netbeans61/files/patch-etc_netbeans.conf
deleted file mode 100644
index 0a9da6ba5f2a..000000000000
--- a/java/netbeans61/files/patch-etc_netbeans.conf
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- etc/netbeans.conf.orig
-+++ etc/netbeans.conf
-@@ -13,7 +13,7 @@
- # (see http://wiki.netbeans.org/wiki/view/FaqGCPauses)
-
- # Default location of JDK, can be overridden by using --jdkhome <dir>:
--#netbeans_jdkhome="/path/to/jdk"
-+netbeans_jdkhome="%%JAVA_HOME%%"
-
- # Additional module clusters, using ${path.separator} (';' on Windows or ':' on Unix):
- #netbeans_extraclusters="/absolute/path/to/cluster1:/absolute/path/to/cluster2"
diff --git a/java/netbeans61/files/patch-harness_run.xml b/java/netbeans61/files/patch-harness_run.xml
deleted file mode 100644
index a36933f9b58d..000000000000
--- a/java/netbeans61/files/patch-harness_run.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- harness/run.xml.orig
-+++ harness/run.xml
-@@ -151,7 +151,7 @@
- <arg line="${run.args}"/>
- <arg line="${run.args.extra}"/>
- </exec>
-- <exec os="Linux SunOS Solaris Mac OS X" dir="." executable="sh" failonerror="yes">
-+ <exec os="FreeBSD Linux SunOS Solaris Mac OS X" dir="." executable="sh" failonerror="yes">
- <arg value="${run.sh}"/>
- <arg value="--jdkhome"/>
- <arg file="${run.jdkhome}"/>
diff --git a/java/netbeans61/files/patch-platform8_lib_nbexec b/java/netbeans61/files/patch-platform8_lib_nbexec
deleted file mode 100644
index 1a60b4a90ae2..000000000000
--- a/java/netbeans61/files/patch-platform8_lib_nbexec
+++ /dev/null
@@ -1,56 +0,0 @@
-
-$FreeBSD$
-
---- platform8/lib/nbexec.orig
-+++ platform8/lib/nbexec
-@@ -270,7 +270,7 @@
- # detect system http proxy setting
-
- detect_gnome_proxy () {
-- gconftool=/usr/bin/gconftool-2
-+ gconftool=%%GCONFTOOL%%
- if [ -x $gconftool ] ; then
- proxy_mode=`$gconftool --get /system/proxy/mode 2>/dev/null`
- if [ "$proxy_mode" = "manual" ] ; then
-@@ -299,18 +299,18 @@
- detect_kde_proxy () {
- kioslaverc="${HOME}/.kde/share/config/kioslaverc"
- if [ -f $kioslaverc ] ; then
-- if /bin/grep -q 'ProxyType=1' "$kioslaverc" ; then
-- http_proxy_tmp=`/bin/grep 'httpProxy=http://' "$kioslaverc"`
-+ if %%GREP%% -q 'ProxyType=1' "$kioslaverc" ; then
-+ http_proxy_tmp=`%%GREP%% 'httpProxy=http://' "$kioslaverc"`
- if [ $? ] ; then
- http_proxy_tmp=`echo $http_proxy_tmp | /bin/sed 's/httpProxy=http:\/\///'`
- return 0
- fi
-- http_non_proxy_hosts=`/bin/grep 'NoProxyFor=' "$kioslaverc"`
-+ http_non_proxy_hosts=`%%GREP%% 'NoProxyFor=' "$kioslaverc"`
- if [ $? ] ; then
- http_non_proxy_hosts=`echo $http_non_proxy_hosts | /bin/sed 's/NoProxyFor=//'`
- fi
- else
-- if /bin/grep -q 'ProxyType=0' "$kioslaverc" ; then
-+ if %%GREP%% -q 'ProxyType=0' "$kioslaverc" ; then
- http_proxy_tmp="DIRECT"
- return 0
- fi
-@@ -331,14 +331,14 @@
- close
- EOF
-
-- if /usr/bin/grep -q "ProxyAuto.*: *1" ${scutil_out} >/dev/null ; then
-+ if %%GREP%% -q "ProxyAuto.*: *1" ${scutil_out} >/dev/null ; then
- rm ${scutil_out}
- return 1
- fi
-
-- if /usr/bin/grep -q "HTTPEnable *: *1" ${scutil_out} ; then
-- http_proxy_host=`/usr/bin/grep HTTPProxy ${scutil_out} | /usr/bin/awk '{print $3}'`
-- http_proxy_port=`/usr/bin/grep HTTPPort ${scutil_out} | /usr/bin/awk '{print $3} '`
-+ if %%GREP%% -q "HTTPEnable *: *1" ${scutil_out} ; then
-+ http_proxy_host=`%%GREP%% HTTPProxy ${scutil_out} | /usr/bin/awk '{print $3}'`
-+ http_proxy_port=`%%GREP%% HTTPPort ${scutil_out} | /usr/bin/awk '{print $3} '`
- http_proxy_tmp=$http_proxy_host:$http_proxy_port
- rm ${scutil_out}
- return 0
diff --git a/java/netbeans61/files/pkg-deinstall.in b/java/netbeans61/files/pkg-deinstall.in
deleted file mode 100644
index 1bfa10364807..000000000000
--- a/java/netbeans61/files/pkg-deinstall.in
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/bin/sh
-
-case "$2" in
- DEINSTALL)
- rm -f %%PREFIX%%/bin/netbeans
- ;;
-esac
-
-exit 0
diff --git a/java/netbeans61/files/pkg-install.in b/java/netbeans61/files/pkg-install.in
deleted file mode 100644
index e21a09d195d0..000000000000
--- a/java/netbeans61/files/pkg-install.in
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/bin/sh
-
-case "$2" in
- POST-INSTALL)
- ln -sf %%PREFIX%%/netbeans/bin/netbeans %%PREFIX%%/bin/netbeans
- ;;
-esac
-
-exit 0
diff --git a/java/netbeans61/pkg-descr b/java/netbeans61/pkg-descr
deleted file mode 100644
index 3ffa48ebe541..000000000000
--- a/java/netbeans61/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-The NetBeans IDE is a world-class development environment written
-in Java. It can be used to develop code in Java, HTML, XML, JSP,
-C/C++ and other languages. The IDE is modular, and there is a huge
-variety of commercial and free extensions to it to support various
-technologies.
-
-WWW: http://www.netbeans.org/