aboutsummaryrefslogtreecommitdiff
path: root/lang/ccl
diff options
context:
space:
mode:
Diffstat (limited to 'lang/ccl')
-rw-r--r--lang/ccl/Makefile13
-rw-r--r--lang/ccl/distinfo5
-rw-r--r--lang/ccl/files/patch-tools_asdf.lisp16
3 files changed, 12 insertions, 22 deletions
diff --git a/lang/ccl/Makefile b/lang/ccl/Makefile
index 49a41b25d657..22e7e1c972bb 100644
--- a/lang/ccl/Makefile
+++ b/lang/ccl/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ccl
-PORTVERSION= 1.5
+PORTVERSION= 1.6
CATEGORIES= lang lisp
MASTER_SITES= ftp://ftp.clozure.com/pub/release/${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-freebsdx86
@@ -25,6 +25,10 @@ CCL_PLIST= ${WRKDIR}/pkg-plist
# the following files will not be installed
EXCLUDE= cocoa-ide lisp-kernel scripts
+USE_ASDF= yes
+
+.include "${.CURDIR}/../../devel/cl-asdf/bsd.cl-asdf.mk"
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"
@@ -54,8 +58,6 @@ do-build:
fi
@cd ${WRKSRC} && ${ECHO_CMD} | ./${FX86CL} --no-init --batch --quiet \
--eval "(ccl:rebuild-ccl :full t)" \
- --eval "(require 'asdf)" \
- --eval "(asdf:operate 'asdf:load-op 'asdf-install)" \
--eval "(quit)"
do-install:
@@ -67,6 +69,11 @@ do-install:
@${INSTALL_SCRIPT} ${WRKDIR}/ccl.sh ${PREFIX}/bin/ccl
post-install:
+ @cd ${WRKSRC} && ${ECHO_CMD} | ./${FX86CL} --no-init --batch --quiet \
+ --eval "(require 'asdf)" \
+ --eval '(load "/usr/local/etc/asdf-init.lisp")' \
+ --eval "(asdf:operate 'asdf:load-op 'asdf-install)" \
+ --eval "(quit)"
@cd ${PREFIX}; ${FIND} lib/ccl/* -type d -empty \
| ${SORT} \
| ${SED} -e 's#^#@exec ${MKDIR} %D/#g' \
diff --git a/lang/ccl/distinfo b/lang/ccl/distinfo
index c2d247a802d9..d817febf0a58 100644
--- a/lang/ccl/distinfo
+++ b/lang/ccl/distinfo
@@ -1,3 +1,2 @@
-MD5 (ccl-1.5-freebsdx86.tar.gz) = 283f4f5cdcd06262606e2de082601a1f
-SHA256 (ccl-1.5-freebsdx86.tar.gz) = 5cbbe9363e642d66c9fd8d98e6caab0d7eec2e47b2aa29c515aead1eb78b2da1
-SIZE (ccl-1.5-freebsdx86.tar.gz) = 72127143
+SHA256 (ccl-1.6-freebsdx86.tar.gz) = c7f29bbefc847118678de7094f3e968559d9f827cb4e10f3c6af6e6c27fa6928
+SIZE (ccl-1.6-freebsdx86.tar.gz) = 43289256
diff --git a/lang/ccl/files/patch-tools_asdf.lisp b/lang/ccl/files/patch-tools_asdf.lisp
deleted file mode 100644
index da4a17561d17..000000000000
--- a/lang/ccl/files/patch-tools_asdf.lisp
+++ /dev/null
@@ -1,16 +0,0 @@
-
-$FreeBSD$
-
---- tools/asdf.lisp.orig
-+++ tools/asdf.lisp
-@@ -564,7 +564,9 @@
- (system-source-file (cdr system-pair)))))))
-
- (defvar *central-registry*
-- `((directory-namestring *default-pathname-defaults*))
-+ `((directory-namestring *default-pathname-defaults*)
-+ "ccl:tools;asdf-install;"
-+ "%%LOCALBASE%%/lib/common-lisp/system-registry/")
- "A list of 'system directory designators' ASDF uses to find systems.
-
- A 'system directory designator' is a pathname or a function