aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc/files
diff options
context:
space:
mode:
Diffstat (limited to 'lang/gcc/files')
-rw-r--r--lang/gcc/files/alpha-freebsd.h132
-rw-r--r--lang/gcc/files/patch-aa12
-rw-r--r--lang/gcc/files/patch-ab11
-rw-r--r--lang/gcc/files/patch-ac13
-rw-r--r--lang/gcc/files/patch-ad84
-rw-r--r--lang/gcc/files/patch-af59
-rw-r--r--lang/gcc/files/patch-ai31
-rw-r--r--lang/gcc/files/patch-ak26
-rw-r--r--lang/gcc/files/patch-al26
-rw-r--r--lang/gcc/files/patch-ar32
-rw-r--r--lang/gcc/files/patch-bc34
-rw-r--r--lang/gcc/files/patch-fa242
-rw-r--r--lang/gcc/files/patch-fb13
-rw-r--r--lang/gcc/files/patch-fc41
-rw-r--r--lang/gcc/files/patch-va20
15 files changed, 0 insertions, 776 deletions
diff --git a/lang/gcc/files/alpha-freebsd.h b/lang/gcc/files/alpha-freebsd.h
deleted file mode 100644
index a227b9444b9e..000000000000
--- a/lang/gcc/files/alpha-freebsd.h
+++ /dev/null
@@ -1,132 +0,0 @@
-/* Definitions for DEC Alpha/AXP running FreeBSD using the ELF format
- Copyright (C) 2000 Free Software Foundation, Inc.
- Contributed by BSDi, written by David O'Brien <obrien@FreeBSD.org>
-
-This file is part of GNU CC.
-
-GNU CC is free software; you can redistribute it and/or modify
-it under the terms of the GNU General Public License as published by
-the Free Software Foundation; either version 2, or (at your option)
-any later version.
-
-GNU CC is distributed in the hope that it will be useful,
-but WITHOUT ANY WARRANTY; without even the implied warranty of
-MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-GNU General Public License for more details.
-
-You should have received a copy of the GNU General Public License
-along with GNU CC; see the file COPYING. If not, write to
-the Free Software Foundation, 675 Mass Ave, Cambridge, MA 02139, USA. */
-
-
-#undef CPP_PREDEFINES
-#define CPP_PREDEFINES \
- "-D__ELF__ -Dunix -D__FreeBSD__ -Asystem(unix) -Asystem(bsd) -Asystem(FreeBSD)"
-
-/* Provide a CPP_SPEC appropriate for FreeBSD/alpha. Besides the dealing with
- the GCC option `-posix', and PIC issues as on all FreeBSD platforms, we must
- deal with the Alpha's FP issues. */
-
-#undef CPP_SPEC
-#define CPP_SPEC "%(cpp_cpu) \
- %{fPIC:-D__PIC__ -D__pic__} %{fpic:-D__PIC__ -D__pic__} \
- %{posix:-D_POSIX_SOURCE} \
- %{mieee:-D_IEEE_FP} \
- %{mieee-with-inexact:-D_IEEE_FP -D_IEEE_FP_INEXACT}"
-
-#undef LINK_SPEC
-#define LINK_SPEC "-m elf64alpha %{G*} %{relax:-relax} \
- %{p:%e`-p' not supported; use `-pg' and gprof(1)} \
- %{Wl,*:%*} \
- %{assert*} %{R*} %{rpath*} %{defsym*} \
- %{shared:-Bshareable %{h*} %{soname*}} \
- %{symbolic:-Bsymbolic} \
- %{!shared: \
- %{!static: \
- %{rdynamic:-export-dynamic} \
- %{!dynamic-linker:-dynamic-linker /usr/libexec/ld-elf.so.1}} \
- %{static:-Bstatic}}"
-
-/* Provide an ASM_SPEC appropriate for a FreeBSD/Alpha target. This differs
- from the generic FreeBSD ASM_SPEC in that no special handling of PIC is
- necessary on the Alpha. */
-/* Per Richard Henderson <rth@cygnus.com>, it is better to use the `.arch'
- directive in the assembly file. alpha/elf.h gives us this in
- "ASM_FILE_START".
-#undef ASM_SPEC
-#define ASM_SPEC " %| %{mcpu=*:-m%*}"
-*/
-
-/* XXX, if FreeBSD/Alpha grows a crti.o file, we can use the alpha/elf.h
- definition. */
-#undef STARTFILE_SPEC
-#define STARTFILE_SPEC \
- "%{!shared: %{pg:gcrt1.o%s} %{!pg:%{p:gcrt1.o%s} %{!p:crt1.o%s}}} \
- %{!shared:crtbegin.o%s} %{shared:crtbeginS.o%s}"
-
-/* Provide a ENDFILE_SPEC appropriate for ELF. Here we tack on the
- magical crtend.o file which provides part of the support for
- getting C++ file-scope static object constructed before entering
- `main'. */
-/* XXX, if FreeBSD/Alpha grows a crtn.o file, we can use the alpha/elf.h
- definition. */
-
-#undef ENDFILE_SPEC
-#define ENDFILE_SPEC \
- "%{!shared:crtend.o%s} %{shared:crtendS.o%s}"
-
-
-/************************[ Target stuff ]***********************************/
-
-/* Define the actual types of some ANSI-mandated types.
- Needs to agree with <machine/ansi.h>. GCC defaults come from c-decl.c,
- c-common.c, and config/<arch>/<arch>.h. */
-
-/* alpha.h gets this wrong for FreeBSD. We use the GCC defaults instead. */
-#undef WCHAR_TYPE
-
-#undef WCHAR_UNSIGNED
-#define WCHAR_UNSIGNED 0
-
-#undef WCHAR_TYPE_SIZE
-#define WCHAR_TYPE_SIZE 32
-
-/* Handle cross-compilation on 32-bits machines (such as i386) for 64-bits
- machines (Alpha in this case). */
-
-#if defined(__i386__)
-#undef HOST_BITS_PER_LONG
-#define HOST_BITS_PER_LONG 32
-#undef HOST_WIDE_INT
-#define HOST_WIDE_INT long long
-#undef HOST_BITS_PER_WIDE_INT
-#define HOST_BITS_PER_WIDE_INT 64
-#endif
-
-#undef TARGET_VERSION
-#define TARGET_VERSION fprintf (stderr, " (FreeBSD/alpha ELF)");
-
-#define TARGET_ELF 1
-
-#undef TARGET_DEFAULT
-#define TARGET_DEFAULT (MASK_FP | MASK_FPREGS | MASK_GAS)
-
-#undef HAS_INIT_SECTION
-
-/* Output assembler code to FILE to increment profiler label # LABELNO
- for profiling a function entry. Under FreeBSD/Alpha, the assembler does
- nothing special with -pg. */
-
-#undef FUNCTION_PROFILER
-#define FUNCTION_PROFILER(FILE, LABELNO) \
- fputs ("\tjsr $28,_mcount\n", (FILE))
-
-/* Show that we need a GP when profiling. */
-#undef TARGET_PROFILING_NEEDS_GP
-#define TARGET_PROFILING_NEEDS_GP 1
-
-/* This is the char to use for continuation (in case we need to turn
- continuation back on). */
-
-#undef DBX_CONTIN_CHAR
-#define DBX_CONTIN_CHAR '?'
diff --git a/lang/gcc/files/patch-aa b/lang/gcc/files/patch-aa
deleted file mode 100644
index 9dc2e19279bb..000000000000
--- a/lang/gcc/files/patch-aa
+++ /dev/null
@@ -1,12 +0,0 @@
---- gcc/cpp.texi.orig Mon Aug 11 08:57:05 1997
-+++ gcc/cpp.texi Sat Jan 10 11:59:15 1998
-@@ -1,5 +1,9 @@
- \input texinfo
- @setfilename cpp.info
-+@dircategory The egcs enhanced GNU compiler suite
-+@direntry
-+* cpp: (cpp). The egcs C/C++ preprocessor.
-+@end direntry
- @settitle The C Preprocessor
-
- @ignore
diff --git a/lang/gcc/files/patch-ab b/lang/gcc/files/patch-ab
deleted file mode 100644
index f298fd056742..000000000000
--- a/lang/gcc/files/patch-ab
+++ /dev/null
@@ -1,11 +0,0 @@
---- gcc/f/g77.texi.orig Thu Jun 4 03:41:18 1998
-+++ gcc/f/g77.texi Tue Jun 9 17:52:16 1998
-@@ -150,7 +150,7 @@
-
- @dircategory Programming
- @direntry
--* g77: (g77). The GNU Fortran compiler.
-+* g77: (g77). The EGCS GNU Fortran compiler.
- @end direntry
- @node Top, Copying,, (DIR)
- @top Introduction
diff --git a/lang/gcc/files/patch-ac b/lang/gcc/files/patch-ac
deleted file mode 100644
index 961874c5c315..000000000000
--- a/lang/gcc/files/patch-ac
+++ /dev/null
@@ -1,13 +0,0 @@
---- gcc/gcc.texi.orig Fri Jan 2 15:38:11 1998
-+++ gcc/gcc.texi Sat Jan 10 11:56:49 1998
-@@ -1,6 +1,10 @@
- >\input texinfo @c -*-texinfo-*-
- @c %**start of header
- @setfilename gcc.info
-+@dircategory The egcs enhanced GNU compiler suite
-+@direntry
-+* gcc: (gcc). The egcs C/C++ compiler.
-+@end direntry
- @c @setfilename usegcc.info
- @c @setfilename portgcc.info
- @c To produce the full manual, use the "gcc.info" setfilename, and
diff --git a/lang/gcc/files/patch-ad b/lang/gcc/files/patch-ad
deleted file mode 100644
index 53927df88598..000000000000
--- a/lang/gcc/files/patch-ad
+++ /dev/null
@@ -1,84 +0,0 @@
---- gcc/config/i386/freebsd-aout.h.orig Mon Sep 25 06:03:18 2000
-+++ gcc/config/i386/freebsd-aout.h Tue Sep 26 12:23:26 2000
-@@ -31,12 +31,7 @@
-
- /* This goes away when the math-emulator is fixed */
- #undef TARGET_DEFAULT
--#define TARGET_DEFAULT \
-- (MASK_80387 | MASK_IEEE_FP | MASK_FLOAT_RETURNS | MASK_NO_FANCY_MATH_387)
--
--#undef CPP_PREDEFINES
--#define CPP_PREDEFINES "-Dunix -D__FreeBSD__\
-- -Asystem(unix) -Asystem(bsd) -Asystem(FreeBSD)"
-+#define TARGET_CPU_DEFAULT 0400 /* TARGET_NO_FANCY_MATH_387 */
-
- /* Like the default, except no -lg. */
- #define LIB_SPEC "%{!shared:%{!pg:-lc}%{pg:-lc_p}}"
-@@ -84,14 +79,6 @@
- necessary when compiling PIC code. */
-
- #define JUMP_TABLES_IN_TEXT_SECTION 1
--
--/* Don't default to pcc-struct-return, because in FreeBSD we prefer the
-- superior nature of the older gcc way. */
--#define DEFAULT_PCC_STRUCT_RETURN 0
--
--/* Ensure we the configuration knows our system correctly so we can link with
-- libraries compiled with the native cc. */
--#undef NO_DOLLAR_IN_LABEL
-
- /* i386 freebsd still uses old binutils that don't insert nops by default
- when the .align directive demands to insert extra space in the text
-@@ -102,19 +89,18 @@
-
- /* Profiling routines, partially copied from i386/osfrose.h. */
-
--/* Redefine this to use %eax instead of %edx. */
-+/* Tell final.c that we don't need a label passed to mcount. */
-+#define NO_PROFILE_DATA
-+
- #undef FUNCTION_PROFILER
- #define FUNCTION_PROFILER(FILE, LABELNO) \
- { \
- if (flag_pic) \
- { \
-- fprintf (FILE, "\tleal %sP%d@GOTOFF(%%ebx),%%eax\n", \
-- LPREFIX, (LABELNO)); \
- fprintf (FILE, "\tcall *mcount@GOT(%%ebx)\n"); \
- } \
- else \
- { \
-- fprintf (FILE, "\tmovl $%sP%d,%%eax\n", LPREFIX, (LABELNO)); \
- fprintf (FILE, "\tcall mcount\n"); \
- } \
- }
-@@ -132,6 +118,7 @@
-
- #define TYPE_ASM_OP "\t.type\t"
- #define SIZE_ASM_OP "\t.size\t"
-+#define SET_ASM_OP "\t.set\t"
-
- /* The following macro defines the format used to output the second
- operand of the .type assembler directive. Different svr4 assemblers
-@@ -141,6 +128,12 @@
-
- #define TYPE_OPERAND_FMT "@%s"
-
-+#define HANDLE_SYSV_PRAGMA 1
-+
-+#define ASM_WEAKEN_LABEL(FILE,NAME) \
-+ do { fputs ("\t.weak\t", FILE); assemble_name (FILE, NAME); \
-+ fputc ('\n', FILE); } while (0)
-+
- /* Write the extra assembler code needed to declare a function's result.
- Most svr4 assemblers don't require any special declaration of the
- result value, but there are exceptions. */
-@@ -242,6 +235,8 @@
- #define STARTFILE_SPEC \
- "%{shared:c++rt0.o%s} \
- %{!shared:%{pg:gcrt0.o%s}%{!pg:%{static:scrt0.o%s}%{!static:crt0.o%s}}}"
-+
-+#define MD_STARTFILE_PREFIX "/usr/lib/aout/"
-
- /* Define this so we can compile MS code for use with WINE. */
- #define HANDLE_PRAGMA_PACK_PUSH_POP
diff --git a/lang/gcc/files/patch-af b/lang/gcc/files/patch-af
deleted file mode 100644
index f1058d4e21ec..000000000000
--- a/lang/gcc/files/patch-af
+++ /dev/null
@@ -1,59 +0,0 @@
---- gcc/config/i386/freebsd.h.orig Sun Jan 30 23:28:05 2000
-+++ gcc/config/i386/freebsd.h Fri Feb 4 05:22:36 2000
-@@ -52,6 +52,10 @@
- #undef DBX_REGISTER_NUMBER
- #define DBX_REGISTER_NUMBER(n) svr4_dbx_register_map[n]
-
-+/* Don't use EGCS's normal profiling code -- we have our own fine-grained
-+ basic block profiling. */
-+#define NO_PROFILE_COUNTERS
-+
- /* Tell final.c that we don't need a label passed to mcount. */
-
- #undef FUNCTION_PROFILER
-@@ -73,11 +77,15 @@
-
- #undef WCHAR_TYPE_SIZE
- #define WCHAR_TYPE_SIZE BITS_PER_WORD
--
--#undef CPP_PREDEFINES
--#define CPP_PREDEFINES "-Dunix -D__ELF__ -D__FreeBSD__\
-- -Asystem(unix) -Asystem(bsd) -Asystem(FreeBSD)"
-
-+#undef CC1_SPEC
-+#define CC1_SPEC "\
-+ %{gline:%{!g:%{!g0:%{!g1:%{!g2: -g1}}}}} \
-+ %{maout: %{!mno-underscores: %{!munderscores: -munderscores }}}"
-+
-+#undef ASM_SPEC
-+#define ASM_SPEC "%{v*: -v} %{maout: %{fpic:-k} %{fPIC:-k}}"
-+
- /* Provide a STARTFILE_SPEC appropriate for FreeBSD. Here we add
- the magical crtbegin.o file (see crtstuff.c) which provides part
- of the support for getting C++ file-scope static object constructed
-@@ -85,11 +93,11 @@
-
- #undef STARTFILE_SPEC
- #define STARTFILE_SPEC \
-- "%{!shared: \
-- %{pg:gcrt1.o%s} %{!pg:%{p:gcrt1.o%s} \
-- %{!p:%{profile:gcrt1.o%s} \
-- %{!profile:crt1.o%s}}}} \
-- crti.o%s %{!shared:crtbegin.o%s} %{shared:crtbeginS.o%s}"
-+ "%{maout: %{shared:c++rt0.o%s} \
-+ %{!shared:%{pg:gcrt0.o%s}%{!pg:%{static:scrt0.o%s}%{!static:crt0.o%s}}}} \
-+ %{!maout: %{!shared: \
-+ %{pg:gcrt1.o%s} %{!pg:%{p:gcrt1.o%s} %{!p:crt1.o%s}}} \
-+ crti.o%s %{!shared:crtbegin.o%s} %{shared:crtbeginS.o%s}}"
-
- /* Provide a ENDFILE_SPEC appropriate for FreeBSD. Here we tack on
- the magical crtend.o file (see crtstuff.c) which provides part of
-@@ -99,7 +107,7 @@
-
- #undef ENDFILE_SPEC
- #define ENDFILE_SPEC \
-- "%{!shared:crtend.o%s} %{shared:crtendS.o%s} crtn.o%s"
-+ "%{!maout: %{!shared:crtend.o%s} %{shared:crtendS.o%s} crtn.o%s}"
-
- /* Provide a LINK_SPEC appropriate for FreeBSD. Here we provide support
- for the special GCC options -static and -shared, which allow us to
diff --git a/lang/gcc/files/patch-ai b/lang/gcc/files/patch-ai
deleted file mode 100644
index d88ee27871b3..000000000000
--- a/lang/gcc/files/patch-ai
+++ /dev/null
@@ -1,31 +0,0 @@
---- gcc/final.c.orig Sat Sep 5 22:52:01 1998
-+++ gcc/final.c Wed Oct 7 17:06:58 1998
-@@ -383,6 +383,8 @@
- /* zero word */
- assemble_integer (const0_rtx, long_bytes, 1);
-
-+ fprintf(asm_out_file,".stabs \"bbset\", 25, 0, 0, LPBX0\n");
-+
- /* address of filename */
- ASM_GENERATE_INTERNAL_LABEL (name, "LPBX", 1);
- assemble_integer (gen_rtx_SYMBOL_REF (Pmode, name), pointer_bytes, 1);
-@@ -1635,6 +1637,9 @@
- leaf_renumber_regs (first);
- #endif
-
-+ if (profile_block_flag)
-+ add_bb (file);
-+
- /* The Sun386i and perhaps other machines don't work right
- if the profiling code comes after the prologue. */
- #ifdef PROFILE_BEFORE_PROLOGUE
-@@ -1800,6 +1809,9 @@
- code to restore the stack frame and return to the caller. */
- FUNCTION_EPILOGUE (file, get_frame_size ());
- #endif
-+
-+ if (profile_block_flag)
-+ add_bb (file);
-
- #ifdef SDB_DEBUGGING_INFO
- if (write_symbols == SDB_DEBUG)
diff --git a/lang/gcc/files/patch-ak b/lang/gcc/files/patch-ak
deleted file mode 100644
index 98c373d4e980..000000000000
--- a/lang/gcc/files/patch-ak
+++ /dev/null
@@ -1,26 +0,0 @@
---- gcc/configure.orig Sun Oct 1 23:50:51 2000
-+++ gcc/configure Mon Oct 9 18:55:44 2000
-@@ -3910,6 +3910,23 @@
- thread_file='posix'
- fi
- ;;
-+ alpha*-*-freebsd*)
-+ tm_file="${tm_file} freebsd.h alpha/elf.h alpha/freebsd.h"
-+ xm_file="${xm_file} xm-freebsd.h"
-+ target_cpu_default="MASK_GAS"
-+ tmake_file="t-freebsd alpha/t-crtbe alpha/t-alpha alpha/t-ieee"
-+ extra_parts="crtbegin.o crtend.o crtbeginS.o crtendS.o"
-+ xmake_file=none
-+ fixincludes=fixinc.wrap
-+ gas=yes gnu_ld=yes
-+ stabs=yes
-+ case x${enable_threads} in
-+ xyes | xpthreads | xposix)
-+ thread_file='posix'
-+ tmake_file="${tmake_file} t-freebsd-thread"
-+ ;;
-+ esac
-+ ;;
- alpha*-*-netbsd*)
- tm_file="${tm_file} alpha/elf.h alpha/netbsd.h alpha/netbsd-elf.h"
- target_cpu_default="MASK_GAS"
diff --git a/lang/gcc/files/patch-al b/lang/gcc/files/patch-al
deleted file mode 100644
index e2760943566e..000000000000
--- a/lang/gcc/files/patch-al
+++ /dev/null
@@ -1,26 +0,0 @@
---- gcc/configure.in.orig Sun Oct 1 23:50:51 2000
-+++ gcc/configure.in Mon Oct 9 18:56:34 2000
-@@ -786,6 +786,23 @@
- if test x$enable_threads = xyes; then
- thread_file='posix'
- fi
-+ alpha*-*-freebsd*)
-+ tm_file="${tm_file} freebsd.h alpha/elf.h alpha/freebsd.h"
-+ xm_file="${xm_file} xm-freebsd.h"
-+ target_cpu_default="MASK_GAS"
-+ tmake_file="t-freebsd alpha/t-crtbe alpha/t-alpha alpha/t-ieee"
-+ extra_parts="crtbegin.o crtend.o crtbeginS.o crtendS.o"
-+ xmake_file=none
-+ fixincludes=fixinc.wrap
-+ gas=yes gnu_ld=yes
-+ stabs=yes
-+ case x${enable_threads} in
-+ xyes | xpthreads | xposix)
-+ thread_file='posix'
-+ tmake_file="${tmake_file} t-freebsd-thread"
-+ ;;
-+ esac
-+ ;;
- ;;
- alpha*-*-netbsd*)
- tm_file="${tm_file} alpha/elf.h alpha/netbsd.h alpha/netbsd-elf.h"
diff --git a/lang/gcc/files/patch-ar b/lang/gcc/files/patch-ar
deleted file mode 100644
index e6a4c8ad30b0..000000000000
--- a/lang/gcc/files/patch-ar
+++ /dev/null
@@ -1,32 +0,0 @@
---- gcc/config/freebsd.h.orig Mon Nov 22 22:17:32 1999
-+++ gcc/config/freebsd.h Fri Feb 4 05:29:31 2000
-@@ -48,13 +48,26 @@
- #undef WORD_SWITCH_TAKES_ARG
- #define WORD_SWITCH_TAKES_ARG(STR) (FBSD_WORD_SWITCH_TAKES_ARG(STR))
-
-+/* Place spaces around this string. We depend on string splicing to produce
-+ the final CPP_PREDEFINES value. */
-+#define FBSD_CPP_PREDEFINES " -Dunix -D__FreeBSD__ -Asystem(unix) -Asystem(bsd) -Asystem(FreeBSD) "
-+
-+#undef CPP_PREDEFINES
-+#define CPP_PREDEFINES FBSD_CPP_PREDEFINES
-+
- /* Provide a CPP_SPEC appropriate for FreeBSD. We just deal with the GCC
- option `-posix', and PIC issues. */
-
--#undef CPP_SPEC
--#define CPP_SPEC "%(cpp_cpu) \
-+#define FBSD_CPP_SPEC " \
-+ %(cpp_cpu) \
- %{fPIC:-D__PIC__ -D__pic__} %{fpic:-D__PIC__ -D__pic__} \
-- %{posix:-D_POSIX_SOURCE}"
-+ %{posix:-D_POSIX_SOURCE} \
-+ %{!maout: -D__ELF__} \
-+ %{munderscores: -D__UNDERSCORES__} \
-+ %{maout: %{!mno-underscores: -D__UNDERSCORES__}}"
-+
-+#undef CPP_SPEC
-+#define CPP_SPEC FBSD_CPP_SPEC
-
- /* Provide a LIB_SPEC appropriate for FreeBSD. Just select the appropriate
- libc, depending on whether we're doing profiling or need threads support.
diff --git a/lang/gcc/files/patch-bc b/lang/gcc/files/patch-bc
deleted file mode 100644
index c3159ca2788c..000000000000
--- a/lang/gcc/files/patch-bc
+++ /dev/null
@@ -1,34 +0,0 @@
---- libstdc++/Makefile.in.orig Sat Jul 17 22:50:47 1999
-+++ libstdc++/Makefile.in Tue Jul 20 07:56:00 1999
-@@ -14,7 +14,7 @@
- # along with this library; see the file COPYING. If not, write to the Free
- # Software Foundation, 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
-
--VERSION = 2.10.0
-+VERSION = 4
- INTERFACE = 3
-
- gxx_include_dir=${includedir}/g++
-@@ -111,7 +111,8 @@
- $(LN_S) $(SHLIB) $(SHLINK) || cp $(ARLIB) $(ARLINK)
-
- mshlink:
-- @$(MAKE) $(MSHLINK) "SHLINK=$(MSHLINK)"
-+ #@$(MAKE) $(MSHLINK) "SHLINK=$(MSHLINK)"
-+ @true
-
- $(IO_DIR)/iostream.list: force
- cd $(IO_DIR) ; $(MAKE) $(FLAGS_TO_PASS) iostream.list
-@@ -336,11 +337,7 @@
- || cp $${RELINSTALLDIR}$(ARLIB) $${INSTALLLINKDIR}$(MULTISUBDIR)/$$FILE ; \
- fi; \
- elif [ $$FILE = mshlink ]; then \
-- for FILE in $(MSHLINK) ; do \
-- rm -f $${INSTALLDIR}$(MULTISUBDIR)/$$FILE ; \
-- $(LN_S) $(SHLIB) $${INSTALLDIR}$(MULTISUBDIR)/$$FILE \
-- || cp $(SHLIB) $${INSTALLDIR}$(MULTISUBDIR)/$$FILE ; \
-- done; \
-+ true; \
- elif [ $$FILE = marlink ]; then \
- for FILE in $(MARLINK) ; do \
- rm -f $${INSTALLDIR}$(MULTISUBDIR)/$$FILE ; \
diff --git a/lang/gcc/files/patch-fa b/lang/gcc/files/patch-fa
deleted file mode 100644
index d6b90e4ba86c..000000000000
--- a/lang/gcc/files/patch-fa
+++ /dev/null
@@ -1,242 +0,0 @@
---- gcc/c-common.c.orig Mon Sep 25 10:04:45 2000
-+++ gcc/c-common.c Mon Oct 9 02:51:14 2000
-@@ -171,7 +171,7 @@
- int, int, int));
- static void init_attributes PARAMS ((void));
- static void record_function_format PARAMS ((tree, tree, enum format_type,
-- int, int));
-+ int, int, int));
- static void record_international_format PARAMS ((tree, tree, int));
- static int default_valid_lang_attribute PARAMS ((tree, tree, tree, tree));
-
-@@ -862,6 +862,7 @@
- enum format_type format_type;
- tree argument;
- unsigned int arg_num;
-+ int null_format_ok;
-
- if (TREE_CODE (decl) != FUNCTION_DECL)
- {
-@@ -872,7 +873,7 @@
-
- if (TREE_CODE (format_type_id) != IDENTIFIER_NODE)
- {
-- error ("unrecognized format specifier");
-+ error_with_decl (decl, "unrecognized format specifier");
- continue;
- }
- else
-@@ -880,12 +881,26 @@
- const char *p = IDENTIFIER_POINTER (format_type_id);
-
- if (!strcmp (p, "printf") || !strcmp (p, "__printf__"))
-+ {
-+ format_type = printf_format_type;
-+ null_format_ok = 0;
-+ }
-+ else if (!strcmp (p, "printf0") || !strcmp (p, "__printf0__"))
-+ {
- format_type = printf_format_type;
-+ null_format_ok = 1;
-+ }
- else if (!strcmp (p, "scanf") || !strcmp (p, "__scanf__"))
-+ {
- format_type = scanf_format_type;
-+ null_format_ok = 0;
-+ }
- else if (!strcmp (p, "strftime")
- || !strcmp (p, "__strftime__"))
-+ {
- format_type = strftime_format_type;
-+ null_format_ok = 0;
-+ }
- else
- {
- status_warning (status, "`%s' is an unrecognized format function type", p);
-@@ -958,7 +973,8 @@
-
- record_function_format (DECL_NAME (decl),
- DECL_ASSEMBLER_NAME (decl),
-- format_type, format_num, first_arg_num);
-+ format_type, format_num, first_arg_num,
-+ null_format_ok);
- break;
- }
-
-@@ -1441,6 +1457,13 @@
-
- static const format_char_info print_char_table[] =
- {
-+#ifdef XXX_NEED_TO_UPDATE_THIS_FOR_GCC297_CHANGES
-+/* FreeBSD kernel extensions. */
-+ { "D", 1, T_C, T_C, NULL, NULL, NULL, NULL, NULL, "-wp" },
-+ { "b", 1, T_C, T_C, NULL, NULL, NULL, NULL, NULL, "-wp" },
-+ { "rz", 0, NULL, T_I, T_I, T_L, NULL, NULL, NULL, "-wp0 +#" },
-+#define unextended_print_char_table (print_char_table + 3)
-+#endif
- /* C89 conversion specifiers. */
- { "di", 0, STD_C89, { T89_I, T99_I, T89_I, T89_L, T99_LL, TEX_LL, T99_SST, T99_PD, T99_IM }, "-wp0 +'I", "i" },
- { "oxX", 0, STD_C89, { T89_UI, T99_UI, T89_UI, T89_UL, T99_ULL, TEX_ULL, T99_ST, T99_UPD, T99_UIM }, "-wp0#", "i" },
-@@ -1526,6 +1549,7 @@
- enum format_type format_type; /* type of format (printf, scanf, etc.) */
- int format_num; /* number of format argument */
- int first_arg_num; /* number of first arg (zero for varargs) */
-+ int null_format_ok; /* TRUE if the format string may be NULL */
- } function_format_info;
-
- static function_format_info *function_format_list = NULL;
-@@ -1570,42 +1594,42 @@
- {
- /* Functions from ISO/IEC 9899:1990. */
- record_function_format (get_identifier ("printf"), NULL_TREE,
-- printf_format_type, 1, 2);
-+ printf_format_type, 1, 2, 0);
- record_function_format (get_identifier ("__builtin_printf"), NULL_TREE,
-- printf_format_type, 1, 2);
-+ printf_format_type, 1, 2, 0);
- record_function_format (get_identifier ("fprintf"), NULL_TREE,
-- printf_format_type, 2, 3);
-+ printf_format_type, 2, 3, 0);
- record_function_format (get_identifier ("sprintf"), NULL_TREE,
-- printf_format_type, 2, 3);
-+ printf_format_type, 2, 3, 0);
- record_function_format (get_identifier ("scanf"), NULL_TREE,
-- scanf_format_type, 1, 2);
-+ scanf_format_type, 1, 2, 0);
- record_function_format (get_identifier ("fscanf"), NULL_TREE,
-- scanf_format_type, 2, 3);
-+ scanf_format_type, 2, 3, 0);
- record_function_format (get_identifier ("sscanf"), NULL_TREE,
-- scanf_format_type, 2, 3);
-+ scanf_format_type, 2, 3, 0);
- record_function_format (get_identifier ("vprintf"), NULL_TREE,
-- printf_format_type, 1, 0);
-+ printf_format_type, 1, 0, 0);
- record_function_format (get_identifier ("vfprintf"), NULL_TREE,
-- printf_format_type, 2, 0);
-+ printf_format_type, 2, 0, 0);
- record_function_format (get_identifier ("vsprintf"), NULL_TREE,
-- printf_format_type, 2, 0);
-+ printf_format_type, 2, 0, 0);
- record_function_format (get_identifier ("strftime"), NULL_TREE,
-- strftime_format_type, 3, 0);
-+ strftime_format_type, 3, 0, 0);
- }
-
- if (flag_hosted && flag_isoc99)
- {
- /* ISO C99 adds the snprintf and vscanf family functions. */
- record_function_format (get_identifier ("snprintf"), NULL_TREE,
-- printf_format_type, 3, 4);
-+ printf_format_type, 3, 4, 0);
- record_function_format (get_identifier ("vsnprintf"), NULL_TREE,
-- printf_format_type, 3, 0);
-+ printf_format_type, 3, 0, 0);
- record_function_format (get_identifier ("vscanf"), NULL_TREE,
-- scanf_format_type, 1, 0);
-+ scanf_format_type, 1, 0, 0);
- record_function_format (get_identifier ("vfscanf"), NULL_TREE,
-- scanf_format_type, 2, 0);
-+ scanf_format_type, 2, 0, 0);
- record_function_format (get_identifier ("vsscanf"), NULL_TREE,
-- scanf_format_type, 2, 0);
-+ scanf_format_type, 2, 0, 0);
- }
-
- if (flag_hosted && flag_noniso_default_format_attributes)
-@@ -1630,12 +1654,13 @@
-
- static void
- record_function_format (name, assembler_name, format_type,
-- format_num, first_arg_num)
-+ format_num, first_arg_num, null_format_ok)
- tree name;
- tree assembler_name;
- enum format_type format_type;
- int format_num;
- int first_arg_num;
-+ int null_format_ok;
- {
- function_format_info *info;
-
-@@ -1659,6 +1684,7 @@
- info->format_type = format_type;
- info->format_num = format_num;
- info->first_arg_num = first_arg_num;
-+ info->null_format_ok = null_format_ok;
- }
-
- /* Record information for the names of function that modify the format
-@@ -2019,7 +2045,7 @@
-
- if (integer_zerop (format_tree))
- {
-- status_warning (status, "null format string");
-+ if (!info->null_format_ok) status_warning (status, "null format string");
- return;
- }
- if (TREE_CODE (format_tree) != ADDR_EXPR)
-@@ -2340,6 +2366,54 @@
- }
- }
- }
-+ if (*format_chars == 'b')
-+ {
-+ /* There should be an int arg to control the string arg. */
-+ if (params == 0)
-+ {
-+ status_warning (status, "too few arguments for format");
-+ return;
-+ }
-+ if (info->first_arg_num != 0)
-+ {
-+ cur_param = TREE_VALUE (params);
-+ params = TREE_CHAIN (params);
-+ ++arg_num;
-+ if ((TYPE_MAIN_VARIANT (TREE_TYPE (cur_param))
-+ != integer_type_node)
-+ &&
-+ (TYPE_MAIN_VARIANT (TREE_TYPE (cur_param))
-+ != unsigned_type_node))
-+ {
-+ status_warning (status, "bitmap is not type int (arg %d)", arg_num);
-+ }
-+ }
-+ }
-+ if (*format_chars == 'D')
-+ {
-+ /* There should be an unsigned char * arg before the string arg. */
-+ if (params == 0)
-+ {
-+ status_warning (status, "too few arguments for format");
-+ return;
-+ }
-+ if (info->first_arg_num != 0)
-+ {
-+ tree cur_type;
-+ cur_param = TREE_VALUE (params);
-+ params = TREE_CHAIN (params);
-+ ++arg_num;
-+ cur_type = TREE_TYPE (cur_param);
-+ if (TREE_CODE (cur_type) != POINTER_TYPE
-+ || TYPE_MAIN_VARIANT (TREE_TYPE (cur_type))
-+ != unsigned_char_type_node)
-+ {
-+ status_warning (status,
-+ "ethernet address is not type unsigned char * (arg %d)",
-+ arg_num);
-+ }
-+ }
-+ }
-
- aflag = 0;
-
-@@ -2441,7 +2515,7 @@
- status_warning (status, "width used with `%c' format", format_char);
- if (index (fci->flags2, '3') != 0
- || (format_char == 'y' && index (flag_chars, 'E')))
-- status_warning (status, "`%%%c' yields only last 2 digits of year in some locales",
-+ status_warning (status, "`%%%c' yields only last 2 digits of year in some locales on non-BSD systems",
- format_char);
- else if (index (fci->flags2, '2') != 0)
- status_warning (status, "`%%%c' yields only last 2 digits of year", format_char);
diff --git a/lang/gcc/files/patch-fb b/lang/gcc/files/patch-fb
deleted file mode 100644
index dae6d331898c..000000000000
--- a/lang/gcc/files/patch-fb
+++ /dev/null
@@ -1,13 +0,0 @@
---- gcc/flags.h.orig Sun Jan 31 09:46:18 1999
-+++ gcc/flags.h Tue Mar 30 13:17:11 1999
-@@ -137,6 +137,10 @@
-
- extern int warn_aggregate_return;
-
-+/* Nonzero means that -Wformat accepts certain non-ANSI formats. */
-+
-+extern int flag_format_extensions;
-+
- /* Nonzero if generating code to do profiling. */
-
- extern int profile_flag;
diff --git a/lang/gcc/files/patch-fc b/lang/gcc/files/patch-fc
deleted file mode 100644
index f783e5cae528..000000000000
--- a/lang/gcc/files/patch-fc
+++ /dev/null
@@ -1,41 +0,0 @@
---- gcc/toplev.c.orig Tue Jun 6 13:11:39 2000
-+++ gcc/toplev.c Mon Jun 26 20:19:31 2000
-@@ -787,6 +787,9 @@
- /* Tag all structures with __attribute__(packed) */
- int flag_pack_struct = 0;
-
-+/* Nonzero means that -Wformat accepts certain system-dependent formats. */
-+int flag_format_extensions = 0;
-+
- /* Emit code to check for stack overflow; also may cause large objects
- to be allocated dynamically. */
- int flag_stack_check;
-@@ -1064,6 +1067,8 @@
- "Do the full regmove optimization pass"},
- {"pack-struct", &flag_pack_struct, 1,
- "Pack structure members together without holes" },
-+ {"format-extensions", &flag_format_extensions, 1,
-+ "-Wformat accepts certain FreeBSD system-dependent formats" },
- {"stack-check", &flag_stack_check, 1,
- "Insert stack checking code into the program" },
- {"argument-alias", &flag_argument_noalias, 0,
-@@ -4484,6 +4489,19 @@
- if (optimize_val != -1)
- {
- optimize = optimize_val;
-+#ifdef __alpha__
-+ if (optimize > 1)
-+ {
-+ #ifdef FORCE_OPTIMIZATION_DOWNGRADE
-+ optimize = 1;
-+ warning ("\n***\n***\t-O%d converted to \"-O1\" due to optimizer bugs on this platform\n***\n",
-+ optimize_val);
-+ #else
-+ warning ("\n***\n***\tThe -O%d flag TRIGGERS KNOWN OPTIMIZER BUGS ON THIS PLATFORM\n***\n",
-+ optimize_val);
-+ #endif
-+ }
-+#endif /*__alpha__*/
- optimize_size = 0;
- }
- }
diff --git a/lang/gcc/files/patch-va b/lang/gcc/files/patch-va
deleted file mode 100644
index 48040ffa6e96..000000000000
--- a/lang/gcc/files/patch-va
+++ /dev/null
@@ -1,20 +0,0 @@
---- gcc/Makefile.in.orig Thu Feb 25 12:40:16 1999
-+++ gcc/Makefile.in Mon Mar 1 04:36:40 1999
-@@ -793,7 +793,7 @@
- rm -f config.run
-
- $(srcdir)/configure: $(srcdir)/configure.in
-- cd $(srcdir); autoconf
-+ cd $(srcdir); echo "wants to run autoconf"
-
- # cstamp-h.in controls rebuilding of config.in.
- # It is named cstamp-h.in and not stamp-h.in so the mostlyclean rule doesn't
-@@ -806,7 +806,7 @@
- # ??? Newer versions have a maintainer mode that may be useful here.
- $(srcdir)/config.in: $(srcdir)/cstamp-h.in
- $(srcdir)/cstamp-h.in: $(srcdir)/configure.in $(srcdir)/acconfig.h
-- cd $(srcdir) && autoheader
-+ cd $(srcdir) && echo "want to run autoheader"
- @rm -f $(srcdir)/cstamp-h.in
- echo timestamp > $(srcdir)/cstamp-h.in
- auto-host.h: cstamp-h ; @true