aboutsummaryrefslogtreecommitdiff
path: root/lang/php4
diff options
context:
space:
mode:
Diffstat (limited to 'lang/php4')
-rw-r--r--lang/php4/Makefile8
-rw-r--r--lang/php4/files/patch-scripts::phpize.in4
2 files changed, 8 insertions, 4 deletions
diff --git a/lang/php4/Makefile b/lang/php4/Makefile
index ab42906778c5..d5360cf2737c 100644
--- a/lang/php4/Makefile
+++ b/lang/php4/Makefile
@@ -7,7 +7,7 @@
PORTNAME= php4
PORTVERSION= 4.4.9
-PORTREVISION?= 3
+PORTREVISION?= 4
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP:S,$,:release,} \
http://downloads.php.net/ilia/:rc \
@@ -23,7 +23,7 @@ LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}
USE_BZIP2= yes
.if !defined(PKGNAMESUFFIX)
-USE_AUTOTOOLS= autoconf:262
+USE_AUTOTOOLS= autoconf:267
CONFIGURE_ARGS= --enable-versioning \
--enable-memory-limit \
@@ -158,7 +158,11 @@ post-patch:
@${TOUCH} ${WRKSRC}/ext/php_config.h
@${REINPLACE_CMD} "s|^\(extension_dir\)|; \1|" ${WRKSRC}/php.ini-*
+# Work around issues with newer (>=2.64) autoconf
pre-configure:
+ @${REINPLACE_CMD} -E 's:^((m4_)?divert)[(]([0-9]*)[)]:\1(600\3):' \
+ ${WRKSRC}/configure.in `${FIND} ${WRKSRC} -name '*.m4'`
+ @${RM} ${WRKSRC}/configure
@${CAT} ${WRKSRC}/acinclude.m4 ${WRKSRC}/build/libtool.m4 > ${WRKSRC}/aclocal.m4
post-build:
diff --git a/lang/php4/files/patch-scripts::phpize.in b/lang/php4/files/patch-scripts::phpize.in
index c3ebb0867fbe..504db64246c8 100644
--- a/lang/php4/files/patch-scripts::phpize.in
+++ b/lang/php4/files/patch-scripts::phpize.in
@@ -6,8 +6,8 @@
{
- test -z "$PHP_AUTOCONF" && PHP_AUTOCONF=autoconf
- test -z "$PHP_AUTOHEADER" && PHP_AUTOHEADER=autoheader
-+ test -z "$PHP_AUTOCONF" && PHP_AUTOCONF=autoconf-2.62
-+ test -z "$PHP_AUTOHEADER" && PHP_AUTOHEADER=autoheader-2.62
++ test -z "$PHP_AUTOCONF" && PHP_AUTOCONF=autoconf-2.67
++ test -z "$PHP_AUTOHEADER" && PHP_AUTOHEADER=autoheader-2.67
if test ! -x "`$php_shtool path $PHP_AUTOCONF`"; then
cat <<EOF