aboutsummaryrefslogtreecommitdiff
path: root/lang/php5/Makefile.ext
diff options
context:
space:
mode:
Diffstat (limited to 'lang/php5/Makefile.ext')
-rw-r--r--lang/php5/Makefile.ext50
1 files changed, 38 insertions, 12 deletions
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index d30bcf102e2a..f969b6883ae1 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -179,17 +179,11 @@ CONFIGURE_ARGS+=--with-mssql=${LOCALBASE}
.endif
.if ${PHP_MODNAME} == "mysql"
-CONFIGURE_ARGS+=--with-mysql=${LOCALBASE} \
- --with-zlib-dir=/usr
-
-USE_MYSQL= yes
+OPTIONS= MYSQLND "Use MySQL Native Driver" off
.endif
.if ${PHP_MODNAME} == "mysqli"
-CONFIGURE_ARGS+=--with-mysqli=${LOCALBASE}/bin/mysql_config
-
-USE_MYSQL= yes
-BROKEN_WITH_MYSQL= 323 40
+OPTIONS= MYSQLND "Use MySQL Native Driver" off
.endif
.if ${PHP_MODNAME} == "odbc"
@@ -232,10 +226,7 @@ USE_FIREBIRD= yes
.endif
.if ${PHP_MODNAME} == "pdo_mysql"
-CONFIGURE_ARGS+=--with-pdo-mysql=${LOCALBASE} \
- --with-zlib-dir=/usr
-
-USE_MYSQL= yes
+OPTIONS= MYSQLND "Use MySQL Native Driver" off
USE_PHP= pdo
USE_PHP_BUILD= yes
@@ -493,6 +484,28 @@ CONFIGURE_ARGS+=--with-onig=${LOCALBASE}
. endif
.endif
+.if ${PHP_MODNAME} == "mysql"
+. if defined(WITH_MYSQLND)
+CONFIGURE_ARGS+=--with-mysql=mysqlnd
+. else
+CONFIGURE_ARGS+=--with-mysql=${LOCALBASE} \
+ --with-zlib-dir=/usr
+
+USE_MYSQL= yes
+. endif
+.endif
+
+.if ${PHP_MODNAME} == "mysqli"
+. if defined(WITH_MYSQLND)
+CONFIGURE_ARGS+=--with-mysqli=mysqlnd
+. else
+CONFIGURE_ARGS+=--with-mysqli=${LOCALBASE}/bin/mysql_config
+
+USE_MYSQL= yes
+BROKEN_WITH_MYSQL= 323 40
+. endif
+.endif
+
.if ${PHP_MODNAME} == "openssl"
post-extract:
@${MV} ${WRKSRC}/config0.m4 ${WRKSRC}/config.m4
@@ -506,6 +519,19 @@ LIB_DEPENDS+= ct.4:${PORTSDIR}/databases/freetds
.endif
.endif
+.if ${PHP_MODNAME} == "pdo_mysql"
+. if defined(WITH_MYSQLND)
+CONFIGURE_ARGS+=--with-pdo-mysql=mysqlnd
+
+USE_PHP+= mysql
+. else
+CONFIGURE_ARGS+=--with-pdo-mysql=${LOCALBASE} \
+ --with-zlib-dir=/usr
+
+USE_MYSQL= yes
+. endif
+.endif
+
.if ${PHP_MODNAME} == "sqlite"
. if defined(WITH_UTF8)
CONFIGURE_ARGS+=--enable-sqlite-utf8