aboutsummaryrefslogtreecommitdiff
path: root/lang/python/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python/Makefile')
-rw-r--r--lang/python/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index ceac8f7cc0fa..080969a76ebd 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -41,7 +41,8 @@ TOOLSDIR= ${PREFIX}/share/${PYTHON_VERSION}
OPTIONS= THREADS "Enable thread support" on \
HUGE_STACK_SIZE "Use a larger thread stack" off \
UCS4 "Use UCS4 for unicode support" on \
- PYMALLOC "Uses python's internal malloc" on
+ PYMALLOC "Use python's internal malloc" on \
+ IPV6 "Enable IPv6 support" on
.include <bsd.port.pre.mk>
@@ -96,7 +97,7 @@ CONFIGURE_ARGS+= --with-libs='-lxpg4'
CONFIGURE_ARGS+= --with-libs='-lxpg4'
.endif
-.if ${OSVERSION} >= 400014
+.if !defined(WITHOUT_IPV6) && ${OSVERSION} >= 400014
CONFIGURE_ARGS+= --enable-ipv6
.else
CONFIGURE_ARGS+= --disable-ipv6