aboutsummaryrefslogtreecommitdiff
path: root/lang/python21/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python21/Makefile')
-rw-r--r--lang/python21/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/lang/python21/Makefile b/lang/python21/Makefile
index ad0785ef6ca3..8ab23120d5dc 100644
--- a/lang/python21/Makefile
+++ b/lang/python21/Makefile
@@ -7,7 +7,7 @@
PORTNAME= python
PORTVERSION= 2.1.3
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= lang python
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -28,6 +28,7 @@ USE_PYTHON= yes
PYTHON_VERSION= python2.1
PYTHON_NO_DEPENDS= yes
LATEST_LINK= ${PYTHON_VERSION:S/.//}
+USE_REINPLACE= yes
#
# If you don't want to use Python's thread module, you need to set
@@ -72,6 +73,14 @@ post-extract:
${SED} -e '1s,^.*$$,#!${PREFIX}/bin/${PYTHON_VERSION},' \
${WRKSRC}/Tools/scripts/pydoc > ${WRKDIR}/pydoc2.1
+pre-patch:
+ ${REINPLACE_CMD} -e \
+ 's,/usr/doc/python-docs-,${PREFIX}/share/doc/python,g' \
+ ${WRKSRC}/Lib/pydoc.py
+ ${REINPLACE_CMD} -e \
+ 's|^\(prefixes = .*\)\]$$|\1, "${X11BASE}"]|g' \
+ ${WRKSRC}/Lib/site.py
+
pre-su-install:
.for platform in ${PLATFORMS}
${MKDIR} ${PYTHONPREFIX_LIBDIR}/${platform}