aboutsummaryrefslogtreecommitdiff
path: root/lang/python32/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python32/Makefile')
-rw-r--r--lang/python32/Makefile7
1 files changed, 1 insertions, 6 deletions
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 85939aaf5095..8d2ebe779c75 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -6,6 +6,7 @@
PORTNAME= python32
PORTVERSION= 3.2.2
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -49,7 +50,6 @@ BINLINKS_SUB= -e 's,(2to3|idle3|pydoc3),\1-${PYTHON_VER},' \
-e 's,(python-shared|python),\1${PYTHON_VER},'
OPTIONS= THREADS "Enable thread support" on \
- HUGE_STACK_SIZE "Use a larger thread stack" off \
UCS4 "Use UCS4 for unicode support" on \
PYMALLOC "Use python's internal malloc" on \
IPV6 "Enable IPv6 support" on \
@@ -71,11 +71,6 @@ CFLAGS+= -D__wchar_t=wchar_t
PLIST_SUB+= THREADS=""
CONFIGURE_ARGS+= --with-threads
CFLAGS+= ${PTHREAD_CFLAGS}
-.if defined(WITHOUT_HUGE_STACK_SIZE)
-CFLAGS+= -DTHREAD_STACK_SIZE=0x20000
-.else
-CFLAGS+= -DTHREAD_STACK_SIZE=0x100000
-.endif # defined(WITHOUT_HUGE_STACK_SIZE)
LDFLAGS+= ${PTHREAD_LIBS}
.else # defined(WITHOUT_THREADS)
PLIST_SUB+= THREADS="@comment "