aboutsummaryrefslogtreecommitdiff
path: root/lang/python33
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python33')
-rw-r--r--lang/python33/Makefile4
-rw-r--r--lang/python33/files/patch-Makefile.pre.in14
2 files changed, 1 insertions, 17 deletions
diff --git a/lang/python33/Makefile b/lang/python33/Makefile
index 2cb14b222db6..c7872f59ff29 100644
--- a/lang/python33/Makefile
+++ b/lang/python33/Makefile
@@ -27,8 +27,7 @@ CONFIGURE_ARGS+= --enable-shared
CONFIGURE_ENV+= OPT="" # Null out OPT to respect user CFLAGS and remove optimizations
INSTALL_TARGET= altinstall # Don't want cloberring of unprefixed files
-SHAREMODE= 644 # Match upstream INSTALL_DATA=644, so we can STRIP shared libraries
-MAKE_ARGS+= INSTALL_SHARED="${INSTALL_LIB}" # Override read-only for libraries, so we can STRIP them
+MAKE_ARGS+= INSTALL_SHARED="${INSTALL_LIB}" # Strip shared library
MAKE_ARGS+= LIBPC="${PREFIX}/libdata/pkgconfig" # Until pathfix gets support for files other than Makefile.in
PLIST_SUB= ABI=${ABIFLAGS} \
@@ -99,7 +98,6 @@ post-install:
.endif
for i in ${STAGEDIR}${PREFIX}/lib/python3.3/lib-dynload/*.so; do \
${STRIP_CMD} $$i; done # Strip shared extensions
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libpython3.3${ABIFLAGS}.so.1 # Strip shared library
regression-test: build
@cd ${WRKSRC} && ${MAKE} TESTOPTS=-j${MAKE_JOBS_NUMBER} buildbottest
diff --git a/lang/python33/files/patch-Makefile.pre.in b/lang/python33/files/patch-Makefile.pre.in
index b904dbaaa3f6..1c2bfa4c4ade 100644
--- a/lang/python33/files/patch-Makefile.pre.in
+++ b/lang/python33/files/patch-Makefile.pre.in
@@ -4,10 +4,6 @@
# Submitted by: koobs (r326729)
# TODO: Upstream
-# Description: Run ranlib before installing the library read-only
-# Submitted by: antoine@ (r350207)
-# TODO: Upstream
-
# Description: Create symlinks for non-ABI-suffixed python*-config and ABI-suffixed python-*.pc
# Submitted by: antoine@ (r358029)
# TODO: Upstream
@@ -96,16 +92,6 @@
-rm -f $(DESTDIR)$(BINDIR)/python3-config
(cd $(DESTDIR)$(BINDIR); $(LN) -s python$(VERSION)-config python3-config)
-rm -f $(DESTDIR)$(LIBPC)/python3.pc
-@@ -1205,8 +1199,8 @@
- if test "$(SHLIB_SUFFIX)" = .dll; then \
- $(INSTALL_DATA) $(LDLIBRARY) $(DESTDIR)$(LIBPL) ; \
- else \
-+ $(RANLIB) $(LIBRARY) ; \
- $(INSTALL_DATA) $(LIBRARY) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
-- $(RANLIB) $(DESTDIR)$(LIBPL)/$(LIBRARY) ; \
- fi; \
- else \
- echo Skip install of $(LIBRARY) - use make frameworkinstall; \
@@ -1223,6 +1217,12 @@
$(INSTALL_SCRIPT) $(srcdir)/Modules/makesetup $(DESTDIR)$(LIBPL)/makesetup
$(INSTALL_SCRIPT) $(srcdir)/install-sh $(DESTDIR)$(LIBPL)/install-sh