aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby32/files/patch-configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'lang/ruby32/files/patch-configure.ac')
-rw-r--r--lang/ruby32/files/patch-configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/lang/ruby32/files/patch-configure.ac b/lang/ruby32/files/patch-configure.ac
new file mode 100644
index 000000000000..170a9f3a9fe8
--- /dev/null
+++ b/lang/ruby32/files/patch-configure.ac
@@ -0,0 +1,19 @@
+--- configure.ac.orig 2018-12-28 12:03:09 UTC
++++ configure.ac
+@@ -2678,7 +2678,7 @@ AS_IF([test "$with_dln_a_out" != yes], [
+ : ${LDSHARED='$(CC) -shared'}
+ AS_IF([test "$rb_cv_binary_elf" = yes], [
+ LDFLAGS="$LDFLAGS -rdynamic"
+- DLDFLAGS="$DLDFLAGS "'-Wl,-soname,$@'
++ DLDFLAGS="$DLDFLAGS "'-Wl,-E'
+ ], [
+ test "$GCC" = yes && test "$rb_cv_prog_gnu_ld" = yes || LDSHARED='$(LD) -Bshareable'
+ ])
+@@ -3163,6 +3163,7 @@ AS_CASE("$enable_shared", [yes], [
+ [freebsd*|dragonfly*], [
+ LIBRUBY_SO='lib$(RUBY_SO_NAME).$(SOEXT).$(MAJOR)$(MINOR)'
+ LIBRUBY_SONAME='$(LIBRUBY_SO)'
++ RUBY_APPEND_OPTIONS(LIBRUBY_DLDFLAGS, ['-Wl,-soname,${LIBRUBY_SO}'])
+ AS_IF([test "$rb_cv_binary_elf" != "yes" ], [
+ LIBRUBY_SO="$LIBRUBY_SO.\$(TEENY)"
+ LIBRUBY_ALIASES=''