aboutsummaryrefslogtreecommitdiff
path: root/mail/bogofilter-sqlite
diff options
context:
space:
mode:
Diffstat (limited to 'mail/bogofilter-sqlite')
-rw-r--r--mail/bogofilter-sqlite/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/mail/bogofilter-sqlite/Makefile b/mail/bogofilter-sqlite/Makefile
new file mode 100644
index 000000000000..99e160676745
--- /dev/null
+++ b/mail/bogofilter-sqlite/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: bogofilter-sqlite
+# Date created: 2005-05-24
+# Whom: Matthias Andree <matthias.andree@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bogofilter
+PORTREVISION= 0
+CATEGORIES= mail
+PKGNAMESUFFIX= -sqlite
+
+MAINTAINER= matthias.andree@gmx.de
+
+LIB_DEPENDS= sqlite3.8:${PORTSDIR}/databases/sqlite3
+
+CONFLICTS= bogofilter-[0-9]* bogofilter-qdbm-[0-9]* bogofilter-tdb-[0-9]* \
+ [a-z][a-z]-bogofilter-[0-9]* bogofilter-current-[0-9]*
+
+CONFIGURE_ARGS= --with-database=sqlite
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+DESCR= ${PKGDIR}/pkg-descr
+
+MASTERDIR= ${.CURDIR}/../bogofilter
+
+.include "${MASTERDIR}/Makefile"