aboutsummaryrefslogtreecommitdiff
path: root/mail/cmail/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/cmail/Makefile')
-rw-r--r--mail/cmail/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/mail/cmail/Makefile b/mail/cmail/Makefile
index 491694965cac..e0d0179493ed 100644
--- a/mail/cmail/Makefile
+++ b/mail/cmail/Makefile
@@ -6,20 +6,28 @@
#
PORTNAME= cmail
-PORTVERSION= 3.1
+PORTVERSION= 4.01
CATEGORIES= mail
MASTER_SITES= ftp://ftp.eboai.org/pub/users/chip/
-EXTRACT_SUFX= .tar.bz2
MAINTAINER= chip@chocobo.cx
-USE_BZIP2= yes
+RUN_DEPENDS= ${SITE_PERL}/Term/ANSIColor.pm:${PORTSDIR}/devel/p5-Term-ANSIColor
+USE_BZIP2= yes
PERL_CONFIGURE= yes
MAN1= cmail.1
+DOCS= LICENSE README
post-install:
- ${INSTALL_MAN} ${WRKSRC}/cmailrc.sample ${PREFIX}/share/examples/cmailrc.sample
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/cmail.rc ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
.include <bsd.port.mk>