aboutsummaryrefslogtreecommitdiff
path: root/mail/imap-uw/files/patch-ab
diff options
context:
space:
mode:
Diffstat (limited to 'mail/imap-uw/files/patch-ab')
-rw-r--r--mail/imap-uw/files/patch-ab29
1 files changed, 15 insertions, 14 deletions
diff --git a/mail/imap-uw/files/patch-ab b/mail/imap-uw/files/patch-ab
index 43d26fb58aef..6de8fc321668 100644
--- a/mail/imap-uw/files/patch-ab
+++ b/mail/imap-uw/files/patch-ab
@@ -1,15 +1,16 @@
---- src/osdep/unix/Makefile.orig Wed Apr 11 00:02:06 2001
-+++ src/osdep/unix/Makefile Sat Apr 14 03:20:57 2001
-@@ -28,12 +28,12 @@
+--- src/osdep/unix/Makefile.orig Fri Apr 30 02:08:48 2004
++++ src/osdep/unix/Makefile Fri Jun 4 07:34:19 2004
+@@ -29,13 +29,13 @@
# Extended flags needed for SSL. You may need to modify.
-SSLDIR=/usr/local/ssl
-SSLCERTS=$(SSLDIR)/certs
--SSLINCLUDE=$(SSLDIR)/include
--SSLLIB=$(SSLDIR)/lib
+SSLDIR=$(OPENSSLBASE)
+SSLCERTS=$(PREFIX)/certs
+ SSLKEYS=$(SSLCERTS)
+-SSLINCLUDE=$(SSLDIR)/include
+-SSLLIB=$(SSLDIR)/lib
+SSLINCLUDE=$(OPENSSLINC)
+SSLLIB=$(OPENSSLLIB)
@@ -18,16 +19,16 @@
# Older versions of MIT Kerberos also have a libcrypto. If so, you may need
# to use this instead
-@@ -46,7 +46,7 @@
+@@ -48,7 +48,7 @@
SSLCFLAGS= -I$(SSLINCLUDE) -I$(SSLINCLUDE)/openssl\
- -DSSL_CERT_DIRECTORY=\"$(SSLCERTS)\"
+ -DSSL_CERT_DIRECTORY=\"$(SSLCERTS)\" -DSSL_KEY_DIRECTORY=\"$(SSLKEYS)\"
-SSLLDFLAGS= -L$(SSLLIB) -lssl $(SSLCRYPTO) $(SSLRSA)
+SSLLDFLAGS= # -L$(SSLLIB) -lssl $(SSLCRYPTO) $(SSLRSA)
# Extended flags needed for non-standard passwd types. You may need to modify.
-@@ -60,7 +60,7 @@
+@@ -62,7 +62,7 @@
# AFSLDFLAGS may also need -L/usr/ucblib -lucb
DCECFLAGS= -DDCE_MINIMAL -DPASSWD_OVERRIDE=\"/opt/pop3/passwd/passwd\"
DCELDFLAGS= -ldce
@@ -36,7 +37,7 @@
# Build parameters normally set by the individual port
-@@ -97,7 +97,7 @@
+@@ -99,7 +99,7 @@
# Commands possibly overriden by the individual port
ARRC=ar rc
@@ -45,16 +46,16 @@
LN=ln -s
RANLIB=ranlib
-@@ -115,7 +115,7 @@
+@@ -117,7 +117,7 @@
dummy.o pseudo.o netmsg.o flstring.o fdstring.o \
rfc822.o nntp.o smtp.o imap4r1.o pop3.o \
- unix.o mbox.o mbx.o mmdf.o tenex.o mtx.o news.o phile.o mh.o mx.o
+ unix.o mbx.o mmdf.o tenex.o mtx.o news.o phile.o mh.o mx.o
-CFLAGS=-g
+CFLAGS+=$(BASECFLAGS) $(EXTRACFLAGS)
CAT=cat
MAKE=make
-@@ -198,6 +198,15 @@
+@@ -200,6 +200,15 @@
BASECFLAGS="-g -B/usr/lib/big/ -Dvoid=char -Dconst=" \
RANLIB=true ARRC="ar -rc"
@@ -70,7 +71,7 @@
bs3: # BSD/i386 3.0 or higher
$(BUILD) `$(CAT) SPECIALS` OS=bsi \
CHECKPW=bsi LOGINPW=bsi CRXTYPE=nfs \
-@@ -217,8 +226,9 @@
+@@ -219,8 +228,9 @@
SPOOLDIR=/var \
ACTIVEFILE=/usr/local/news/lib/active \
RSHPATH=/usr/bin/rsh \
@@ -82,7 +83,7 @@
bsi: # BSD/i386
$(BUILD) `$(CAT) SPECIALS` OS=$@ \
-@@ -764,7 +774,7 @@
+@@ -788,7 +798,7 @@
build: clean once $(ARCHIVE)