aboutsummaryrefslogtreecommitdiff
path: root/mail/mailman
diff options
context:
space:
mode:
Diffstat (limited to 'mail/mailman')
-rw-r--r--mail/mailman/Makefile11
-rw-r--r--mail/mailman/files/extra-patch-mailpasswds22
2 files changed, 30 insertions, 3 deletions
diff --git a/mail/mailman/Makefile b/mail/mailman/Makefile
index d2f00201b5c1..575e9ffabcb7 100644
--- a/mail/mailman/Makefile
+++ b/mail/mailman/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mailman
DISTVERSION= 2.1.29
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail
MASTER_SITES= GNU \
SF/${PORTNAME}/Mailman%202.1%20%28stable%29/${PORTVERSION} \
@@ -71,8 +71,8 @@ PORTDOCS= ACKNOWLEDGMENTS BUGS FAQ INSTALL NEWS README README-I18N.en \
OPTIONS_SINGLE= MTA
OPTIONS_SINGLE_MTA= COURIER EXIM4 OPENSMTPD POSTFIX SENDMAIL
-OPTIONS_DEFINE= HTDIG NAMAZU2 NLS DOCS
-OPTIONS_DEFAULT= SENDMAIL
+OPTIONS_DEFINE= HTDIG NAMAZU2 NOMAILPWD NLS DOCS
+OPTIONS_DEFAULT= SENDMAIL NOMAILPWD
COURIER_DESC= for use with courier
EXIM4_DESC= for use with exim4
OPENSMTPD_DESC= for use with opensmtpd - EXPERIMENTAL -
@@ -80,6 +80,7 @@ POSTFIX_DESC= for use with postfix
SENDMAIL_DESC= for use with sendmail
HTDIG_DESC= - EXPERIMENTAL - htdig integration patches
NAMAZU2_DESC= Make private archives searchable with namazu2
+NOMAILPWD_DESC= Elide plaintext passwords from monthly reminders
MTA_DESC= Integrate with which MTA?
.include <bsd.port.options.mk>
@@ -142,6 +143,10 @@ RUN_DEPENDS+= mknmz:databases/namazu2
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-Mailman-Cgi-private.py
.endif
+.if ${PORT_OPTIONS:MNOMAILPWD}
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-mailpasswds
+.endif
+
BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}dnspython>=0:dns/py-dnspython@${PY_FLAVOR}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}dnspython>=0:dns/py-dnspython@${PY_FLAVOR}
diff --git a/mail/mailman/files/extra-patch-mailpasswds b/mail/mailman/files/extra-patch-mailpasswds
new file mode 100644
index 000000000000..4c1350c0a9dc
--- /dev/null
+++ b/mail/mailman/files/extra-patch-mailpasswds
@@ -0,0 +1,22 @@
+--- cron/mailpasswds.orig 2018-07-25 00:01:28.000000000 +0200
++++ cron/mailpasswds 2018-10-03 11:00:40.137699000 +0200
+@@ -148,17 +148,8 @@
+ if mlist.getMemberOption(member,
+ mm_cfg.SuppressPasswordReminder):
+ continue
+- # Group by the lower-cased address, since Mailman always
+- # treates person@dom.ain the same as PERSON@dom.ain.
+- try:
+- password = mlist.getMemberPassword(member)
+- except Errors.NotAMemberError:
+- # Here's a member with no passwords, which I think was
+- # possible in older versions of Mailman. Log this and
+- # move on.
+- syslog('error', 'password-less member %s for list %s',
+- member, mlist.internal_name())
+- continue
++ # https://mail.python.org/pipermail/mailman-users/2016-April/080746.html
++ password = '****'
+ optionsurl = mlist.GetOptionsURL(member)
+ lang = mlist.getMemberLanguage(member)
+ info = (listaddr, password, optionsurl, lang)