aboutsummaryrefslogtreecommitdiff
path: root/mail/mutt-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/mutt-devel/Makefile')
-rw-r--r--mail/mutt-devel/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index b13862a41b03..bb7846894a56 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -104,6 +104,9 @@
# If you want to enable the assumed_charset option define:
# WITH_MUTT_ASSUMED_CHARSET_PATCH
#
+# If you want to enable the `greeting' option define:
+# WITH_MUTT_GREETING_PATCH
+#
PORTNAME= mutt-devel
PORTVERSION= 1.5.13
@@ -203,6 +206,11 @@ IGNORE= cannot install: the WITH_MUTT_SIDEBAR_PATCH and WITH_MUTT_NNTP are not c
IGNORE= cannot install: the WITH_MUTT_ASSUMED_CHARSET_PATCH and WITH_MUTT_NNTP are not compatible
.endif
.endif
+.if defined(WITH_MUTT_GREETING_PATCH)
+.if defined(WITH_MUTT_NNTP)
+IGNORE= cannot install: the WITH_MUTT_GREETING_PATCH and WITH_MUTT_NNTP are not compatible
+.endif
+.endif
.if defined (MUTT_LITE)
WITHOUT_MUTT_XML= yes
@@ -339,6 +347,11 @@ post-patch::
@${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-reverse_reply
.endif
+.if defined(WITH_MUTT_GREETING_PATCH)
+post-patch::
+ @${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-greeting
+.endif
+
.if defined(WITHOUT_MUTT_FLOCK)
CONFIGURE_ARGS+= --disable-flock
.else