aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-Mail-DKIM/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/p5-Mail-DKIM/Makefile')
-rw-r--r--mail/p5-Mail-DKIM/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/mail/p5-Mail-DKIM/Makefile b/mail/p5-Mail-DKIM/Makefile
index f77cc05e8e40..d31301e3bd04 100644
--- a/mail/p5-Mail-DKIM/Makefile
+++ b/mail/p5-Mail-DKIM/Makefile
@@ -15,7 +15,6 @@ MAINTAINER= yanagisawa@csg.is.titech.ac.jp
COMMENT= Perl5 module to process and/or create DKIM email
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Crypt/OpenSSL/RSA.pm:${PORTSDIR}/security/p5-Crypt-OpenSSL-RSA \
- ${SITE_PERL}/${PERL_ARCH}/Digest/SHA.pm:${PORTSDIR}/security/p5-Digest-SHA \
${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS \
${SITE_PERL}/Mail/Address.pm:${PORTSDIR}/mail/p5-Mail-Tools
BUILD_DEPENDS= ${RUN_DEPENDS}
@@ -44,4 +43,11 @@ MAN3= Mail::DKIM.3 \
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/scripts/dkim*.pl ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501000
+RUN_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA
+BUILD_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA
+.endif
+
+.include <bsd.port.post.mk>