aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-Mail-Verify
diff options
context:
space:
mode:
Diffstat (limited to 'mail/p5-Mail-Verify')
-rw-r--r--mail/p5-Mail-Verify/Makefile28
-rw-r--r--mail/p5-Mail-Verify/distinfo1
-rw-r--r--mail/p5-Mail-Verify/pkg-comment1
-rw-r--r--mail/p5-Mail-Verify/pkg-descr12
-rw-r--r--mail/p5-Mail-Verify/pkg-plist5
5 files changed, 47 insertions, 0 deletions
diff --git a/mail/p5-Mail-Verify/Makefile b/mail/p5-Mail-Verify/Makefile
new file mode 100644
index 000000000000..eae332a38ff2
--- /dev/null
+++ b/mail/p5-Mail-Verify/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Mail-Verify
+# Date created: 2 August 2001
+# Whom: Pete Fritchman <petef@databits.net >
+#
+# $FreeBSD$
+#
+
+PORTNAME= Mail-Verify
+PORTVERSION= 0.01
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Mail
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= petef@databits.net
+
+BUILD_DEPENDS= ${SITE_PERL}/Net/DNS.pm:${PORTSDIR}/net/p5-Net-DNS
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Mail::Verify.3
+
+.include <bsd.port.mk>
diff --git a/mail/p5-Mail-Verify/distinfo b/mail/p5-Mail-Verify/distinfo
new file mode 100644
index 000000000000..82906de36a49
--- /dev/null
+++ b/mail/p5-Mail-Verify/distinfo
@@ -0,0 +1 @@
+MD5 (Mail-Verify-0.01.tar.gz) = 66c9e4f5cb7667370411dd04a7c81125
diff --git a/mail/p5-Mail-Verify/pkg-comment b/mail/p5-Mail-Verify/pkg-comment
new file mode 100644
index 000000000000..10a5f9710d7c
--- /dev/null
+++ b/mail/p5-Mail-Verify/pkg-comment
@@ -0,0 +1 @@
+Perl module to verify email addresses
diff --git a/mail/p5-Mail-Verify/pkg-descr b/mail/p5-Mail-Verify/pkg-descr
new file mode 100644
index 000000000000..f2173cdd57f6
--- /dev/null
+++ b/mail/p5-Mail-Verify/pkg-descr
@@ -0,0 +1,12 @@
+Mail::Verify provides a function CheckAddress function for verifying
+email addresses. First the syntax of the email address is checked,
+then it verifies that there is at least one valid MX server accepting
+email for the domain. Using the Net::DNS module and the IO::Socket
+module a list of MX records (or, falling back on a hosts A record)
+are checked to make sure at least one SMTP server is accepting
+connections.
+
+WWW: http://search.cpan.org/search?dist=Mail-Verify
+
+- Pete
+petef@databits.net
diff --git a/mail/p5-Mail-Verify/pkg-plist b/mail/p5-Mail-Verify/pkg-plist
new file mode 100644
index 000000000000..93316c1916b0
--- /dev/null
+++ b/mail/p5-Mail-Verify/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/Mail/Verify.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Mail/Verify/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Mail/Verify
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Mail 2>/dev/null || true 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Mail 2>/dev/null || true